Showing results for 
Search instead for 
Did you mean: 


Adept II

2700X + Asus Prime X470-Pro => random and weird black screen

I built a new PC as below config last month and it started my nightmare.

The PC randomly black screen in low CPU usage and NO related errors in event views (it only shows "power off unexpected", "dump fail" etc.).

At the beginning, I thought it was caused by overclock. I disabled all overclock options in bios and win10, even Cool & Quiet, set performance bias to None or Auto. I used aida64, OCCT, Furmark, memtest, Fritz Chess, etc. to test for hours and days, NO black screen.

But when I start to use it with low workload (internet browsing, listening music, downloading, etc.) daily, it occurred black screen again.

Sometimes several times in one hour, sometimes one or two times in days.

And when the black screen occurs, I can PING that PC successfully and read the files/folders shared by that PC from another laptop/pc; it seems I can't remote desktop to that PC when black screen. Keyboard, mouse is dead (Caps Lock light didn't on / off when you press); no signal to TV or monitor, CPU fans and VGA, motherboard, chassis fans work as normal.

I can't reset the PC by press the RESET on chassis (it works when PC working normally), I only can press the POWER button for 3 seconds to power off the PC. And after I re-power on the PC, sometimes it ask you to enter BIOS.

I almost try to change every settings in the BIOS to test, I didn't install AI Suite, any RGB software on my PC, no start HW monitoring tools.Tried ultimate power plan, ryzen power plan, performance power plan, no timers for sleep...... I try to set everything I could figure out. Sometimes I even believe I fixed it after using it without black screen for day, then it black screen again.

The video card is from my another PC. It works well on that one for years. Memory is tested on other PC, no issue.

I've RMAed the RAM.

And tested them,

if I enable 'virtual memory'/"paging file" in win10 , and start eight HCI memtest (each 2048MB), one of them will find huge amounts of erros, when mentest just starts.

if disable 'virtual memory'/"paging file" in win10, ans start HCI memtest to test as more as they can (around 15GB), no erros , BUT it will black screen sometimes.

use memtest86 test in DOS, no erros.

Shall I RMA the CPU ??? Is it a problem of IMC of ryzen???

My build:

AMD Ryzen 2700x

Prime X470 pro BIOS 4011 / 4008

g.skill f4-3200c16d-16gtzr

AMD R9 370 4G HDMI to TV, DP to monitor

Win 10 Pro x64

21 Replies
Adept II

whatever the mem fre is 3200 or 2133

Big Boss

creatie, please tell me what "problem of IMC" means and how you do this "enable 'virtual memory'/"paging file"" and disable.  I had a similar problem to yours with my 1800X.  It turned out to be bad memory slots and required a MB RMA.  What memory slot(s) are you using?  Try one memory stick in one slot then the next - no stress, just idle.  I would suggest you contact the HCL Memtest people about the "huge amounts of erros".  It is not time to RMA the processor.  Enjoy, John.


IMC Internal memory controller.

Virtual memory is setting in Win 10 System properties -> Advanced -> Performace -> Advanced

I tried B2 & A2 or  B1 & A1. The situations are the same.

Maybe I'm unlucky that one channel (two slots ) of  MB is bad.


creatie, as I stated above, please use one memory stick in A1.  If that works OK try B1 and in turn each of the four slots, one at a time..  In my case both A1 and A2 were bad and using dual channel always failed no matter where they were plugged.  "Maybe I'm unlucky that one channel (two slots ) of  MB is bad." - exactly the problem I had.  Please do a Load UEFI Defaults or a Clear CMOS.  I do not know why you are running without/with a paging file.  W10 has a memory tester: Open Administrator Command Prompt - mdsched.  You will be requested to restart to run it.  Enjoy, John.


I've tried B2 A2 B1 A1 and one by one with one of the two DIMMs. Some show black screen, some will auto restart, some have memtest error.

If all these 4 slots of ASUS MB are bad, I'm totally disappointed at ASUS.

Normally I used my PC without virtual memory since 16GB is enough. When I did mentest, it blacked screen. I though the reason may be I disbabled virtual memory. So I tried to enable it.

There are no errors to use windows memory tester or Memtest86.


I've applied MB RMA. Hope it can fix the problem.


creatie, I doubt you were running without virtual memory using the Page File setting.  I suspect W10 always uses virtual memory and even using that setting,  I doubt it really runs with no page file.  If you are curious, I suggest you search MSDN  and/or MSTechNet.  Good luck with your RMA.  It is a good guess even if you did not run the tests I recommended.  Please let us hear.  Thanks and enjoy, John.


New MB arrived. No more memory test error with virtual memory or black screen when testing memory.

BUT, still have change to get black screen in low workload. OMG

Journeyman III

I have or had the exact same problem same symptoms with similar hardware.

2700X Asus Prime X470 Pro and EVGA 1070ti G-Skill F4-3200C16-8GTZ. I thought it was maybe video card or overclocking. Even under clocking everything didn't stop it.

I have flashed the MB with Asus latest bios released yesterday. Ver. 4018

I have not yet had the issue but I only flashed it maybe 10 hrs ago.


I got my new MB. Tried 4018 bios. And back to 4011. No more memory test error with virtual memory or black screen when testing memory.

BUT, still have change to get black screen in low workload whatever BIOS 4011 or 4018. OMG

I' don't think it's a video card problem. My R9 370 was used on old PC, works well for years. And I stress tested 370 on old MB for hours, no black screen.

Yesterday I tested 370 again, no black screen, and played AC:Origins, no black screen. Only one black screen happened yesterday when Ieft the PC for a minute.

BTW, I don't overclock my 2700X. AND also disable 'core performance boost', PBO, etc. The highest frequency of CPU is limited to 3.7GHz. The temp of CPU is not higher than 70 C.


creatie, what is the Wattage of your power supply?  If not at least 650 Watts, then you need to upgrade - I would use 750 Watts.  Please try one memory card in A1 then A2 and see if you get any failures.  If none try the another card till you have tested all cards/slots.  Good luck and enjoy, John.


EVGA 550w G3. Are you kidding me? 750w for 2700x + R9 370(only ONE  6pin PCIE power connector )? i don't overclock the CPU or GPU or memory.

I tried A1 or A2 or B1 or B2 only before MB RMA. memtest A1:auto restart , other slots:black screen

After MB RMA, no memtest error and black screen.

I tried my VGA card on the old PC. But it's win 7 pro. No black screen as before. Didn't try another slot, since I've got a new MB.

Now black screen just happens in a LOW workload situation.


creatie, what happened on your old MB is no longer relevant.  I had your symptoms on an X370 and it required a MB RMA - bad memory slots.  You need to determine if this is a MB or memory problem or something else.  I am not kidding - 550 W is way too little!  I had 750W on my 1800X - no OC.  Thanks and enjoy, John.


I've RMAed my MB and Memory. Now totally no memtest issue.  I've got BOTH new MB and new memory.  I don't think I get twice buggy MB and memory.

Below is the power cal. and I DON'T OVERCLOCK anything. I even limited  CPU highest freq to 3.7Ghz.



creatie, you have the absolute right to do as you like.  I am trying to help you based on the experience I have had and certainly could be very wrong.  You are welcome to ignore my suggestions.  Have fun and enjoy, John.


Hi creatie

I would have to agree with misterj and recommend a minimum 750w PS.

But, since updating my BIOS I have not had any more issues with black screens under low/idle loads as I was having previously.

Question, did or do you have any hardware monitoring software running when your screen blanks out?

Were you running CPUID HWMonitor or similar software running when the screen blanked out? These are known to cause instability. I know since I updated the BIOS I have not run any hardware monitoring software and I have had zero blank screens, freezing/rebooting. The PC has been up and running continuously since updating the BIOS , almost 7 days straight. This includes gaming (BF4, Quake CH....) nightly. I haven't rebooted or shut down except for the last Windows update.


I think I found the root cause is AMD driver. Still need days to figure out which one.

Journeyman III

I have or had the exact same problem same symptoms with similar hardware.


Tryt to uninstall windwos 10 patcheds, and keep you windows 10 version before 17134.81

uninstall AMD video drivers and chipset drivers. Currently I didn't find which version of drivers works perfectly on my PC. But after uninstall all AMD drivers, no more black screen.


Hey how's this going btw? Still black screen free?

I have this board and cpu and when I first put everything together, I was getting random black screens myself.

First I read that having too many monitoring programs running simultaneously can freak this particular setup out. So only have one, maybe two, monitoring programs (cpuz, Core Temp, Ai Suite, etc) running at any time. This helped reduce my black screens to almost never. But...

Second (and this is what was really causing the problem). I came from a history of Intel builds and, with them, I put memory in A1/B1 slots if using only two sticks. For whatever reason, this board (maybe all AM4X470 boards?) require you to put your RAM into A2/B2 if you're only running two sticks. As soon as I did this, my Gskill Trident Z 3200 actually ran flawlessly at 3200Mhz (using DOCP preset) and so does the rest of the system.

Hope that helps!

Journeyman III

I had this problem too. Helped update the BIOS firmware to version 4602 2019/03/25