cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

zeromaverick
Adept I

2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

I'm in need of some serious help. My boot kit finally came in. I installed the A6. I updated my BIOS. I uninstalled the A6. I installed my 2400G. No display. Everything powers on, but there's no display.

I've tried: one stick of ram in various slots, different ram (from QVL), and even a new 2400G. Nothing. I turn on the PC, and I just get no signal.

Here's what's weird:

If I toss the APU AMD sent me back onto the motherboard, it boots up and brings up the UEFI right away, so it can't be the components or the way I have things set up.

What the hell is going on?

Please help, I'm losing my mind.

0 Likes
1 Solution

Accepted Solutions
zeromaverick
Adept I

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

You're going to think I'm an idiot--because I feel like an idiot--but it was posting the entire time. Turns out, for some reason, my LG TV didn't want to display the PC. At the end of my rope, I hooked the PC up to my 4K Vizio, and the thing came right on. I felt like such a dope.

View solution in original post

0 Likes
7 Replies
kenbee
Journeyman III

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

I had/have a problem with hdmi and had to hook up a monitor to the dvi to see the bios, I tried it on my tv and it worked fine but the monitor(dell SE2717h) would not sync.

0 Likes
zeromaverick
Adept I

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

Damn, my only display options are TVs. But I just don't understand why the AMD A6 worked no problem, but the 2400G with a motherboard BIOS update won't display. I don't know what else to try other than returning everything to Amazon and giving up.

0 Likes
arcticwind
Forerunner

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

Did you clear/reset the CMOS on the motherboard when you switched the CPUs?

If not, install the new CPU, take out the motherboard battery for a few seconds then power the system up.

0 Likes
zeromaverick
Adept I

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

Turn it on with the battery out? I've tried removing the battery, leaving it out for fifteen minutes, clearing the CMOS using the jumper, and nothing's changed.

0 Likes
zeromaverick
Adept I

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

It's just: If the motherboard was bad, then the A6 wouldn't work. If the RAM was bad, then the motherboard wouldn't recognize the RAM in the BIOS. If my original 2400G was borked, then surely the new one I bought yesterday to test would've worked. It's not the HDMI because with the A6 in, it showed the UEFI. So I cannot imagine what it could possibly be, and it's making me feel, like, actually depressed. It's like the universe doesn't want me to have a gaming PC for some reason.

0 Likes
infj
Journeyman III

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

Did you ever find a solution?

0 Likes
zeromaverick
Adept I

Re: 2400G Wont Post After Updating Bios Using AMD's Boot Kit

Jump to solution

You're going to think I'm an idiot--because I feel like an idiot--but it was posting the entire time. Turns out, for some reason, my LG TV didn't want to display the PC. At the end of my rope, I hooked the PC up to my 4K Vizio, and the thing came right on. I felt like such a dope.

View solution in original post

0 Likes