Showing results for 
Search instead for 
Did you mean: 


Journeyman III

1950x to slow for video encoding?

Hi there!

My actual system, what i'm runing for a week now:

Describe your system:

  • GFX
    • Gigabyte Aorus 1080 TI Xtreme
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 Pro 64bit
  • Driver version installed
    • Ryzen Master
  • Display Devices
    • Samsung U28E50, 3840x2160, @60Hz, Mini DP
  • Motherboard + Bios Revision
    • Gigabyte Aorus X399 Gaming 7, BIOS: F3g
    • Ryzen Threadripper 1950x
    • Cooling: Enermax TR4 360
  • Power Supply Unit  Make, Model & Wattage
    • be quiet! Dark Power Pro Platinum 850w
  • RAM
    • 32GB

I recently changed from an Intel i7-5820k (6x3.40GHz) to an 1950x and don't regret it at all!

There are no really issues or problems that can't be solved via the Master Tool, even Games are working fine.

The main use for my new PC is Gaming, Streaming and Video Editing, and the last point really dissapoints me. It dissapoints me so much, that there must be a error the way i use this 32 Thread Beast, otherwise i cannot explain the low FPS-Rates i get while encoding a video.

I searched a lot across the Internet, but no one else seems to have this problem, what is pretty uncommon...

What i do:

- record some gameplay @2560x1440 (60 FPS, mostly) using DxTory with MagicYUV-Codec (near to lossless, huge filesize)

- while encoding i resize the video to 3200x1800 with 60 FPS

- x264 or x265

The Intel-based system used to work with 20-40 FPS, depending on the raw-material.

The new 1950x system barley reaches 20 FPS...this CAN'T be normal!

Tested with:

- TMPGEnc Videoworks 6

- MeGui (AFAIK the fastest x264 build)

- StaxRIP

All Cores are running at 100% while encoding.

If you have ANY hints or ideas, i would really appreciate to hear from you!

If any additional details or screenshots are required, please let me know.



11 Replies



I use several drives:

1 x SSD for Windows and most used Programms

1 x HD (Seagate Barracuda 2 TB) for Storage

2 x HD (Seagate Barracuda 1 TB) in Raid 0 for Recording (yes, i know about the risks, but i need the speed! )


there are some performance issues with windows 10 so wait until redmond manages to fix them

i am on the insider and even there it's not 100% well

Big Boss

ZP, I think most Ryzen BIOS/UEFI codes do a pretty extensive memory test during POST and may mark some offline.  Please run CPU-Z​ and post a screenshot of the memory tab so we can see what channel configuration and memory you are running.  Thanks and enjoy, John.

EDIT; Please open Settings (Win Key i), click Apps, click AMD Software, click Modify (takes a few seconds) and post a screen shot.  Should look like this:AMDsoftware.jpg

0 Likes BIOS i set the Memory to 3200MHz, but GPU-Z tells a different Story:


Wow...the AMD-Software looks way different than your screenshot!

As far as i remember, during the installation of this Software i got some errors saying, that i don't have any AMD or Radeon-Hardware installed.



BTW Hardware Manager has no unidentified Hardware listed.



ZP, the memory speed is fine.  It is showing 1600 MHz, half of your 3200 MHz  (how DDR works).  I wanted to make sure your system was in Quad channel and showing all 32 GB.  I assume the Task Manager shows all 32 GB usable.  Our AMD Software display is quite different due to my having a AMD Radeon video card.  You do need to update your TR Chipset drivers.  I get mine here​.  Unless your MB vendor recommends you get these drivers from them, I strongly recommend you get them from the AMD site.  Seems like MB vendor drivers are always down level.  RAID and Aquantia NIC drivers are different and must be DLed from the MB vendor (at least for ASRock).  Please tell me a little more about your RAID0 and post a screenshot of the RAIDXper2.  Thanks and enjoy, John.

EDIT: If your video editing is dependent on your RAID0, then a HW RAID0 of Samsung SSDs may help.  I am running a RAID0 of two Samsung 960 EVO 250 GB SSDs.  Performance looks like this:



Hi John,

yeah, afterwards i thought it's displayed this way, but good to hear.

Yes, all of the installed Memory is usable in the Task Manager.


I've downloaded the Chipset Drivers directly from AMD and compered them to the one from Gigabyte (my MB-Vendor).

As you mentioned, they where outdated...

After installing them, it looks way more like your screenshot.


I'm not the biggest Fan of onboard RAID-Controllers, so i like to use my DawiControl 600e RAID-Controller. Because of this, there are no Settings available from the onboard Controller.

Using SSDs is a massive boost of Speed, for sure, but i would need at least 2 TB of space. My RAID0 delivers stable 330 MB/s and this is more than enough, even for (nearly) lossless 4K 60 fps Gameplay. But, as far as the Pricing for bigger SSDs will drop, i surely will swap my drives.

Thank you very much for your Help and Support!



You are very welcome, ZP.   It does not seem we have addressed your video editing speed problem.  Did the later drivers help at all?  I am running out of suggestions, but I do not think waiting for W10 to get faster is the answer.  Thanks and enjoy, John.

EDIT: Please run GPU-Z​ and paste the output here - will tell us some info about your video card.  When you are doing your video work what does the CPU & GPU utilization look like?

EDIT again: you might try running PassMark​.  Here's mine:



I can confirm the statements from the threadstarter.

My system:

MSI Gameing Pro Carbon AC

AMD Threadripper 1950x

Kingston Predator 16GB DDR4-3600


AMD GPIO Driver (for Promontory)


AMD I2C Driver

AMD PCI Device Driver

AMD PSP-Driver

AMD SMBus-Driver

My old cpu was a i7-3930k (6c/12t @3.8 GHz). I use vidcoder for encodings and I always use the same settings.

So I took a episode from a series and the old intel managed the work in 1h33m.

The new amd did it in 54m (with the same settings and same source).

If you look at some benchmarks, for example Cinebench R11.5 64bit (Multi-Core), the AMD is nearly 350% faster than my old Intel.

So I thought, the result would be about 30 minutes or so.

So I can fully understand the threadstarter and I dont know, if this can be true ... so much money for only +70% ? ;(


OK, i found out that the 1950x is not the problem, but the encoders ( like handbrake, vidcoder and so on) are.

They all seem to be optimized for 6 / max 8 cores.

I did some testings on weekend und will do some more and post the results here in the next days.

Maybe this can help someone, who things that there is a driver problem or something like that. No, its not


Here are a few results:

The episode, which I encoded is still the same and the configuration of vidcoder too.

3930k (my old cpu) with 12t needs 1h33m

1950x (my new cpu) with 32t needs 0h54m

Thats to slow, so I created a VM with w10, running on my 1950x with w10.

VM (1950x)         with  6t needs 1h37m

VM (1950x)         with  8t needs 1h13m (+2t = +32%)

VM (1950x)         with 12t needs 1h03m (+4t = +15%)

So it is better, to use only (max) 8 threads for a encoder like vidcoder or handbrake.

Handbrake offers a command line interface, so it is possible to run a job with one long commandline limited maybe to 6 threads.

Than start a second commandline with another encoding .. and so on.

Maybe its possible to split a encoding into 3 parts, so first cl starts encoding from 0m to 30m, the second from 30m to 60m, but I dont know, how to merge theese parts again.