Showing results for 
Search instead for 
Did you mean: 


Adept I

OpenCL2.0 : clBuildProgram segment falue


In my application, when host codes execute clBuildProgram() to build kernel, "Unknown executable reference LLVM ERROR" happens.

When I run my codes on platform (Kaveri A10-7850K + ubuntu 15.04 (64-bit) + SDK3.0 + amd-driver-installer-15.20.1046-x86.x86_64), the above fault happens.

But when I run my codes Kaveri A10-7850K + ubuntu 14.10(64-bit) + SDK3.0 + amd-catalyst-omega-14.12, the kernel is executable.

I don't know whether SDK3.0 works well with 15.04 or not.

Then, I run an empty kernel "kernel void insert_kernel(global void *table){}" , segment fault occur on clSetKernelArgSVMPointer().

And when I run the kernel "kernel void insert_kernel(){}", segment fault occurs on clEnqueueNDRangeKernel().

BTW, other samples in SDK work correctly. I'm so confused about what causes these segment faults.

Any help will be appreciated~

0 Kudos
1 Reply

Re: OpenCL2.0 : clBuildProgram segment falue

From your description, its difficult to say what may be the reason behind this problem. During the APP SDK 3.0 beta release, it was not tested on Ubuntu 15.04 (for supported systems, see ), so, I'm not sure whether it'll work on Ubuntu 15.04 or not.

As you said that SDK samples are working fine, so, may I assume that its applicable to both OpenCL 1.2 and OpenCL 2.0 samples?

It would be helpful if you could provide a reproducible test-case such that we can check the issue at our end.


0 Kudos