cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCL

Highlighted
Adept II
Adept II

No GPU device available.

I tried to run the HelloWorld OpenCL example that came with APP SDK v2.8, but it said "No GPU device available. Choose CPU as default device" I have an AMD FirePro W8000 in a workstation running RHEL 6.2. The 9.003.3.3 driver (http://support.amd.com/us/gpudownload/fire/Pages/fire_linux.aspx) would not install. I was only able to install the 8.982.8.1 driver (http://support.amd.com/us/gpudownload/fire/Pages/fire_linux.aspx#2).

0 Kudos
Reply
5 Replies
Highlighted
Grandmaster
Grandmaster

Re: No GPU device available.

Hi stuart,

No need to start another thread with the same issue. I am tracking your previous thread unless you get an answer. It is currently taking me some time to get hold of a W8000 card. I will try more to get hold of the card soon.

EDIT: Original Thread: http://devgurus.amd.com/message/1288658#1288658

Highlighted
Adept II
Adept II

Re: No GPU device available.

I was able to fix the HelloWorld OpenCL issue by changing the platform from platform[0] (Intel Xeon CPU) to platform[1] (AMD FirePro W8000 GPU card). Perhaps AMD APP was not recognizing the CPU as a GPU device since it is an Intel rather than AMD chip. But I still was not able to get 9.003.3.3 driver to recognize the GPU card. Instead I have to use 8.982.8.1 driver. I don't know if there is any penalty for using the older driver, but right now things seem to be running ok on the FirePro W8000 GPU card.

0 Kudos
Reply
Highlighted
Grandmaster
Grandmaster

Re: No GPU device available.

Thanks for the information.


stuart.rogers wrote:



I was able to fix the HelloWorld OpenCL issue by changing the platform from platform[0] (Intel Xeon CPU) to platform[1] (AMD FirePro W8000 GPU card). Perhaps AMD APP was not recognizing the CPU as a GPU device since it is an Intel rather than AMD chip.


I guess you have both Intel and AMD OpenCL installed. But why do you think AMD APP should recognize Intel CPU as a GPU. Intel CPU will be recognized as a CPU only . It is one of the good features of AMD APP as it detects the CPU(any x86 CPU) from other vendors too.

0 Kudos
Reply
Highlighted
Adept II
Adept II

Re: No GPU device available.

Hi ,

i am also seeing the same issue. 

in my case i am able to run the application as root user. but as user i am getting the issue .

please check following thread.

http://devgurus.amd.com/message/1301798#1301798

Thanks.

0 Kudos
Reply
Highlighted
Adept I
Adept I

Re: No GPU device available.

Yes, I had a similar problem. Always use the vendor's platform to be on the safe side

0 Kudos
Reply