cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCL

balu
Journeyman III

Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

I have no idea so I decided to write here. I'm trying to integrate my vs2013 with openc(ati GPU).

I did everything according to this instruction:

1.Instaling Opencl from http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/ version 2.9.1

2.       Setting up the Project

First thing to do is set up an empty VS project by choosing

‘New Project->Visual C++->Win32 Console Application'

Enter a name for the project and choose OK

In the application creation wizard choose ‘Next’

Under ‘Additional options’ check the ‘Empty project’ box and click ‘Finish’

3.       Including OpenCL in the Project

The first step in including OpenCL is to create a C++ file, this enables the configuration options we will need.

Right click on the ‘Source Files’ folder in the solution explorer and select ‘Add-> New Item’

Select C++ File and give the file a name

Click the ‘Add’ button in the bottom right hand corner of the dialog box

Now we are ready to point the project to the include directories for OpenCL

Right click on the project name in the solution explorer and select ‘Properties’

From the ‘Configuration’ drop down box choose ‘All Configurations’

Navigate to ‘Configuration Properties-> C/C++ -> General’

In the ‘Additional Include Directories’ field add the following information

$(AMDAPPSDKROOT)\include

4.       Linking OpenCL

Without closing the dialog box used above:

Choose ‘Linker-> General’

In  the ‘Additional Dependencies’ field enter the following

$(AMDAPPSDKROOT)\lib\x86

  • Still in the ‘Linker’ submenu, select ‘Input’
  • In the ‘Additional Dependencies’ field click on the arrow that appears at the end of the field and choose Edit…
  • In the dialog that appears enter “OpenCL.lib”

But when I run project I see error message like:

Program called project1 stopped


Why?

0 Kudos
Reply
1 Solution

Accepted Solutions
bsp2020
Elite

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

From the requirement page (http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/syst...)

SDK 2.9.1 requires AMD Catalyst™ 14.4 (14.10.1006) I don't know how that relates to the version number you posted. How did you get that version number? I'm beginning to suspect that you may not have the right driver installed. Also, HD5730 is very old and it will only support up to OCL1.1 according to the requirement page... I'd try to get a newer hardware if you are serious about learning OCL programming.

View solution in original post

8 Replies
ravkum
Staff
Staff

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

Hi Balu,

It could be that the exe is not able to find your kernel file. Try debugging the application and see where does it fail. To resolve it, copy the .cl kernel file to the directory containing the exe.

Your project settings look okay to me. But you could verify the settings with one of the APP SDK samples.

Regards,

Ravi

0 Kudos
Reply
balu
Journeyman III

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

Hello. I think the problem is my hardware. In other computer program was run correctly. I try also codeblock and I have status: Process terminated with status -1073741510 (0 minute(s), 2 second(s))

What else can I do ?

0 Kudos
Reply
bsp2020
Elite

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

What graphics card and what version of driver are you using?

Also, what does clinfo report?

balu
Journeyman III

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

GPU switchable: ATi Mobility Radeon HD 5730/ Intel GMA HD

ati driver: 8.733.0.0000

clinfo - try to run but i have Process terminated with status -1073741510 (0 minute(s), 4 second(s))

Maybe the problem is that switchable graphic? I try run that program in Ati GPU and Intel integrated GPU. Result is the same...

0 Kudos
Reply
bsp2020
Elite

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

From the requirement page (http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/syst...)

SDK 2.9.1 requires AMD Catalyst™ 14.4 (14.10.1006) I don't know how that relates to the version number you posted. How did you get that version number? I'm beginning to suspect that you may not have the right driver installed. Also, HD5730 is very old and it will only support up to OCL1.1 according to the requirement page... I'd try to get a newer hardware if you are serious about learning OCL programming.

View solution in original post

balu
Journeyman III

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

My version of catalyst is 2009. I try to update the driver.

0 Kudos
Reply
balu
Journeyman III

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

k1Dn6Of.png

0 Kudos
Reply
balu
Journeyman III

Re: Integrating Visual studio 2013 with OpenCL and ATI GPU

Jump to solution

I tried to install the driver , who showed me but it does not detect my GPU. It seems that I have too old hardware to OCL . Thanks for your response.

0 Kudos
Reply