cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCL

mjmdavis
Journeyman III

gpu not detected

Jump to solution

I am having some issues getting my AMD gpu to come up.


$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon R9 200 Series
OpenGL version string: 4.4.12874 Compatibility Profile Context 14.10.1006



$ clinfo | grep -i 'device type'
  Device Type:                     CL_DEVICE_TYPE_CPU



$ ls /dev/ati/
card0


I'm not sure what's going on. I did a locate for libOpenCL.so:


$ locate libOpenCL.so
/opt/AMD/CodeXL_1.4.5728/spies/libOpenCL.so
/opt/AMD/CodeXL_1.4.5728/spies/libOpenCL.so.1
/opt/AMDAPP/lib/x86/libOpenCL.so
/opt/AMDAPP/lib/x86/libOpenCL.so.1
/opt/AMDAPP/lib/x86_64/libOpenCL.so
/opt/AMDAPP/lib/x86_64/libOpenCL.so.1
/usr/lib/libOpenCL.so
/usr/lib/libOpenCL.so.1
/usr/lib/i386-linux-gnu/libOpenCL.so.1


As far as I understand, libOpenCL.so is provided by khronos so it shouldn't matter which one is linked..

Does anyone have any ideas?

0 Likes
Reply
1 Solution

Accepted Solutions
mjmdavis
Journeyman III

Re: gpu not detected

Jump to solution

It seems that I fixed it by reinstalling AMDAPP. I don't know what the problem was.

View solution in original post

0 Likes
Reply
1 Reply
mjmdavis
Journeyman III

Re: gpu not detected

Jump to solution

It seems that I fixed it by reinstalling AMDAPP. I don't know what the problem was.

View solution in original post

0 Likes
Reply