cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCL

goldenriver
Journeyman III
Journeyman III

confronting a problem with - "no OpenCL SDK installed",

Jump to solution

Hello, Im confronting a problem with - "no OpenCL SDK installed", Im using win7 with ATI Mobility Radeon HD 4330 (Dell) series. I have installed AMD's APP SDK , but doesnt work yet.

Any help is greatly appreciated!!!

[2013-11-27 19:04:18] Started cgminer 3.2.2

[2013-11-27 19:04:18] Error -1001: clGetPlatformsIDs failed (no OpenCL SDK inst

alled?)

[2013-11-27 19:04:18] clDevicesNum returned error, no GPUs usable

[2013-11-27 19:04:19] No devices detected!

[2013-11-27 19:04:19] Waiting for USB hotplug devices or press q to quit

[2013-11-27 19:04:19] Need to specify at least one pool server.

Input server details.

URL:

Tags (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
himanshu_gautam
Grandmaster
Grandmaster

Re: confronting a problem with - "no OpenCL SDK installed",

Jump to solution

1. Make sure that the AMD APP SDK installed properly.

2. Check whether the PATH environmental variable set correctly.

3. Check whether you linked opencl library properly to your program

4. whcih catalyst you are using. Check the proper catalyst version and install.


View solution in original post

0 Kudos
Reply
3 Replies
himanshu_gautam
Grandmaster
Grandmaster

Re: confronting a problem with - "no OpenCL SDK installed",

Jump to solution

1. Make sure that the AMD APP SDK installed properly.

2. Check whether the PATH environmental variable set correctly.

3. Check whether you linked opencl library properly to your program

4. whcih catalyst you are using. Check the proper catalyst version and install.


View solution in original post

0 Kudos
Reply
goldenriver
Journeyman III
Journeyman III

Re: confronting a problem with - "no OpenCL SDK installed",

Jump to solution

thank you for replying. After I  installed the AMD Driver(catalyst), the problem is solved.    

0 Kudos
Reply
himanshu_gautam
Grandmaster
Grandmaster

Re: confronting a problem with - "no OpenCL SDK installed",

Jump to solution


You are always welcome and all the best for your experiments

0 Kudos
Reply