cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCL

fkane
Journeyman III

Catalyst 11.6 and OpenGL interop with floating point textures

My application suddenly went wonky after my system updated to Catalyst 11.6. Specifically I'm using clCreateFromGLTexture2D in order to access a GL_RGBA32F texture as a __write_only image2d_t.

It's hard to describe, but it's basically writing the same value across large, square regions of the texture, whereas before it addressed the texture correctly. It's as though the addressing is off or it's treating it as 8 bit instead of 32 perhaps somewhere under the hood. Worked fine under Catalyst 11.4.

Is this also a known issue being worked on with 11.6, or is there perhaps something specific I should be doing to handle floating point textures that 11.4 was just more tolerant of?

Tags (1)
0 Likes
Reply
2 Replies
fkane
Journeyman III

Catalyst 11.6 and OpenGL interop with floating point textures

Digging into things a bit more, the issue doesn't seem to be with GL interop, but rather with the clAmdFFT library from the APP Math Libraries package. It seems to have somehow lost a bunch of precision when used with Catalyst 11.6.

Anyone else experiencing sudden problems with clAmdFFT with Catalyst 11.6?

 

0 Likes
Reply
fkane
Journeyman III

Catalyst 11.6 and OpenGL interop with floating point textures

Interestingly, updating to the Catalyst 11.6b hotfix cleared this up, if anyone else stumbled across this having similar problems. Guess it was in fact a driver issue and I'm not going crazy after all 🙂

Hope this fix gets deployed more widely soon; I can't release my app to consumers while the latest publicly available drivers have this issue.

 

0 Likes
Reply