Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Why rx 480 doesn't work on old motherboard?

Hello, I have RX 480 and RX 470 both cards working fine on one old PC, but both doesn't work on other PC, the problem is no display after post, or even if use onboard graphics then the device manager don't detect cards. Fans spinning lights on, but no display in any dvi or hdmi ports.

Spec of PC I'm having problems on:

MB Asus P77H55-M,

CPU i5-650 (tried with xeon-x3430 too),

PSU 1000w (same, taken from old PC on which everything works fine),

RAM kingston 4x2gb 1333hz

Updated BIOS to latest version.

If I put old Radeon HD 7770 and older psu PC runs fine everything works, and if I put both RX 480 or RX 470 to other PC and same 1000w psu they work too, so issue is not in hardware i assume.

I think its bios uefi problem, but can't find why its happening because I've seen benchmarks with same setups working fine.

I've tried almost everything with no luck, please help...

0 Replies