cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

ptcrusader
Journeyman III

Why am i unable to use more than 2 Radeon VII

I am building a mining rig with eventually 6 gpus. I just got my 3rd card and tested it and all seems fine. i added it via a riser and turned it on. the system boots up fine and goes through its initialization, but i only get a black screen. so i disconnected it and rebooted. Back to normal. Then i tried different combinations of 2 gpus and it all works perfectly, until i add a 3rd card. Anyone else have an issue similar and what be the reason/solution, please?

ASUS ROG STRIX B450-F GAMING AM4 AMD B450 SATA 6Gb/s ATX AMD Motherboard

Ryzen 5 3600

1600W PSU

2 Replies
elstaci
MVP

Re: Why am i unable to use more than 2 Radeon VII

This YouTube video shows that you can connect, at least, 6 Radeon VII for mining by Red Panda: My 6 x Radeon VII Mining Rig Is COMPLETE! - YouTube 

Below are a series of YouTube showing how Red Panda was able to connect his 6 Radeon VII GPUs for mining. Possibly it may show you how to connect your Radeon VII GPUs for your mining rig:

This YouTube series shows how to set up a Radeon VII Mining rig from above YouTube - Red Panda:

1-Building My 6 x Radeon VII Mining Rig... Part 1 - YouTube 

2- Building My 6 x Radeon VII Mining Rig... Part 2 - YouTube

3-Building My 6 x Radeon VII Mining Rig... Part 3 - YouTube 

4-Building My 6 x Radeon VII Mining Rig... Part 4 CODE 43? - YouTube 

5-Building My 6 x Radeon VII Mining Rig... Part 5 - YouTube 

6-Building My 6 x Radeon VII Mining Rig... Part 6 - YouTube 

7-Building My 6 x RADEON VII Mining Rig... Part 7 - YouTube 

8-Building My 6 x RADEON VII Mining Rig... Part 8 FINALE - YouTube 

elstaci
MVP

Re: Why am i unable to use more than 2 Radeon VII

Watching those YouTube videos seems like you may have a bad Riser or Riser cable or even the Motherboard's slot where the 3rd Riser is connected is defective.

Since you mentioned you tried all 3 GPUs in combinations of twos and they all worked correctly. That indicates the 3rd Riser, cable, or Motherboard slot where the Riser is connected may be defective.

What does Device Manager show when you have all 3 GPUs connected? is it recognized or error code 43 or any other type of error or yellow exclamation points?

What Mining program and OS are you using (Windows or Linux)? 

0 Kudos