cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

corradopolo
Journeyman III

Weird input lag in EVERY game

Hi everyone, i'm having an issue which is making me go crazy:
In every game/app i'm experiencing a slight input delay which makes it unplayable and frustrating. Even if FPS and ping are always ok i can always feel a delay between my mouse/keyboard clicks and the actual movement on display. Everything was working fine like few weeks ago.

Here is what i tried:
-updating graphic drivers
-updating chipset drivers
-changing HDMI cable
-Cleaning the CPU fan (i don't have an external fan but till few days ago everything worked fine so i don't think it could be the problem)
-Resetting router
-Booting with one of the 2 rams
-Checking V-Sync off in my settings ( but i experience this problem even in stupid browser games which doesn't have V-sync, like haxball, for example)
-Enabling Radeon Anti-Lag
-Checking my RAM with Memtest
-Packet-Loss test

These are my specs: 

EU0JspX.png

Monitor: MSI MP241
PSU: be quiet! System Power B9 350W , Model: SB9-350W



What else can i try? Or what could the problem be in your opinion? Thank you!

 

2 Replies
eccentric
Challenger

remove all usb devices use minimal keyboard and mouse in your fastest newest usb ports.

try updating usb drivers.

make a config.ini file or in registry and ensure directtransport or directstorage is enabled.

try if you have a heap of RAM 16GB or higher and a high spec system removing or disabling your pagefile and or hibernation

usb often has say a cheap or old mouse or keyboard plugged in or a old cheap slower usb port and the fake drivers for usb are common generic stuff not made for it. if you have an ASUS board you MUST get the CD that came with the mainboard and check it for SCSI over USB drivers that are special for their usb controller which uses a custom usb chip that actually makes the USB 3 standards function more as intended but cant function without the right driver and the driver isnt available via the internet anywhere. the usb is direct to the system bus and crippling it can limit entire system performance like bus speed/cpu/ram as it has to wait on data from the hdd and as you can literally 'boot from usb' its umm kinda important

clear cmos in your mainboards jumper pins with the power cable unplugged and ensure your bios gets reset to defaults.

try enable PBO and disable XMP.. set your RAM To 1866mhz or 1600mhz low as it can go command rate CR1T and disable geardown mode if its XMP stick of RAM see in the xmp profile what its voltage is and set it to that for with xmp disabled else the higher much faster better performance lower latency 1866mhz wont have enough power to boot. try and set all your CAS and TRD and whatever else secondary timings to something suitable for your system.. basically whatever it can boot on. this may require many clears of the cmos and rebooting and resetting bios. i suggest you contact the RAM vendor or forums or just set it to the generic 1866mhz timings listed in RAM TIMING INFO in the bios all RAM has default timings for generic speeds that arent overclocks if its under 2133mhz.

enable TPM 2.0 and secure boot in bios and windows device security ensure they're working turn on core isolation in windows device security. consider also enabling all exploit protection in windows device security but randomized images ASLR can stop some titles such as read dead redemption 2 from ever launching.. or honkai impact 3rd which is a free game i greatly enjoy.

make a config.ini text file or registry entry SPEED_LIMIT_FALSE and so on. enable freesync in your monitor or display

also LOWER YOUR RESOLUTION.. i game in trillions of resolution at 1080p.. the virtual super resolution and fidelityFXsuperresolution make it so that you can rendertodisplay and use the full panel and game amazingly well in super uber quality at lower resolutions no fake DLSS no upscaling no fake FSR

not even really need RSR.

if you've got an ultra wide load of **bleep** monitor and it isnt 16:9 you need to game in half the height resolution of whatever you want to game in. literally. 2160p? go the one half that number it should read like 1440p for 4k gaming on one of those overpriced abominations of real displays cut in half veritcally.

enabling HDR or auto HDR if your display is lousy or your card isnt one of the best will cripple you performance wise and your HDMI ports HDR and TV/monitor can often only do HDR at 30fps and may be limiting it to like 23hz or 23fps or some terrible low quality setting. disable all HDR in game menus and in windows OS and on your TV and see if it helps. input lag skyrockets with hdr enabled on almost every device. my 444 full ScRGB 12bit or 10bit HDR 120hz 64bit or 256bit or 128bit RGBcolorspace gaming can ONLY be done at 1080p as the bandwidth is sooo very high that my HDMI 2.0b cant handle it.. HDR uses more bandwidth.. 10bit or 12bit does too.. so does FULL RGB. so umm go turn your dials way lower on the resolution .. 1080p means its 720p on an ultra wide load of **bleep** monitor.

try disabling antialiasing?

 

 

0 Likes
popcopone
Adept I

i m here with you corradopolo

same input lag on high end pc. ...and tried everything you tried
 
my pc: 

AMD Ryzen 7 7700X
Noctua NH-D15
ASRock X670E Steel Legend
Corsair Vengeance 32 GB (2 x 16 GB) DDR5-5600 CL36 Memory
Western Digital Black SN850X 1 TB M.2-2280
PowerColor Radeon RX 6600 Fighter 8GB GDDR6
Seasonic Focus GX, 80+ Gold, 850W

did you mange to fix it?

 
 
0 Likes