Showing results for 
Search instead for 
Did you mean: 



Weird driver issues(?) with used RX 580 Nitro+. Windows stuck in loading animation

Got my used RX 580 Nitro+ 8Gb today removed my gtx 770 drivers with DDU, restart, then installed the latest AMD driver and after I restart Windows 10 is stuck with the dot circle animation.

With the 2017 AMD driver that windows auto installs there is no problem. With the drivers from sapphire (6 months old) also no problems.

Things I've tried:

Make sure the latest driver is installed before windows install what it thinks is best.

Put it in the other PCI-e slot and it started (After 5 weird one second tries) then I installed some other programm that restarted the PC which caused the same issue.

Reset windows

My System:

Win 10

Xeon e3-1230 v3

Fatal1ty H87 Performance

RX 580 Nitro+ 8gb (the 1340 boost clock one)

Card bios: 113-1E366CU-S5S


(the 1340 boost clock one)

It just doesnt go up to 1411Mhz

pic attached is the same for both bioses


Another Update

Apparently there is a Nitro+ that doesnt boost and just stays at 1340Mhz

I tried flashing the bios with the 1411Mhz one worked but same problem with newer driver

0 Replies