cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

stephenamd
Journeyman III

Two issues with RX570. Monitor sometimes randomly "turns off" on game load. It also causes Skyrim to "white screen".

I got a new  Sapphire Radeon RX 570 4G Pulse recently and paired it with my system:

Intel i5 8400

Corsair 16 Gb DDR4

Samsung 970 EVO 250Gb

Asus Prime Z370-A LGA 1151 ATX Motherboard

750W Antec PSU

I installed the latest drivers (18.7.1), updated my motherboard flash and updated all of my drivers.

I do not overclock.

The first issue is that the monitor sometimes "turns off" on the game load.  It does not say that it is disconnected, but the power light flashes, as though the computer is off.  I found a few other threads which suggested fiddling with the windows power settings, which may have fixed the problem.

The second issue is much more annoying.  I was playing Skyrim on my old NVidia 750TI card and didn't have any issues.  But since upgrading to the RX570 Skyrim randomly will have the screen go "all white".  When it happens it looks like the white radiates from a point on the screen for half a second before the entire screen is white.  I can still hear the game sounds after this happens and the pc seems responsive to my key presses, but the screen is entirely unresponsive.  Note I'm running this at 4k and with all graphics set to the highest possible.

This has been bugging me so I ran some diagnostics on this issue.

The GPU gets up to 1284 Mhz and stays there for much of the time.  The memory clock sits nicely at 1750Mhz.

The GPU temperature peaks at 74 degrees.  The CPU temperature peaks at 57 degrees.

I did not encounter this issue running the unigine heaven engine benchmark tool for either the DX9, DX11 or OpenGL settings.

Most of the time this occurs it seems to happen when my avatar is hit in game, so I think the issue might have to do with a particular effect that the GPU handles.

I'm at a loss on how to fix this and it's very frustrating.

0 Likes
4 Replies
arcticwind
Forerunner

You are not going to want to hear this but...

Lower the game setting till you get to a point that is stable.

OR, try older driver versions till you find one that is stable. 

0 Likes

mh - in 2016-2017 AMD had problems with 2 screens and playing games + watching videos same time

also had those "white screens" - i think it was fixed in 17.6.2
try this driver pls - and then post your findings at www.amd.com/report

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes

If a new displayport cable doesn't work, I'll try this driver.  Thanks for your help.

I had the exact same problem with the drivers that came with my video card, which were significantly older.  I installed the new drivers with a clean install.

I'm going to try changing the cable.  My old video card used an HDMI cable while this one uses a Displayport cable that I had not tested before.  I got a chance to use my PC for work today and it semi-randomly flashed black, as though it was a signal issue.  Maybe a similar issue while in full screen 3D causes the video card to crash.

The frustrating thing about this is that the problem might not show up for 2h but then might happen five times in a twenty minute period.

It's very frustrating having a new PC which doesn't work as expected.

0 Likes