Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Trouble installing an rx 480 in a Dell XPS 420

I'm at my wits end and hope posting my problem will find a solution. I've recently purchased a new XFX Radeon RX 480 8gb Graphics card and have nothing but problems trying to get my Dell XPS 420 to recognize it. I keep getting the infamous "Windows has stopped this device because it has reported problems. (Code 43)" error. So, its day three, its 11:00 pm, I'm two days away from throwing in the towel and returning the card (which I would hate to do) so please HELP! I've installed it into the only PCIe x16 slot on the computer, which is a 2.0, but I know the RX 480 can step down from 3.0 to 2.0. Here are my system specs.

Dell XPS 420

Intel Core2 Duo CPU E8500 @ 3.16GHz


Windows 10 @ 64 BIT

450W Dell PSU

250GB SanDisk SSD HD

And to help speed things along I tell you what I've already done to date.

1) Completely uninstalled the old drivers with DDU, restarted, updated the BIOS (A07 from dell), restarted, updated Windows 10, restarted, ran SFC and DISM (as per Troubleshooting Common AMD Graphics Driver Installation Problems), disabled my Norton anti-virus and firewall, downloaded the latest drivers (crimson 16.9.1 Sep 13), did a clean install of the drivers, restarted, and still no luck.

2) Rinse and repeat the above steps, but also made sure that the BIOS were reading the PCIe slot (FYI I have no integrated video on the MOBO). Still no joy.

3) I've also tried unplugging the computer from the wall, pushing the power button, and discharging the capacitors to hopefully wipe any old settings...did not work.

I've made sure that I've installed the 6 pin power supply (six different ways from Sunday, even went so far as using a secondary power supply unit to ensure it was getting enough power). Windows can see and detect the display adapter in my device manager, it shows it as "Radeon (TM) RX 480 Graphics", so I know it can see it. Heck, I know its using the default display pass-though on it in order for me to even use the monitor that's plugged into it. I've heard conflicting reports on the RX 480 only being compatible with UEFI/EFI and not legacy BIOS and other reports that it can work with legacy, so I'm not sure if that's the issue. I'm almost positive that this is a software, or deeper hardware issue and hope someone has an answer.

Tags (3)
4 Replies

Re: Trouble installing an rx 480 in a Dell XPS 420

Dollars to donuts it's your 8 year old system not being able to handle the RX 480's power requirements, namely the large amount of power through the motherboard, and your 8 year old Dell power supply (which at 2% max power loss per year due to age puts it at 382w and even then it's not all at 12v) not being able to deliver.

Journeyman III

Re: Trouble installing an rx 480 in a Dell XPS 420

I have the same problem with an Sapphire RX 460 2GB, no 6 pin version. I also have the code 43 problem. Tried reinstalling the drivers, cleaning and reinstalling them.

The thing is that after I reinstalled the latest drivers (16.9.2) without any luck on the RX 460, I plugged in the computer an Asus Strix R9 390 and Windows recongnized the GPU without any problem.

I I believe that this has to do with the drivers, because my PSU in the computer is a Corsair V450. I have Windows 10 x64 installed.

Adept I

Re: Trouble installing an rx 480 in a Dell XPS 420

Here is Solution For Fixing Error Code 43 Messages:

Option #1: Update your drivers automatically (the easy way)

Option #2: Update your drivers manually (the technical way)

Step #1 – Uninstall the current driver:

Step #2 – Locate the correct driver.

Step #3 – Download the driver

Step #4 – Install the new driver on your PC

Step #5 – Reboot your PC

For the details of first option visit Dell Xps 420 Manual.

Adept I

Re: Trouble installing an rx 480 in a Dell XPS 420

The BTX Dells all have an issue with GCN3 and up AMD graphics cards. They don't display the VESA 103 mode the BIOS screen requires.Sometimes F1 will get you past it, but you'll never see your BIOS again with that GPU.

The only work around I've heard of is a 2nd low level PCI or PCIe GPU that CAN display the BIOS and then it will proceed.