Showing results for 
Search instead for 
Did you mean: 


Adept I

thread stuck in device driver

Two days ago buy a procesor r5 3400g. And when start the game "Apex" or "Aion" get Bluescreen thread stuck in device driver. What i need to do ?

9 Replies

It will be helpful to know your computer Specs including Make & Model of your Motherboard, APU, and Windows and AMD Driver versions installed.

Make sure you have the latest Motherboard BIOS & CHIPSET Driver installed from your motherboard's Support download page.

Note: It is important to follow the BIOS update notes at the right side of each BIOS Version for updating the BIOS correctly.

After doing that and you still have BSODs then do following:

Try installing the latest AMD APU Driver and see if that helps from here: 

If you continue to have BSODs try a previous AMD APU Driver and see if that helps with BSODs from here: 

Then use this  basic method to remove and install your AMD APU driver:

Uninstall the current AMD Driver using DDU as per this method:

It could be due to a corrupted AMD Driver installation.

Download free program DDU (Display Driver Uninstaller). Run it in Safe mode with the internet disconnected.

You can also run it in Windows Desktop but then you would need to Reboot the computer for DDU to finish erasing all of  the AMD Driver traces from your computer.

 Once it finishes uninstalling the current AMD Driver in Safe mode and boots back to Windows Desktop, still with the Internet disconnected, delete the AMD Installation folder C:\AMD if it was created before.

Now install the full AMD Drive package you downloaded manually from AMD Download page. Not the express package. Run the package and if it installs correctly again delete C:\AMD folder and reconnect the internet.

This should prevent any conflict when installing the new version from the previous version.

By the way, C:\AMD is always created whenever you run the AMD Driver package

Thanks for answer. My mother board is ASRock > B450M-HDV R4.0   . I installed chipset driver. And installet lattest driver and try driver from windows update video driver. Bios was installed lattest by me 1 day ago . 


I would download the full AMD APU Driver package rather than just have Windows update the driver which could be an older version then the current one now at AMD Download page.


Okey i will try re- install windows from the Microsoft website. Install all driver/shipset download  previous driver AMD , disconect ethernet install this driver. After check this all answer you. Thanks for help. If will need i write again. Good day.


I don't believe you need to reinstall Windows OS.

I first would just try to install the AMD APU driver first before reinstalling Windows unless you have an older version of Windows installed.

Windows must be fully updated via Windows Update excluding Windows Drivers updates.


It dont worked. I try the new driver and the most previos driver. 


I had this same exact issue, I was able to fix it by putting the BIOS to an older version! Please let me know if this works!

Thanks god. It's realy help me ). Thank you man.

This is the way it worked for me, appreciate and good look