cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

MihaiChiciu
Journeyman III

Smart Access Memory Black Screen

Hello,

I have recently build a new PC with Amd Ryzen 5600x and Radeon 6800xt. I managed to install Windows, install the newest BIOS and after trying to allow Smart Access Memory from BIOS according to the official AMD website, I restarted and now the VGA Led stays white on the motherboard and I don't have any signal in my monitors. I tried moving the GPU slot, changing the monitor, the cables, reinstalling the BIOS, trying with HDMI and Display Port and no success. My motherboard is Asus ROG Strix b550-e gaming and I managed to replicated the problem by just trying to enable Smart Access Memory. The same issue occurred with the black screen and no signal out of my graphics card. The solution was not really a solution. I had to refresh the BIOS settings by updating it with BIOS Flashback, but, of course, I do not have SMA active and I woul really like to benefit from this feature.

I have to mention that I have already sent an email to the motherboard manufacturer and is still to be responded.

Is there any solution for this?

12 Replies
Sparkylipper
Journeyman III

Re: Smart Access Memory Black Screen

I'm having the exact same issue, have you gotten any answers yet?

I'm running a 5900, 6800xt & rpg strix b550-f

pokester
MVP

Re: Smart Access Memory Black Screen

This is a new feature that requires a lot of coordination between the components. Not surprising it is having some problems. 

I would report the issue to your motherboard makers support department.

In Radeon Settings there is a Bug Report tool too you can submit the issue or

You can contact AMD support here: https://www.amd.com/en/support/contact-email-form

Good Luck!

0 Kudos
HungryMonk
Journeyman III

Re: Smart Access Memory Black Screen

I have the same problem.I've enabled above 4g decoding and Resizable BAR and now when i start the PC, the screen goes black or in sleep mode.I can't acces Windows nor BIOS.Please help, what can I do...

0 Kudos
Recax
Journeyman III

Re: Smart Access Memory Black Screen

Me too, same problem with a RX6900XT, Ryzen 9 5900x and a Aorus x570 Pro mainboard

0 Kudos
Stuarthanson
Journeyman III

Re: Smart Access Memory Black Screen

Nvme, ssd, or hdd, whatever media you boot from must be gpt format to boot in uefi mode, it won’t detect the gpu on post with resizable bar enabled unless the boot media is uefi.

I had the same issue with my system last month, 5600x msi x570 board and rx6800 gpu 

I used the Samsung migration tool to move the OS from a legacy boot ssd to a uefi boot nvme.2 drive and it fixed the issue, note you can only use the Samsung tool if the destination drive is Samsung 

0 Kudos
Cmdr-ZiN
Adept II

Re: Smart Access Memory Black Screen

I'm also having the same issue.

I have ASUS B550 plus WiFi BIOS v1216 not the latest.
I have a 5800X and a XFX Radeon RX 6900 XT Speedster Merc 319, stock bios.

I set Above 4G Decoding” and “Re-Size BAR Support” to enabled and I got black screens, both display port and HDMI on multiple monitors.

Windows booted, I could tell because my AIDA 64 software running on my keyboard.
Everything was fine except no GFX card detected.

Very similar to how it's crashed before during RDR2 when set to non Vulkan API, it has crash a handful of times and rebooted since I got it.
Upon reboot I got the same results as above, however I just shutdown windows with the power button and turned back on and it was working again.

With enabling “Re-Size BAR Support” I had to pull my entire PC apart to get to the CLRTC BIOS reset pins under the massive GFX card.

This is not a smooth experience at all and I don't know who's at fault AMD, ASUS or XFX. I'm not sure where to start next, I think I'll update my BIOS but I'm not looking forward to this happening again.

If I find a solution I'll let you know.

Edit: I didn't notice the above comment about the UEFI boot drive. I Also don't have UEFI boot, I'm using a legacy boot I've ported over multiple times, it should be GPT. It's a Force MP600 NVME.

I can't believe this is related to UEFI I can't think of a reason why this would be, but I'll definitely try it.

0 Kudos
colesdav
MVP

Re: Smart Access Memory Black Screen

What FPS boost do you get though...

It is all a joke.

0 Kudos
Cmdr-ZiN
Adept II

Re: Smart Access Memory Black Screen

Yeah switching to UEFI Boot loader instead of legacy CSM fixed the issue, crazy this wasn't mentioned as a requirement.

I used MBR2GPT.exe after having to clean up my BOOT folder of invalid entries. I was able to convert my OS drive without any data loss.

Glissov
Journeyman III

Re: Smart Access Memory Black Screen

I had to remove my motherboard battery to reset the bios because after following the official instructions from AMD to enable this smart access memory both my monitors went black and I couldn't even access the bios anymore.