cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

kaxxi
Adept I

Screen freezing / stuttering every few seconds

Hello,

For some time now, I have been having screen lags where the screen would essentially stutter for a few seconds and this would be really annoying. This happens all the time, not just when I'm playing games.  Somehow, I managed to fix it by downloading the 20.4.2 driver and every morning, I would plug out my HDMI cable and plug it back in. That seemed to work. But then my computer occasionally blue-screened with the video error issue and I decided to update my drivers. Once I updated them to 20.7.1, the issue reoccured, and I have no idea what is causing the issue. Any help would really be appreciated.

I have tried many possible solutions such as disabling windows game bar, turning on HDMI support, lowering graphics but I am currently trying to revert my driver back to 20.4.2 and hopefully that will work but I'm not sure. I have also switched from HDMI to displayport but that didn't make a difference.

GPU: ASRock Radeon RX 5700 XT Phantom Gaming D 8G OC

CPU: AMD Ryzen 9 3900X

Motherboard: Asus ROG STRIX B450-F GAMING

RAM: Corsair Vengeance LPX Black DDR4 2 x 8 GB 2666 MHz CAS 16

1 Solution
dk313
Adept I

To give an update on my problem, I was able to fix the VRAM issue by doing a clean reinstall of Windows 10 2004. Originally I had just built a new pc and had installed a clean version of 1909 a few weeks before 2004 had initially released and at the time I didn't have any problems with game performance. But when 2004 did release I didn't receive the update right away and decided "what the heck why don't I just force it". Figured it wouldn't be that much of a problem. I didn't really have problems at first but as I updated my GPU drivers I started to notice I was starting to have stutters and freezing that got progressively worse. It wasn't until just recently that it was starting to get really bad. 

For whatever reason, I think forcing the upgrade in my case (from 1909 t0 2004) when my system wasn't ready was probably the culprit because now with a clean install of 2004 and drivers installed my games are running fast and smooth like they did when I was on 1909. 

Is it possible your problem is software related like my mine was and maybe you need to do a clean reinstallation of Windows?

View solution in original post

0 Likes
10 Replies