cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

puthre
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

Same here with ga-ex58-ud3r rev 1.6 updated to the latest bios.

Also windows 7 is unstable for me.

0 Kudos
hardcoregames_
Big Boss
Big Boss

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

puthre wrote:

Same here with ga-ex58-ud3r rev 1.6 updated to the latest bios.

Also windows 7 is unstable for me.

is windows 10 any better?

0 Kudos
puthre
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

No, windows 10 shows bluescreen on instalation, the same problem that is described in this thread.

0 Kudos
dstdvl
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I have the same problem.

Gigabyte GA-X58A-UD3R rev 1.0 with XFX Radeon Vega RX 64. Driver install ends with BSOD on Windows 10 (system thread exception not handled / atikmdag.sys). I read that some people got RX Vega working with Asus Sabertooth X58 mainboad with legacy BIOS and Windows 10, so looks like it's not a architectural limit.

I can upgrade my system, but why I'm forced to do now?

The reason I choose Vega 64 over 1080ti was to make an economical upgrade and give this system 1 year more life but any system upgrade (motherboard, CPU, DDR4 RAM, a new cooler on certain CPUs)  will cost more than the price difference or the price of a new 1080ti.

Desperately waiting for a fix or a statement so I can plan what to do next.

0 Kudos
aurus
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I tried it with the following Systems:

GA-Z68AP-D3

I7-2600k

and

GA-970-UD3

FX8150

I have the Bluescreen with atikmdag.sys with both system. Does anyone have a solution? It´s more than half a year after the last post.

Thank you!

0 Kudos
daveng
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

The only solution was to replace your motherboard BIOS with UEFI, but I can't see any UEFI available for your motherboards on the Gigabyte website.  I never had any useful response from AMD or Gigabyte about this problem. Sorry, but I think your card cannot work with those two motherboards.

(And my motherboard, which had a beta UEFI, was almost broken by it because the UEFI made the machine get stuck in boot loops every single time I put the computer to sleep or turned it off. Thanks Gigabtye - it's not even the first time I had boot loops which made a machine unusable due to one of their motherboards.)

0 Kudos
hardcoregames_
Big Boss
Big Boss

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

puthre wrote:

No, windows 10 shows bluescreen on instalation, the same problem that is described in this thread.

Try installing the new 1803 and see if the box works with that. Also use drivers on windows update only to see if it is stable.

0 Kudos
aurus
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

Thanks for your quick reply. I think that's a shame. AMD should be able to turn off some features when discovering a non-uefi motherboard. Especially if it works with Win 7.

I have tried the 2 last 10 builds. They behave completely identically.

0 Kudos
slu
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

This is pretty much the current situation - I did the same and used a beta UEFI, which worked fine but totally impacted my system o/c' - so was either a case of

  • Use beta UEFI if it exists with possible side effects.
  • Stick with Windows 7.
  • Change motherboards (which is what i eventually did, and swapped boards with a pal who also had 1155 mobo and uefi natively).

shame really ; (

0 Kudos