cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Journeyman III
Journeyman III

Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I just got my new RX Vega 64 and unfortunately it seems to be faulty.
Before sending it back I would like to share the issue in the official forums.

My system:
GA-Z68X-UD4-B3

2600K (no OC)
Corsair RMi750


I was runnning a Fury X and 2 970's before without any issues.
After my Vega arrived I used DDU for driver deinstallation and was about to install the new RX Vega driver from the offical download page.
When the installer is about to install the AMD display driver and recognized the display my system crashed with Bug Check String "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED" in
atikmdag.sys. I repeated to process a view times and already did a fresh new installation of Windows, always result in bluescree while installing the driver.
I already tried HDMI and Displayport connection and did reset my motherboard to factory defaults.
Apart from that, when I start my computer with "Display Full Screen Logo" from motherboard BIOS, it shows some weird blue/red artifacts instead of the logo..

For me the card seems faulty unfortunately. Do you recommend anything more to try before returning it? I was actually really looking forward to this card and its out of stock at the moment

The Event Viewer tells:
"The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000007e (0xffffffffc0000005, 0xfffff80182ffb401, 0xffff9f811d6ba8f8, 0xffff9f811d6ba130). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: d1cd2e08-6c21-46bf-91cc-713e2d341246."

The bugcheck looks like following:

==================================================

Dump File         : 082017-4296-01.dmp

Crash Time        : 20/08/2017 16:14:05

Bug Check String  : SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Bug Check Code    : 0x1000007e

Parameter 1       : ffffffff`c0000005

Parameter 2       : fffff801`82ffb401

Parameter 3       : ffff9f81`1d6ba8f8

Parameter 4       : ffff9f81`1d6ba130

Caused By Driver  : atikmdag.sys

Caused By Address : atikmdag.sys+f43d4c

File Description  :

Product Name      :

Company           :

File Version      :

Processor         : x64

Crash Address     : atikmdag.sys+16b401

Stack Address 1   :

Stack Address 2   :

Stack Address 3   :

Computer Name     :

Full Path         : C:\Windows\Minidump\082017-4296-01.dmp

Processors Count  : 8

Major Version     : 15

Minor Version     : 15063

Dump File Size    : 788.980

Dump File Time    : 20/08/2017 16:14:44

==================================================

Thanks in advance and have a nice day!

EDIT:
Is is possible that the issue is related to PCI.E 2.0 on my board?

0 Kudos
88 Replies
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I just got my msi vega64, same issue. Bsod when trying to install driver through amds suite, if i get windows to find and install a driver for it, it will also bsod. If i pre install the driver, then put the card in the machine, it will bsod as soon as windows boots loads the driver. Is the card doa or is this an issue with the driver?

0 Kudos
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

What motherboard are you using?

I tested my card yesterday with a PCI-E 3.0 motherboard and the card was running fine.

It seems like a driver issue related to PCI-E 2.0 to me.. Yesterday night new drivers came out, have you already tried them? I will try them on my setup today evening.

0 Kudos
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I have tried the card in 2 machines. Both pcie 2.0. Latest drivers (17.8.1). Same issue in both

0 Kudos
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I have the same issue. Sapphire Vega RX 64 air cooled, trying to run it on an old X58 motherboard with PCIE 2.0 slots. I'm using Windows 10 64-bit as OS.

When trying to install the driver I get BSOD error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED in atikmdag.sys.

I have tried both the Beta 6 drivers and the driver that was released on the 21st. I've also experimented with the VEGA FE edition drivers (won't recognised the card obviously, but I figured it was worth a shot) and the Blockchain optimised drivers (which gave the same error).

Also tested and replaced my system memory, tried different PCIE slots and different PCIE power cables from the PSU.

I'm going to try Windows 7 tonight and if that doesn't work, Ubuntu Linux.

0 Kudos
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I just tried my vega in a pcie 3 machine and have a new issue (bsod as soon as it opens the driver package). I have opened a support ticket with both amd and msi.

0 Kudos
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

Looking forward if you can install the driver on Win7 or Ubuntu. I don't have enough time the next two days unfortunately to test something other another OS.

However, it is almost certainly sure that there is an issue with the driver on Win10 and PCI-E 2.0. This has to fixed by AMD as soon as possible! PCI-E 3.0 is backward-compatible to PCI-E 2.0 in terms of hardware, so Vega cannot force to have a PCI-E 3.0 board..

I want to wait for Coffeelake to upgrade and did not plan to buy anything in prior so I can use my new Vega.. Hopefully some dev and/or AMD support reads this. Is there any other "channel" to tell AMD about?

0 Kudos
Journeyman III
Journeyman III

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I just got the blue screen to. I was looking in Google Map and then my whole screen just went blue. I'm using XFX Vega 64 Air cooled as well (Black). Using the latest Drivers that just got released. I also notice when I'm playing Black Ops 3, the game either crash to desktop.

0 Kudos
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

Could you let us know what their answers are once they reply? Really curious to hear what they have to say.

0 Kudos
Adept I
Adept I

Re: Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

Msi advised me to clean the connector, try the same drivers i told them i tried...and try the card in another machine...*rolls eyes*...im sending the card back to the retailer on monday if some magical driver package that solves our issue isnt released between now and then...I suspect the card is just DOA

0 Kudos