Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 5 1600 - thread maxing out when using video/games

Hi all,

For greater information please visit my thread: Ryzen 5 1600 Microstutter

I have replaced every single component (including the CPU) 3+ times. I have tested the grounding in my home. I have tried 3 PSU's, and will soon test a fourth, but I don't think that's the issue.

I have also tested an RX580, and 4 x Nvidia 1060's (1 x 3GB and 3 x 6GB).

I have tested on fresh installs, over multiple operating systems (Windows 10 and Linux Mint), on multiple disks, with different hardware, different motherboard brands, and different AGESA firmware (different BIOS updates) and yet this still persists.

I am frequently being told that this is not possible, and yet here I am.

The single consistent 'model' is the Ryzen 5 1600.

The official response from Nvidia was:

"Sorry we have not been able to reproduce the stutters. The logs you provided shows stutters from blocking pixel shader compiles, from blocking resource creates, the main app thread going long on some unknown operation. This type of stutter in theory is not caused by the GPU so likely if you were to swap out the GPU, you would still see the issue. I don't think whatever the cause is, that it is an NVIDIA issue."

Please note that I have tried disabling:

  • SMT
  • OpCache
  • Core Performance Boost
  • Cool n Quiet
  • C-States
  • P-States
  • HPET
  • Etc

I've tried overclocks, underclocks, stock.

Is this a known Ryzen issue? Because for this to exist across multiple processors and multiple operating systems, I would assume that there is an issue with the micro code for the processor on particular systems.

For a better idea of what this looks like please see this thread for a minor example that I created, and for additional information: