Showing results for 
Search instead for 
Did you mean: 


Journeyman III

[RX590] GPU usage "crash" in game

Hi guys,

First, here is a summary of my rig :

  • GPU : Radeon RX590 Series
  • CPU : Intel I5-6600k 3.5Ghz
  • OS :Windows 10 64bit (Version 1903)
  • Software : Adrenalin 19.5.2
  • Display : 2 monitors
    • 2560*1440 - 144Hz (primary display, connected to GPU)
    • 1920*1080 - 60Hz (secondary display, connected to the integrated graphic)
  • RAM : 16Gb

( You can find a DxDiag file below my post in the case where you would want more information on my computer.)

So, since some times ago, I started to have a lot of FPS loss in "some" games. it is a weird issue. For example, when I play WoW on really good settings, I have no problems at all, no lag, no stuttering, no FPS drop, nothing. But when I try to play other games (mostly Steam games) my GPU have a lot of trouble to run. In Divinity Original Sin 2, when I try to lauch a spell, my gpu usage tank from 60% to 0-5% and I only get 1 fps. If I cancel or lauch the spell, Everything goes back to normal and the game run. In The Witcher 3, the game is now unplayable, I used to be able to play in Ultra settings with steady 60fps, now the game give me like 10-15fps in the main menu and it stutter a lot while in game with medium-low settings. I tried other games, some runned smoothly with a steady gpu usage, but I noticed that I've lost some fps with other games compared to before this situation. It seems like my GPU has a lot of trouble dealing with animation or rendering, I don't know exactly. My GPU is recent (less than a year old) and was bought from an official retailer so its not a second-hand part.

You can see a video example of Divinity here. You can see that I lose fps with some spells but not others.

This bug started occuring before I installed the 1903 update for windows. My Windows installation is all clean, I re-installed it yesterday and the problem is still there.

I've tried a lot of things, from uninstalling Amd softwares, drivers and installing manually the correct ones. Re-installing steam etc.. But as of today I have no clue from where to even begin searching for a solution. That is why I post here, in hope that you could have some ideas of the cause and maybe some ways of solution ?