cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

defiant11000
Journeyman III

RX580 Screens displaying no signal after startup

I'm using an RX580 on Windows 10, worked fine for the last two years but suddenly about a week ago I've been having issues after startup.

The actual startup screen works fine until the lock screen, when the screens lose signal. Using 3 screens but tried with 1 and still happened. Weirdly, it works in Safe Mode and I can get in about 30% of the time, usually in the morning.

Really weird, but when I managed to get in yesterday I installed the update to the Radeon software and it's still not working.

Appreciate any help.

0 Likes
4 Replies
elstaci
MVP

Re: RX580 Screens displaying no signal after startup

It would help to know your computer Information like Make & Model of your Motherboard, GPU, CPU, and Windows and AMD driver currently installed.

If possible install your GPU card in another compatible PC and see if the same thing occurs.

I would mention to run OCCT GPU Test and GPU MEMTEST to check out your GPU card but if you can't enter regular Windows it might be difficult to stress test your GPU card.

But first I would install a previous AMD Driver and see if that fixes your issue. Could be the latest AMD driver is the problem: https://www.amd.com/en/support/previous-drivers/graphics/radeon-500-series/radeon-rx-500-series/rade...

You can run DDU in Safe Mode and then download a previous AMD driver and install it. If the current AMD Driver is at fault once you uninstall it using DDU and it boots back into Windows Desktop you should have video Output again using Window's Microsoft Basic Display Adapter GPU driver.

Or Restore your PC back to a Restore Point before the problem started either in Safe Mode or Windows Troubleshooting Menu.

0 Likes
Huntnwabits
Adept I

Re: RX580 Screens displaying no signal after startup

I would also make sure you HDMI. or whatever your using is good.

0 Likes
defiant11000
Journeyman III

Re: RX580 Screens displaying no signal after startup

Thank you for the fast reply.

My motherboard is an Asus A68HM-Plus, my GPU is Radeon RX580, CPU is AMD A10-7680K Radeon R7.
Drivers installed for GPU are version 30.0.13025.5005 from 5th October 2021. When I got in yesterday I updated the Radeon software to the latest version, which I believe said was released in early November.
I can't seem to find my Windows version on Safe Mode.

I'll take a look at the drivers and see if I'm up to date and/or which I should install to try and fix this..

0 Likes
elstaci
MVP

Re: RX580 Screens displaying no signal after startup

Okay you have a AMD APU Processor with Integrated Graphics.

Also check in Device Manager for any errors concerning your GPU card or Integrated Graphics.

It is possible the Motherboard is not seeing or recognizing your RX580 and thus reverting to your Integrated Graphics on your processor.

Device Manager will show if your RX580 or Integrated Graphics is being recognized or not.

EDIT: I don't see any processor A10-7680K but I do see a AMD A10-7860K. Is that the processor you have installed?

If it is you can't update to the latest AMD driver for your RX580 since it will be incompatible with your Integrated Graphics.

The last AMD driver for your APU is from 06/2021: https://www.amd.com/en/support/apu/amd-series-processors/amd-a10-series-apu-for-desktops/a10-7860k-r...

That driver should be compatible with both your Integrated and RX GPU card.

Unfortunately, you can't install 2 different AMD driver versions. Thus you are forced to install the 06/2021 AMD driver.

0 Likes