cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

forestdream
Adept I

Re: RX5700 and HDMI sound problem

Sorry to say that this problem come back to my computer.

I hope AMD to solve this problem as soon as possible.

kfir
Adept II

Re: RX5700 and HDMI sound problem

Update: I had to send the LG OLED to the lab -- there were green spots on the screen when it displayed orange or yellow, and luckily it's warranty is still valid -- so got a replacement LG TV for a few weeks.

Running for several days now and seems the problems do not reproduce. Also tries connecting the computer to an old Philips TV im the other room - no issues. Seems the problems exist only when connected to certain TV models. Possibly just the high-end ones, like OLED?

I told the lab that took the TV about the problems with the HDMI input from the computer. They said they will look into it but I doubt they will find anything on the TV's end.

Will update.

0 Likes
pokester
MVP

Re: RX5700 and HDMI sound problem

You can't hope just hope for it to get better. AMD does this all the time. They have several branches of their drivers. One branch fixes problem "A" another problem "B" and another problem "C" Why AMD can't keep a log of what has been fixed and apply the fixed code to whatever branch they are using is beyond me. Report the issue to AMD. Report what version worked and now does not.  https://www.amd.com/en/support/contact-email-form

0 Likes
ajlueke
Grandmaster

Re: RX5700 and HDMI sound problem

That may be an HDMI link problem, depending on how new the TV is.  Newer OLED TVs and even LCD for that matter are HDMI 2.1 compliant, which supports a lot more bandwidth than HDMI 2.0, which is what all current  AMD GPUs support.  Enabling HDMI link assurance in the drivers may help here.

0 Likes
diabbb
Journeyman III

Re: RX5700 and HDMI sound problem

Radeon Software Adrenalin 2020 Edition 20.10.1 Highlights 

Fixed Issues

  • Audio may experience instability when connected through an Audio Video Receiver via HDMI® on Radeon RX 5000 series graphics products.
0 Likes
diabbb
Journeyman III

Re: RX5700 and HDMI sound problem

Not fixed at all for me.

0 Likes
joni_78
Journeyman III

Re: RX5700 and HDMI sound problem

I returned my 5700 XT to store couple of months ago because of the HDMI audio problem. I've still followed if this will get fixed at all. Seems that the bug is fixed on 20.10.1. Can anyone test it?

Also as expected, the driver brings several bug fixes which are listed below:

  • Audio may experience instability when connected through an Audio Video Receiver via HDMI® on Radeon RX 5000 series graphics products.

0 Likes
taurea
Elite

Re: RX5700 and HDMI sound problem

Driver updated to 20.10.1 and testing right now.

11m30s in and I just had 1 single audio drop lasting no longer than a short splitsecond.

I've had it running fine earlier with older drivers too, for a longer period, thinking things were fixed, but then all of the sudden audio would start dropping all over the place all the time, making it a real nightmare listening to.

Since the 11m30s mark just now, I've not had a single audio drop. It seems fine. But hold on. I'll be testing this for a longer period of time, before I'll start using the R-words.

For now, lets just say that I'm hopeful. I'll report back once I have tested a larger samplesize, so to speak.. 

I'm now at 25m in and still only had this one single audio drop. Before I'd have had like a 200-300 drops by now.

@diabbb - What setup are u running, since u report that this is not fixed for you? Like I said, I'll not use the R-word yet and besides this ONE drop I had, it has been running smoothe as an androids be-hind.

0 Likes
diabbb
Journeyman III

Re: RX5700 and HDMI sound problem

taurea‌: I got two displays, a 144hz screen directly connected via DP and an Onkyo AVR that connects to a projector/tv/whatever. I never had 200-300 drops in such a short amount of time like you described. It was always a rare splitsecond drop for me. It hasn't happened in the last 30 minutes or so since I've restarted my AVR. Maybe a Windows Reboot wasn't enough.

I also have to say to say that I don't know if I had this issue in the last few weeks with 20.5.1.

0 Likes
taurea
Elite

Re: RX5700 and HDMI sound problem

Oh yeah, my drops were baaaad, very bad. Some driver versions more so then others for sure. Drops were no longer then maybe 0,2 - 0,3 seconds in lenght before the audio came back, but it was happening ALL the time, like at least once every second to a sec and a half. 

Nightmare .. ! 

Anyways. I hope it continues to work, we'll see. And I hope it continues to work for you too.

0 Likes