cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

hardcoregames_
Big Boss

Re: RX5700 and HDMI sound problem

Sound works on a monitor but televisions have been demonstrated as problematic

0 Kudos
zealotki11er
Miniboss

Re: RX5700 and HDMI sound problem

I know its not a fix but I started using, I don't have the HDMI issues anymore. The sound works fine.

CLUB 3D CAC-1080 Active DisplayPort 1.4 to HDMI 2.0b

 

shendoe
Journeyman III

Re: RX5700 and HDMI sound problem

Had sound problem since april, nothing helped.

But!

I had to replace hdmi cable. Bought 2.0 version. Aaaand the glitch is gone.

Changes i made beside cable replacement:

Set pixel format to 4:2:0 YCbCr / 10 bit

Turned HDCP off on both displays

Both displays work in 1440p and extend mode


Watched two seasons of Dark, played games for several hours. No problem at all.

I kinda scared to experiment with setting since it is all working now 😃

But I hope this info will be helpful to somebody.

0 Kudos
rockovissi
Adept II

Re: RX5700 and HDMI sound problem

That’s so bizarre. I tried using different HDMI cables, all rated at 2.0 or 2.1. I tried DisplayPort to HDMI cables. I tried changing to 4:2:2 YCbCr 10-bit. What did it for me was to stop using a global framerate cap in Rivatuner. Also, waking the PC up from Hibernation apparently gives me the same issues. So doing a reboot and using AMD’s Chill both minimum and maximum set to 60 does well instead of Rivatuner. Except you have to set a profile per game for it to actually work. For some reason the global setting doesn’t.

0 Kudos
shendoe
Journeyman III

Re: RX5700 and HDMI sound problem

Yep. It is bizzare.

I guess there is no solution that works for everybody. You have to suffer for quite a bit and find some combination that works for you. Like DP to HDMI adapter didn't work for me.

Good luck guys. Stay strong 😃

0 Kudos
brianeddy
Adept I

Re: RX5700 and HDMI sound problem

Just in case, if someone needs yet-another-working-for-someone solution: turning ON "Instant Replay" fixes all in-games  problems, and turning "Record Desktop"  ON also fixes all browser/media player/etc problems.  

This is my settings: 

Снимок.PNG

The only thing that slightly bothers me in this solution, is that with HDR turned on "Record Desktop" option draws tiny 2x 2 pixel gray box in top left corner of the screen. Which sometimes can be seen on OLED panels when waching movie. It's also definitely a bug, but I don't think it will ever be fixed. It's kinda hard to explain to customer support why can't I just turn off "Record Desktop" if it bothers me  

0 Kudos
bcakmak
Adept I

Re: RX5700 and HDMI sound problem

Solved in my setup. My Setup is Gigabyte AMD RX 5700 XT which is connected 1x 27 inch MSI PC monitor on DP port, 1x Onkyo AVR Dolby ATMOS (forwarding the video to LG 65 OLED TV and playing the sound on it)  on HDMI port. It was the same problem mentioned here on and off a long time and, Now figured out that the problem appears when FreeSync is ON on the MSI PC monitor and it disappears when FreeSync is off. Please try and confirm if it fixing your problem.

0 Kudos
taurea
Elite

Re: RX5700 and HDMI sound problem

Hi @Bcakmak

As @brianeddy very neatly described it earlier, it is "yet-another-working-for-someone solution".  Unfortunately, not for me, I've already tried that.

0 Kudos
millsguevarra
Journeyman III

Re: RX5700 and HDMI sound problem

Hi guys.  I have the same issue when my pc is connected to my LG C9 Oled TV via hdmi. 

Tried different cables but no luck.  I have an MSI RX 5700 XT Mech OC.

Seems like the latest drivers improved the issue a lot, it's no longer going off every 5 seconds.  Now it's more like minutes.  Hope AMD fixes this issue soon, it's sad having this issue after paying for an expensive GPU.

0 Kudos
vabiris
Journeyman III

Re: RX5700 and HDMI sound problem

After installing Adrenaline Edition 20.8.2, it seems that all sound issues resolved!!! I'll keep checking different games or programs and get back here with any news!