cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

animeangel
Adept I

RX5700 and HDMI sound problem

Ryzen 5 2600x 

msi b450 tomahawk latest bios

kingston predator 3200 cl  16-18-18-36

Windows 10 up to date. 

I connect VGA to AVR via HDMI.

The problem is the sound from RX5700 is not smooth. It often jerky or sometime, the sound disappear.  I need to mute it from taskbar and open again then the sound will come back. But the problem will happen again and again.   

Updated driver cannot solve this problem. 

And my old RX580X do not have this problem. 

Any advice please? 

708 Replies

If you're using HDMI passthrough from GPU to TV from TV arc to receiver then that setting doesn't matter. Your receiver does the processing.

Now if you have 5.1 PC speakers connected directly to your PC then I understand. It would be a good idea to clarify your setup as to the reason this isn't an option for you. That way it won't confuse those who have the standard home theater type setup and cause them to not try a fix that could solve this frustrating AMD issue for them.

0 Likes

Setup is 5700 XT -> HMDI -> Sony AVR1080 -> Speakers. Also via 2x DP I have a LG UltraGear 34GK950F and Dell U2515H.

Perhaps I don't know the correct settings, how would I used HDMI passthrough, I did not see that option before with my setup in the default Windows 10 sound options. I use the option to configure the speakers to 5.1 and then set the format to 24bit 192000Hz (I do see Dolby Atmos there in the dropdown but that needs the app).

In the option to configure the speakers I only get stereo with the Dolby Atmos driver (and the basic driver as well). Since I want full 5.1 and not some "interpolated" result I don't think this is a good solution for me. But it might that I just didn't put the correct settings.

Look for the PCM option for your device. Turn this OFF or ON based on your setup and see if you get the audio signal decoded to your receiver. But your settings on the PC will still show Stereo. Or at least for me because I'm using my LG OLED TV as my display. If you have any more information to share about your setup reply and I will try to help best I can.

Edit: for the most accurate default setup..If you want to use the AMD HD Audio Driver, I also found that it works fine when connected directly to the receiver. So what you could do is connect your GPU via HDMI directly to your receiver and the HDMI port labeled "output" sometimes will be labeled with Arc oe eArc should connected directly to your display. Now you select the input to tune to the receiver and leave it one that input because you'll be switching to your other devices using your receiver's remote. Now select the input using your receiver's remote that you connected your PC to. Now your PC should show up on the display. Now check your audio settings. Also, on players like VLC you'll need to go Tools --> Preferences ---> Audio and looks for HDMI/SPDIF passthrough and from the drop down box set it to Enabled. Now go here and grab some Dolby Demos ---> Dolby Vision UHD 4K Demos | 4K Media  and test your audio output signal. Your receiver should be displaying ATMOS.  That is the method you would use if you need to have the AMD HD driver. I found that the audio drops do not occur when connected directly to the receiver, for me at least. Hopefully that helps with your setup.

I will look into that when I have some time! I want to avoid using (e)Arc, I rather use DP and not have my receiver as intermediary. Its not even an option since HDMI 2.0 does not support 144Hz 3440x1440 without 4:2:0 subsampling.

I'm back to 19.11.3, sure some games crash after a hour of playing or more but I don't have 2 minute wait times or reboots anymore when switching on a monitor or receiver. So I can live with that.

0 Likes

I solved it another way, or at least I think. System has been stable in games with multiple monitors and audio is normal.

I used the 19.11.3 drivers with the 20.3.1 Audio drivers. However, instead of the normal 5.1 speaker setup I now choose Dolby Atmos for Home Theater, this requires you to download the app from the store (you don't need to purchase anything unless you want to use headphones). The good thing about this is that I can configure it to have 5.1 or 7.1 or something else instead of the stereo (which still did not work even with pass-through). This solution works with pass-through for me, my receiver now correctly detects Dolby Atmos, DTS, Dolby Digital, that TrueHD format etc.

This seems to have solved it for me; I will report in if things crash

0 Likes

I just switched from 5.1 to "dolby atmos for home theater" in Windows, without your split driver solution, and so far the sound seems to work without drop outs. I'm on the newest drivers 20.4.1. 

Edit: Nope it didn't 

0 Likes

Do note that on my system after a boot I had to set it again on the Dolby Atmos for Home Theater. If I don't it is stuck on 7.1. So if it was after a reboot that it stopped working check that! I don't have the solution yet for keeping it on Dolby Atmos after a boot .

No problems yesterday while gaming, even multiple screens on and video playing in one of them. Before that I couldn't do that without weird audio drops or screen issues.

Edit:

Nope, unless my config is wrong somewhere it didn't work. Had after 5 hours artifacts and no audio, switching on receiver on/off solves it for a few hours though. It might be better than before but it is hard to tell.

Conclusion, the AMD HDMI driver sucks.

0 Likes

Yea, that works. It's basically the same solution. You're using the Dolby Driver/Software on top of the AMD Driver. This causes direct audio processing to be done by the Dolby driver/receiver before going to the sound system instead of just the AMD and/or Generic audio Driver.

0 Likes

That worked like a charm. No more dropout at all. AMD needs to fix their crappy HDMI drivers.

There is one idea that I use to deal with bad drivers and flakey sound systems, a USB headphone unit is very low cost. The sound is independent so it gets around other problems.

0 Likes

Great! I'm glad I was able to help. I signed up just for this thread. I felt the pain of what was happening and found a fix and wanted to share it for those who it could help. Now I don't have to go back to Nvidia!

P.S. one additional tip. I found that on my Denon 6500H that disabling eco mode helped as well when connecting the GPU directly to the receiver.

0 Likes

I have check your workaround. unfortunately when I try to do bitstream with 5.1 format, the pc send PCM 2 channels to the AVR. In the sound information, it's seems the driver indicate the AVR can not support 5.1 format. I have try using mpcbe + lavfilters.

Bistreaming conf was working well before  

0 Likes
brianeddy
Adept I

It looks like I've found a workaround for missing HDMI audio problem, which works in almost every  game and application I've tried. In fact, there is only one game that still have audio cut-outs, but they are quite rare and the game is quite old itself, but with workaround they are much less frequent. The still-not-properly-working game is Syberia 2 btw. 

So, workaround is quite simple: you need to enable "Instant Replay" function 

pastedImage_1.png

It's in the same place where Metrics Overlay settings are. 

The default capture resolution is the same as game resolution, which can be too much for some games and cause slowdowns and stutters. But lowering duration time and bitrate helps, and overall this feature doesn't seem to be very demanding. With 720p resolution capture, HEVC encoding and bitrate aroung  5 Mb/s I still have locked 60 at 1440p and good thermals with low cooler noise.

And it looks like even VLC media player now works without issues with this fix. 

My idea is that audio cut-outs  somehow depend on gpu or memory utilisation, because in "heavier" titles they are much less frequent. And this is probably why in older games like Syberia issue is still present with this fix  - game can't stress gpu enough even with screen capture, because resolution is only 800*600. 

And it's probably worth noticing that I use 20.3.1 drivers with High Definition Audio Drivers version 10.0.1.6, also PCIe is manually swithced to Gen4 in BIOS. 

Correct me if I'm wrong, but I think that by enabling the instant replay, we raise the GPU load. I don't mean that it's bad, the GPU is meant to work after all. But adding workload to the GPU when not necessary, when watching movies, YouTube or listening to music for example, and making card work all the time for such simple tasks does not look such a  good idea to me. Sure it's a  clever workaround, but AMD really needs to solve this ASAP, their delay on such an important issue is unacceptable.

0 Likes

Yes, it is definitely adding some GPU load. With my current settings (720p capture, 15 sec duration, HEVC and 5 Mb/s bitrate) it's around 1-2% of additional GPU utilisation. I actually run several benchmarks in Metro Exodus (1440p, Ultra) to measure it, and result are 57.1 fps without Instant Replay and 56.3 fps with Instant Replay. Which is a tolerable sacrifice for a working audio IMO  

Metro Exodus is the most gpu-depending game I have installed right now, and I assume it's a representable "worst-case scenario" for Instant Replay. If you have performance issues with this setting being enable, I suggest lowering capture bitrate and resolution. 

And for some reason no other solution, like switching to microsoft drivers or something else worked in my case. The only thing that also works for me is a Metrics Overlay, but it's quite distracting and tend to disappear. So, for some people I hope this will be of use. 

xjmnz
Adept I

These issues have still not been fixed?! Ridiculous. I've settled on using Microsoft audio drivers. Much better but still has intermittent drop outs.

0 Likes

xjmnz wrote:

These issues have still not been fixed?! Ridiculous. I've settled on using Microsoft audio drivers. Much better but still has intermittent drop outs.

I have also run into the intermittent audio drop outs. Even using a USB audio gizmo.

0 Likes

It's because of the AMD HD Audio Driver. Whatever version you have, you have to use another driver or if you use the AMD Driver, you have to get the Dolby software to do the audio processing. See my solution on my previous posts. It works for some people. Also, make sure you don't forget the other steps before using the Dolby driver/software. i.e. connecting your PC directly to the receiver and setting your PCIe slots in the Bios to Gen3 or Gen4. As long as it's not set to "Auto"

0 Likes

I appreciate your help but installing that Dolby driver didn't work for me; I still experienced intermittent cut outs. Additionally, turning Dolby Atmos On/Off within the software sounded exactly the same.

This is plugged into an LG B8 TV.

0 Likes

AMD audio does not handle a USB device which is an independant audio device and it depends on the windows audio

I use the USB sound device to check if there are other problems and I have found there are problems galore

0 Likes
zezba9000
Adept I

Just use external speakers or sound-bar.  Other big issue with these cards is PCE4 hard crashes my PC. (and yes I have a new 300$ ASUS MB designed for PCE4.  AMD GPU's are a joke on Windows (I should boot up in Linux and see if the issue exists with the open source drivers).

0 Likes
seccadcaglayan
Journeyman III

Hello Guys, I am using Ryzen 5 3600 CPU. After I disable PBO and lock Freq. 4.2 GHz audio drops decrease. After that, I enable instant replay from Radeon software and audio drop has gone for good (I guess). Currently, I don't have any problem sound of games and Also watching movies. I hope that 2 method helps you.

0 Likes
maxx84
Adept II

AMD Starts Rolling Out AGESA 1.0.0.5 BIOS Firmware 

  • Updated AMD AGESA ComboAm4PI 1.0.0.5
  • Fix HDMI audio lost issue when use AMD RX570 vga card.

I suppose "AMD RX570" its a typo and they actually meant RX5700.

0 Likes
vash8888
Adept I

Out of curiosity is anyone having these problems with an Intel MB? I'll test the new BIOS as soon as it's available for the B450 Tomahawk (non max)

0 Likes
voodooman
Journeyman III

The problem does not seem to be motherboard related, the problem comes from the graphics card.

0 Likes
tschi
Adept I

Hello,

I have the problem with a RX5600 XT SAPPHIRE PULSE.
Does someone else get the issue with a RX5600 ?

I use the card for HTPC, this issue is a pitty

I made a test yesterday, using reclock for audio renderer it seems there no more issue but it still need to be test during a long period and reclock is only for x86 player and it's not a soluti

0 Likes
rockmong
Adept I

I solved the audio cut out stuttering problem by using an older HDMI driver.
That's version 10.0.1.07.

Included in Radeon ™ Software Adrenalin Edition 18.10.1 

It is located in the package \ drivers \ audio \ hdmi \ WT64A folder.

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-18-10-1

Please overwrite the driver via manual update and restart

i dont know why maybe audio cut out again 

try driver overwrite again restart 

0 Likes

You should report the issue and how you fixed it with the older file to AMD. It may aid them in isolating why the current drivers are an issue. 

Send your results to AMD: https://www.amd.com/en/support/contact-email-form 

0 Likes

Thanks I had report it and add

Im use TV arc with Yamaha sound bar  first time i had same Hdmi audio issue too by using arc Hdmi cable 1.4 (low spec) and TV EDID setting 

I solved problem by an arc Hdmi cable change to 2.0 and TV arc Hdmi port setting EDID 1.4  change to 2.0 ( Each Hdmi port) 

 

Symptoms of equipment and driver problems are the same ( audio cut out )

I hope this helps.

Sorry about my bad English

Unfortunately this didn’t work for me. I’ve had these issues since day one when I got the card in October. Some games it’s fine but mostly it’s not. I originally had Windows in Dolby Atmos for Home Theater and that would make the audio go out indefinitely until you hit mute and then un-mute. Then it would just go out again after a few seconds. It was constant. But if I put Windows in 5.1, the audio cuts in and out constantly. I hate it. I tried downloading those old drivers and only installed the HDMI audio drivers but that didn’t work for me.

n0aimatall
Journeyman III

Hey, I have been able to solve this issue on my PC.

I shared what I did on a different post here in the Community, but wanted to share this with you as well, as it seems this is the biggest post about this issue.

https://community.amd.com/message/2977708?commentID=2977708#comment-2977708

Fingers crossed this works for some of you as well. I´ll update the post once I had time to nail down what exactly made it work.

0 Likes
rockovissi
Adept II

I just installed the latest 20.5.1 drivers and still no fix. They’ve never acknowledged this in any release notes. I have HDMI out from my Sapphire Pulse RX 5700 in to my Home Theater receiver and HDMI on the main output to HDMI on my Samsung Q70R via ARC. I replaced my Sapphire RX 480, this never happened with it. The audio has been cutting out since October when I got the card. Putting it into Dolby Atmos cuts the audio out completely. Setting Windows to 5.1 has the audio cutting in and out. At least it comes back, though it’s constantly in and out. It depends on the game. But I’d prefer to put Windows in Dolby Atmos. When I do that, I have to mute Windows and unmute in order to have sound again but it just repeats and goes out anywhere from 1 to 5 seconds.

0 Likes
rockovissi
Adept II

It seems that driver version 20.4.2 has lessened the issue greatly for me. I put Windows back into Dolby Atmos and the audio no longer cuts out completely. It has skipped a little but not much. I’m hesitant to get the drivers released on 06/10.

Yes, some drivers are better than others. I've tried 20.5.1 and it was horrible. 20.4.1 and 20.4.2 was OK, but no single driver version ever for the Navi cards, has worked perfectly. Every single one of them has this HDMI stuttering issue, some are just worse than others.

If 20.5.1 was the one you thought of using, then just don't. I've tried and it was a complete fail. Audio drops all over the place and I was infuriated within just 5-7 minutes.

Myself, I'm back on 19.12.1 for the moment. That is the one I've had most luck with. Note, HDMI audio stuttering still happens with this version for me too, it's just not as frequent when only watching content over HDMI.

If I want to play a game AND watch a movie or something else at the same time, HDMI-audio still stutters quite frequently, like 10-15 times a minute.

epicfai1z
Adept I

If anyone has this issue i have managed to resolve the problem on my system. In my case it seems to be a driver conflict between the realtek audio drivers and the amd audio drivers.

This is what i have done and now no longer have audio issues.

  1. Open Device Manager
  2. Select "Sound, video and game controllers"
  3. Check to see if "Realtek(R) Audio" driver is present
  4. Right click on "Realtek(R) Audio" and select "Disable"
  5. Once disabled check to see if you have "AMD High Definition Audio Device" driver
  6. Right click on "AMD High Definition Audio Device" and select "Uninstall Device"
  7. In the Uninstall Device popup ensure you check the "Delete the driver software for this device" checkbox
  8. Confirm Uninstall
  9. Once uninstalled right click on "Sound, video and game controllers" and select "Scan for hardware changes"
  10. This will re-install the "AMD High Definition Audio Device" driver
  11. Restart PC
  12. Test audio, things like youtube should no longer cut out as well as games.

Anyone need help let me know but this is what worked in my case.

Thanks for the share. Great when someone finds a work around to AMD's driver issues. Windows is designed to allow many audio sources and therefore drivers. The fact that re-installing the AMD driver works means that their driver had issues installing to begin with, when another audio device is present. Meaning it is an issue with the AMD driver. I would report you findings as you did above to AMD and maybe they can use this knowledge to get the bug fixed:

https://www.amd.com/en/support/contact-email-form 

0 Likes

As a follow up to my original post when you update the drivers with Radeon Software the audio bug may return simple unistall the High Definition Driver and software again in the device manager and then scan and it should be working again. And even if you disable Realtec in BIOS if the driver is there it will mess with the drivers regardless so it must be disable in the Device Manager

0 Likes
rockovissi
Adept II

The drivers magically started acting up again so I tried different things. I always have MSI Afterburner running in the background with Rivatuner capping the framerate at 60fps as that does a better job than AMD’s with regards to Frametiming. Well I disabled that and stopped both applications from running when Windows starts and that seems to have worked for me so far. I haven’t tried a ton of games but I’ve been playing Red Dead Redemption 2 with Windows in Dolby Atmos and there have been no audio drops or skipping. It usually depends on the game. The Outer Wilds was always dropping audio for me and hasn’t since I disabled Afterburner and Rivatuner. I’ve previously tried uninstalling Realtek drivers but that did not help my issue. Maybe it helps? Either way, it still needs to be addressed and mark as fixed because it’s been almost a year now. If you have MSI Afterburner and Rivatuner running, try closing them and disabling them and let me know if that works for you too.

currently i run afterburner and rivatuner on my system with no issue. dont unistall the realtek drivers just disable as your system will simple re-download once it detects that the driver is missing and override the amd audio driver.

That’s so strange. It’s the only thing I changed and I confirmed it twice. I set the detection level to low. I had a global cap of 60Hz. I can clearly see it does a better job with frametime than setting a minimum and maximum of 60fps under Radeon Chill. So I wish I could still use it. Yes I meant disabled Realtek in my bios.

0 Likes