cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

animeangel
Adept I

RX5700 and HDMI sound problem

Ryzen 5 2600x 

msi b450 tomahawk latest bios

kingston predator 3200 cl  16-18-18-36

Windows 10 up to date. 

I connect VGA to AVR via HDMI.

The problem is the sound from RX5700 is not smooth. It often jerky or sometime, the sound disappear.  I need to mute it from taskbar and open again then the sound will come back. But the problem will happen again and again.   

Updated driver cannot solve this problem. 

And my old RX580X do not have this problem. 

Any advice please? 

708 Replies

I am not a facebook kindda guy … Not that I don't agree with you. If you want to, please spread the word there too. The more noice we can make the better.

HDMI goes from GPU to  AV-receiver and AVR is connceted to TV with HDMI. TV is used when watching movies/youtube and when listening music. Main display (for playing) is connected with DP to GPU.

Yeah, the exact same setup as the rest of us here then.. 

Audio from MOB output (for headphones) works flawlessly. 

I can confirm this too..

0 Likes

Here's a video where you can hear what i mean about my crackling sound. Pretty annoying.

daveydguk
Adept II

Getting drop outs from Dolby digital plus sound tracks.

Rebooted PC and it plays fine. Maybe over time it just screws up. Very strange and puzzling.

I was downloading on Steam at the time it flunked ?

0 Likes
caxyh
Adept I

Hello there! Same issue. As I see there is only one possibly fix - return this "high performance card" back to retailer.

Ryzen 3600

5700xt

On my old NV card everything fine.

0 Likes
zealotki11er
Miniboss

There seem to be multiple issues reported here. Some get it because they use AVR. I have the issue because I use 4K TV via HDMI 2.0. The issue is that it happens with all recent AMD GPUs. Vega 64, Radeon 7 and 5700 XT. They all have the same problem. Sometimes they work fine but at times the audio drops and does not come back until I replay the video again. 

0 Likes

I use a standard monitor which does not have its own speakers but there is a green 3.5mm jack for speakers

0 Likes
zlobotron
Journeyman III

I ordered the RX 5700 from Germany to Russia, 2 weeks of waiting, and I have the same problem with sound, only reinstalling windows helps, the monitor has dvi output and I use the dvi-displayport adapter

Should I wait for new drivers? or is it better to return the card?

0 Likes

That seems like a different issue. The sound issue is only if you used HDMI. 

0 Likes
skoolbus
Journeyman III

I did a direct upgrade from 19.7.5 to 19.12.3 and my HDMI sound issue is gone.

19.7.5 was the last driver where this problem didn't occur, I have been sitting on it since July (trying to upgrade to new ones in between but the HDMI audio issue would come back) until I tried 19.12.3.

I had the audio stuttering issues in the game Control, Everytime I upgraded to a newer driver than 19.7.5 I hit the issue but not anymore.

I'm not sure if I'm on to anything, but people who have this issue, could you attempt installing 19.7.5 (clean install), then upgrade to 19.12.3 (clean install) and see if the issue goes away? Perhaps I am just lucky, but it could be that some settings from 19.7.5 is sticking around in 19.12.3 and allowing me to move on from this god forsaken problem.

0 Likes
taurea
Elite

Hi everyone.

I'm currently using 19.12.3 also. 19.12.1 and 19.12.2 are both broken and are not worth using.

19.12.3 fixes a lot of the stuff that went wrong with the adrenaline 2020 edition driver.

While 19.12.3 indeed is ALOT better and Audio drops are way way down, I still notice drops in audio every now and then. 19.12.3 is a major step in the right direction, if this trend continues, 19.12.4 should be 100% stable in the audio drop department.

We can only hope.

I've had an on going dialogue with AMD tech support since my last post where I said I would contact them. They had me using 19.7.4 drivers too for testing purposes and by god that thing is horrendously broken. Never use 19.7.4 guys!

19.12.3 continued --> I've been using this for testing with AMD for a about a weeks time now. A New issue I've noticed and reported to AMD is this:

1. I put on a video on my 2’nd monitor.

2. I run Shadow of the Tomb Raider on my Main monitor.

3. If I enable Chill on SotTR, the card will draw sub 100w and my 2’nd monitor video will run fine.

4. If I disable Chill and let the card draw 200w + of power, the 2’nd monitor with the video will start to lag very badly or stop completely, while the Audio will continue to play fine. If I then re-enable Chill once more, the video will resume to play without any lag at all.

This seems to be a "prioritizing issue" with the driver, putting too much power into the game and not taking multi-monitor setup's into consideration.

AMD also told me that 19.12.4 should be released shortly and asked that I stay on 19.12.3 for now, continue testing and wait for 19.12.4 for further testing.

I don't know guys … Maybe we actually managed to get AMD's attention this time.

We'll see.

0 Likes

Finally some good news (i hope). Thanks taurea for keeping AMD informed about this issue. 

I have not even used the HDMI output for a while because of this issue. I really hope that 19.12.4 will fix this completely and we all can use our setups like we have previously used.

I bought external sound card because of this issue. My MOB doesn't have optical output for sound so that was my only option. 

0 Likes

Has anyone tried "Adrenalin 2020 Edition 20.1.1 Optional" yet?

0 Likes

zezba9000 wrote:

Has anyone tried "Adrenalin 2020 Edition 20.1.1 Optional" yet?

I am still downloading it, probababy freeze my rig as usual

0 Likes

Adrenaline 2020 isn't the answer. Currently running it. As stated before, I dropped my refresh rate to 4K/30hz, with no problems. As soon as I bump it up to 4K/60hz, that's where the audio cutting comes in. 

0 Likes
hensleewm
Adept I

What is your refresh rate set at? I have only found one solution (that worked) on a Reddit post, but have been unable to find that post again. 

I changed the refresh rate of my card from 59/60hz to initially 24hz, then to 30hz. I haven't extensively tested the 30hz, except for a 10 to 20 minute window (no issues), but I know that at 24hz the audio cutting completely disappeared. Occasional video refresh clean ups, but the audio cutting out was completely eliminated. 

There seems to be an issue with 60hz being processed for AMD Radeon cards to 4K devices. Not sure if its an HDCP mismatch or what. I also turned off HDMI Assurance on AMD Adrenaline software, which also reduced audio skips. 

I'm going to post this answer around. Hopefully AMD will clear this up.

HP 8100 Elite, I5 4th Gen, 8 GB, LG 65' OLED, Radeon 5500 RX 2GB, Integra 4.2, Windows 10

0 Likes
hensleewm
Adept I

I just read the bandwidth maxing out with Chroma Sampling. Possibly the maxing out of 60hz refresh rates doesn't help that either. Apparently 4K/60hz/7.1 Audio HDMI (18 GBps) cords are already obsolete. 

0 Likes
hensleewm
Adept I

Replying to my own answer and question: Has anyone tried updating their cables to 8K (48GBps) bandwidth?

0 Likes

I haven't even thought that another cable might help. If someone have tried 8K cable, i would like to hear how it works.

0 Likes

As to the guy's answer after yours, I was reading on Amazon of people having problem with eARC and Dolby Atmos over Netflix and other issues and them upgrading to 8K cables solved their problems. I ordered some from Amazon and will try this weekend.

0 Likes

RESOLVED - resolve

Upgraded cables 8K/HDMI 2.1/48Gbps bandwidth resolved audio cutting issue. These are the ones I bought. https://www.amazon.com/gp/product/B07NXPS94Q/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 

Bought three: PC to wallplate, wallplate to Receiver, Receiver to TV. 

 

Tested running Netflix, HBO, and VUDU for a few hours. No audio cutting since installed. Also resolved an occasional browser crashing when watching HBO.

 

Adrenaline 19.12 - Recommended Version. HDMI Super Resolution, HDMI Assurance Enabled. 4:4:4 - 8 Bit - 60Hz - 4K

HP 8100 Elite, I5 4th Gen, 8 GB, LG 65' OLED, Radeon RX5500 Low profile 2GB, Integra 4.2, Windows 10

 

The only thing I haven't tried is eARC connection from the TV to receiver. 

 

solutions - AMD, additional testing may be required. May want to include recommended hardware changes for future products. 

0 Likes

to answer your question yes, I tried using this cable Monoprice DynamicView Ultra 8K High Speed HDMI Cable, 48Gbps, 8K, Dynamic HDR, eARC, 6ft Black (amazing cable btw) and it did nothing to stop the audio cut out issues 

The 18GB cables are fine, I tested  them all with a 2070 super and they all worked, which has been the only solution for this problem buying an nvida card, they have zero audio issues.

I'm running 7.1 Atmos surround sound

 DENON AVR-S950H

HDMI out (video card to denon ---denon out to a

Samsung Q80R)

4:4:4  HDR 60 HRZ  4K

windows 10 

0 Likes

You wonder: Is it the card, or the software AMD runs in support of the card? I wouldn't be surprised if Adrenaline is part of the problem.

0 Likes
omegasupreme
Adept II

Finally found a solution, to cut outs and audio crackling.

I was running some benchmarks after overclocking my cpu. when I was done I decided to watch The Witcher

netflix show in 4k.  Normally with my amd card I get all the same issues we all have (audio drop outs and crackling) So I usually have my 2070 super installed instead.(i kept my amd card inside my pc when i was running cpu benchmarks for the OC)

The Witcher was running perfectly and I was wondering why that was SO i opened up the drivers and noticed my amd car was running at 1400 mhz with the fan at about 42% . I guess it was being utilized during my benchmarks and instead of going back to stock (which i think is 300 in Adrenalin 2020 19.12.3) it stayed at this higher clock.  So for about 10 mins everything was perfect and then the gpu finally went down to 300 mhz and thats where I noticed the crackling and audio drop outs occur 

So i ran a few tests....by running monster hunter, read dead redemption 2 and dead cells( which all utilize the gpu at max speed) and then minimizing the games to run any 4k hrd video and voila everything worked!!!!!

So basically what is happening is the stock speed of the gpu's which for the 5700 xt is 300 isnt sufficient enough to run 

any audio out from hdmi thats using a 4K HDR 60 hrz 4:4:4 7.1 atmos signal

i tried changing this but you cannot change the state0 min AMD has locked it ...you can change any of the other clocks but you cant set them to minimum in the new 2020 drivers 

or maybe i just dont know how.( i goggled this and all information i found was on the previous adrenaline drivers based on 2019, apparently you could change and set the min to any state thus allowing the videocard to run higher when in windows instead of the stock 300)

anyways I installed the 2070 super and noticed that the stock speed was set higher then 300mhz( amd card) which would explain why everything worked whenever I would play a 4K HDR 60 hrz 4:4:4 7.1 atmos signal and why there was zero crackling.

So maybe some of you can test this out by running a game which causes your gpu to clock higher then minimizing it and playing whatever video that would case the audio issues. 

0 Likes

I use a 4K panel and any video card I have installed is running hard and often right to the wall.

Maybe the 1080p gamers can see an elite card at idle in games. The DX12 wave processor is not loaded so hard.

0 Likes

Hello omega i notice that also when i use double screen in my config audio drops decrease significantly maybe you are right. I also use splash pro and i notice when i use imotion settings enable audio drops increase maybe cpu and gpu could not comunicate properly. One of the entry said precition boost overdrive can cause these problems. I disable pbo and audio drops decrease again but always there 

0 Likes
hensleewm
Adept I

RESOLVED - #resolve

Upgraded cables 8K/HDMI 2.1/48Gbps bandwidth resolved audio cutting issue. These are the ones I bought. https://www.amazon.com/gp/product/B07NXPS94Q/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 

Bought three: PC to wallplate, wallplate to Receiver, Receiver to TV. 

Tested running Netflix, HBO, and VUDU for a few hours. No audio cutting since installed. Also resolved an occasional browser crashing when watching HBO.

Adrenaline 19.12 - Recommended Version. HDMI Super Resolution, HDMI Assurance Enabled. 4:4:4 - 8 Bit - 60Hz - 4K

HP 8100 Elite, I5 4th Gen, 8 GB, LG 65' OLED, Radeon RX550 Low profile 2GB, Integra 4.2 - 7.1, Windows 10

The only thing I haven't tried is eARC connection from the TV to receiver. 

#solutions -‌ AMD, additional testing may be required. May want to include recommended hardware changes for future products. 

0 Likes
taurea
Elite

@omegasupreme  -  The workaround you found, keeping the card stressed does indeed work. This has been posted earlier in this thread also and I also found this to be true.

If I set heaven benchmark to run to keep the card from goin into low power states, it would run fine with minimal audio drops.

@hensleewm  - Glad this worked for you, but it is simply not a solution and the problem is not resolved. Please don't throw word like that around lightly, AMD-people will simply read this ONE word and think "aaah, easy day at work this monday, nothing to do and I can sit on my …. drinking coffee, how nice .. "

As other people have stated, buying expensive cables does not fix their problem and as has been stated before be some many more people, pre-Navi AMD card and Ngreedia cards work FLAWLESSLY within the same setup, same cables samt everything.

You actually running 4K right? It may be different for you too, my setup is only using 1080p, which is fine for me.

Again, I'm glad it worked for you, but please keep those resolve words in capital letters to a minimum. Thank you.

0 Likes

Maybe I jumped the gun. But the issue itself isn't limited to just AMD cards. When looking through reviews within Amazon when buying 8K cables, people are reporting video and audio issues with Roku, Xbox, AppleTV, and various other problems that were resolve after buying higher bandwidth cables. 

It would be interesting to see what the bandwidth is being utilized over HDMI. The actual amount of data being sent and received.

And Yes, all settings set high: 4K / 60hz / 4:4:4 / 7.1 Audio - The only thing I don't have enabled is ARC. 

0 Likes

hensleewm‌ This is a AMD issue. As people have said over and over again here. Nvidia works fine with the same data cables. This issue happens more often with low bandwidth not more. At 1080p 60fps no HDR on a 18gbit cable it happens all the time for me. Bump that up to 120fps with HDR the issue stops (again bandwidth is not the issue).  Its either a hardware issue but most likely a audio driver issue.

0 Likes

Fair enough. If you read through the reviews on Amazon though, issues with video and audio not playing or decoding properly isn't just an AMD issue. Roku, AppleTV, Blu-Ray players, etc all have similar issues. What's the middle ground?

0 Likes

No idea about that, but it must be a different issue all together.

You should read this thread from page one to get some context mate.

0 Likes

It might be a different issue, it might be related, however, it is unacceptable for this thread to be this long with no fix in sight so if anything let's direct our anger and frustration towards AMD cause they are the ones that deserve it and actually need to read this thread from the beginning.

Users here are just trying to help, helping or not, they have good intentions.

AMD is the bad actor here.

Thanks

0 Likes

for those using HDMI to a television.

I wish to point out that many such television do not present proper EDID so the video card has no idea what to do

0 Likes

It's a pretty high-end TV (LG 55C7) and Nvidia does not have the same issue. 

zealotki11er wrote:

It's a pretty high-end TV (LG 55C7) and Nvidia does not have the same issue. 

NVIDIA does not seem to pay much attention to the EDID like AMD does

0 Likes
mclingo
Challenger

audio dropouts here too, mainly youtube

0 Likes
mclingo
Challenger

seems to be related if not exact same issue as it started with later driver versions, 20.12.1 i think

0 Likes
boltsi
Adept I

I sent message about this to AMD again. Let see will get some "install drivers again with factory reset" answers. 

I was also thinking that because AMD clearly will not notice this issue, i will start search some IT related online news sites and contact them. Maybe some sites are interested to publish this issue on their website. If it gets publicity enough, AMD might actually react to this issue. 

If you guys know some good websites, please let me know. Bigger the better.

0 Likes

Try Reddit.

0 Likes
sp3ci3s8472
Adept I

I Tried the newer 19.12.* drivers and they were horrible for me. Back to 19.7.2 which at least is stable for developing purposes at least they won't randomly crash when something hardware accelerated in the browser is active.

0 Likes