cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Journeyman III
Journeyman III

RX570: no signal via HDMI (but works via DVI); monitor turned off during driver installation

Hi

During first drivers installation for Asrock Radeon RX570 my monitor, connected via HDMI cable, turned off (like there were no signal) for at least 10 min. After reboot my RX570 doesn't work. After that i deleted all graphics drivers, bought DVI cable, installed latest driver version. Now my monitor doesn't work via HDMI (no signal) but works via DVI.

Monitor (Acer R241Y) and HDMI cable checked - they work with my notebook. Problem remains on different motherboards: Gigabyte A320M-S2H and Asrock FM2A68M-DG3+. Driver 26.20.15029.20013 (01.04.2020) "working properly" according to windows device manager. OS Windows 10.

So what's happened during drivers installation and how can i fix HDMI connection?

Tags (3)
0 Kudos
1 Reply
Adept II
Adept II

Re: RX570: no signal via HDMI (but works via DVI); monitor turned off during driver installation

How about mate very good day, I had a similar problem about 2 weeks ago, since then I can not play on my pc, install radeon software, my pc stopped detecting my GPU when it was previously detected and played and streaming Very well, I will tell you the situation: amd is currently presenting many problems both in its drivers and in general software, as there are compatibility errors with windows that have not been solved since the beginning of the year. That the key is the great update of windows and wait a while for new drivers or new software to be released this in order for amd to be able to remember the errors that its components are presenting globally, so my dear friend, the key is to wait for that, about a month, since I very much doubt that one or two weeks will solve this serious problem in general, also taking in when to world situation today.

0 Kudos