cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

gw0081
Adept I

RX480 loses display when 2nd HDMI Port is used

Jump to solution

SO i have this really weird issue with my RX480 where with one monitor plugged into either HDMI it runs perfectly but the second another monitor is connected to the other HDMI it stops displaying on either monitor. If i unplug either screen it starts displaying again. I have tried everything i can think of to fix it but have come up with nothing.

System details:

Radeon Software Version - 17.7

Radeon Software Edition - Crimson

Graphics Chipset -Sapphire Nitro+ Radeon (TM) RX 480 Graphics OC

Memory Size - 8192 MB

Memory Type - GDDR5

Core Clock - 2000 MHz

Windows Version - Windows 10 (64 bit)

System Memory - 16 GB

CPU Type - AMD A10-7870K Radeon R7, 12 core 3.9GHz

0 Likes
1 Solution

Accepted Solutions
gw0081
Adept I

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

Turns out the issue was the cables from the card to the monitors. Replaced them and have no apparent issues now.

View solution in original post

0 Likes
5 Replies
plumboby
Miniboss

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

Have you tried the newer drivers might be an idea to try could be driver related. Whats you psu by the way as could be psu to

0 Likes
gw0081
Adept I

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

All drivers are up to date as of yesterday.

System runs on a 500w PSU which is more than enough by the maths for consumption

0 Likes

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

Cheap 500 watt or a good 500 watt? It does make a difference.

0 Likes
plumboby
Miniboss

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

Makes a huge diffrence a bigger PSU I run a 600w for my system just so I got a buffer as psu lose effiecentcy & degrade over time. I replace at a 2 year cycle had 2 Antec cough within 2 years they not as good as they use to be.

0 Likes
gw0081
Adept I

Re: RX480 loses display when 2nd HDMI Port is used

Jump to solution

Turns out the issue was the cables from the card to the monitors. Replaced them and have no apparent issues now.

0 Likes