cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

akmalzulkifli
Journeyman III

RX470 Fans spin at 100% (~3500rpm) and then stop working

RX470 fans spin at full rpm and then stop after some time. Fans still not spinning even under load @ playing game (GPU temp. at 80-90c). This problem happen every time I boot my computer.

This is what I tried:

1- used DDU to uninstall driver and reinstall the driver (Radeon software 20.2.2)

2- full reset Windows 10 v1903 and then update (Windows 10 64bits - v1909)

3- try different setting in radeon software (Automatic, manual-disable zero rpm/manual fan curve)

4- install msi afterburner and set fan curve (sometimes it work, fan spin at full rpm but just for a few minutes and then stop spinning again)

5- try replugged the gpu and still not working

is this driver/software related problem or my gpu fans broken, if driver/software problem, how I fix this.

0 Likes
4 Replies
warsun
Challenger

Re: RX470 Fans spin at 100% (~3500rpm) and then stop working

Try using this one.

Set your driver to default settings.

Uninstall your driver an install this one.

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-17-9-1 

0 Likes
akmalzulkifli
Journeyman III

Re: RX470 Fans spin at 100% (~3500rpm) and then stop working

i tried and still not working

0 Likes
warsun
Challenger

Re: RX470 Fans spin at 100% (~3500rpm) and then stop working

No one has addressed this issue yet huh? Could it be an old driver setting is preventing it from speeding up?

If its an old driver setting try this. Open your AMD radeon settings> Proficences (at the bottom)> an hit Restore Factory Defaults.

See if that fixes the issue please.

0 Likes
akmalzulkifli
Journeyman III

Re: RX470 Fans spin at 100% (~3500rpm) and then stop working

I changed the gpu fan pin header and connect to motherboard system fan header and both fan work fine. 3 days gaming and the gpu officially dead (maybe?). While gaming, my display always flickered and built-in display speaker make pop sound. Sometimes the gpu just crashed. Now there is no display output at all from the gpu hdmi port when I boot up my pc, and then I switch to hdmi port on motherboard, windows already booted up. I guess the system doesn't recognize the gpu and straight-up boot with igpu instead. Doesnt try display ports on the gpu yet, if I use the display port will it work? Anyway, thank you for your responses.

0 Likes