cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

ashabasha
Journeyman III

rx470 error 43 with bootloop, is recognised in device manager but not radeon software, is it dead?

Graphics card:

     -AMD RX 470

Desktop or laptop:

     -Desktop

Operating System:

     -Windows 10 64bit

Driver Version installed: Have tried all listed below

     - radeon-software-adrenalin-18.3.1-minimalsetup-180305_web

     - win10-64bit-radeon-software-adrenalin-edition-18.2.1-feb7(1)

     - win10-64bit-radeon-software-adrenalin-edition-18.3.1-march5

     - win10-64bit-radeon-software-adrenalin-edition-17.12.2-dec19

Display devices:

     -C24F390 on Intel HD Graphics 4600

Motherboard +BIOS Revision:

     - ASUSTeK H81M-PLUS, Bios version 2205

CPU/APU:

     - Intel Core i5 4460 Model C

Power Supply Unit Make, Model & Wattage:

     - Corsair VS 550

RAM:

     - 8.00GB Single-Channel DDR3 @ 799MHz (10-10-10-30)

4 days ago was playing Fortnite, suddenly checkerboard patterns and colors appeared on screen, game froze then black screen and PC restarted itself.

As it restarted and logged into windows it would crash and restart, boot into windows fine then crash, boot, desktop, repeat. When on the desktop i could move the mouse with no problems, highlighting icons was all good but as soon as i would press any keyboard keys, move the mouse, press start, Windows+E, anything it would then freeze after 3-4 seconds and go into the boot loop once again.

Rebooted into safe mode, disabled the drivers and reboot, PC doesn't crash, then re enabled the drivers, reboot and again the PC would start crashing again. Have uninstalled and reinstalled with the above drivers and still the same problem, as soon as drivers are installed it would crash, device manager is saying there is an Error code 43, cannot troubleshoot the issue, windows doesn't recognize it, have tried updating drivers through device manager, still not working.

Previously card was overclocked so using MSI afterbruner i was able to underclock it back to its default values and that seemed to help, it gave me more time to open applications, browse web etc. before it would crash again. typically 20-30 seconds.

Now the card isint even recognised with Radeon Software, it just says there is no gpu attached. again it recognises it in device manager as an RX 470 with an exclamation mark and Error 43 but the Radeon software will not register it.

Have performed a clean reinstall of Windows, still no luck, have reset the bios through jumper, no luck, have disabled the integrated graphics no luck. I can plug the monitor into the GPU HDMI but the the fans don't work now. There is current flowing through the GPU as it gets hot, around 60c.

As said, can run PC absolutely fine, without the GPU it doesn't crash.

Any help would be greatly appreciated :-)

0 Likes
13 Replies
pokester
MVP

Uninstall Afterburner

Uninstall AMD Graphics Driver.

Run DDU from safe mode.  Official Display Driver Uninstaller DDU Download

Reinstall driver choose Custom install not Express, then choose Clean Install, if clean install isn't an option then the above 2 steps did their job, if not it will do the rest. Continue the installation.

Restart, go to Radeon Settings, Gaming, Global Settings, Wattman and increase the Power Limit all the way to the right to its maximum setting for your card ( under clocking isn't the fix). Save the profile and happy gaming. If you have future issue you may need to set a custom fan profile that kicks your fans on sooner and lowers the max temperature before throttling.

Good Luck & Happy Gaming!

0 Likes
ashabasha
Journeyman III

Hi Pokester,

Thank you for your reply, unfortunately what you suggested has not worked. When trying to open up Radeon I get the error

"Radeon settings are currently not available. Please try again after connecting AMD graphics."

The GPU is definitely connected right as I can use the HDMI port and it is recognised in Device Manager but with the error "Windows has stopped this device because it has reported problems. (Code 43)"

Any further help would be much appreciated.

0 Likes

are you following the correct procedures for installing on a laptop. From you results it sounds like you might be missing something critical. Please review the following advice pinned in the top of these forums. Laptop graphics update...How to

I hope this helps. Let us know if not and we will try again. Please know that loading the vanilla drivers from AMD on your laptop is never a guarantee for success as many laptops only work properly with the modified driver the manufacturers make. Unfortunately they don't keep up these special drivers long after the sale. AMD can do nothing about this practice they only make the chip. The manufactures are the ones the change operating specification and stray away from reference design. If you have not checked you manufacturers site for current drivers and installation instructions that really is the best place to start on any computer you didn't build yourself.

0 Likes
ashabasha
Journeyman III

Hi Pokester,

Again thank you for your reply, however, it is a custom built PC i have, not a laptop.

I have downloaded and installed all drivers from the AMD site as you requested above and still no luck.

0 Likes

My apologies I was reading in your specs and where it said Desktop or Laptop the laptop caught my eye. It happens a lot here, that is the culprit.

I know that a code 43 usually means that a device in Windows isn't identified properly. A very simple thing to try and could help, would be really easy to do anyway. Go to device manager, find your graphics card and remove the device. Restart the machine. Sometimes just having Windows re-recognize hardware fixes things too, it absolutely can be that it is not the driver at all.

Hopefully you try the above first before trying the next advice.

I had many issues with many of the Adrenaline drivers and those directly preceding them myself that are now fixed in the release from a couple days ago of the 18.3.2 drivers, I did however once again have to go through DDU and that whole routine for them to work. I tried the express install (should know better) and it didn't work right. Have you tried these yet. I only saw mention of you installing the 18.3.1 drivers.

If that doesn't help either I'm sorry, I think its beyond me, at least with what I know from this end.

I hope someone else with more insight to offer comes along with better advice for you to try.

0 Likes
ashabasha
Journeyman III

Hi Pokester,

I have tried the new 18.3.2 drivers and still no luck, same issue.

Am i right in believing that the GPU is not a dead brick as it still allows HDMI output?

0 Likes

It is so hard to say as there are different levels of functional while still working/being broken? The real questions are what happens when you start really diagnosing the issue. If you have a spare hard drive you could test with. You could disconect yours and install a fresh windows to that drive and see without wiping what you have out if that fixes things. If you don't you could install Ubuntu to a USB stick and boot that and see if the ports work. You could pop the card out and try it in another PC and see if it works there. I know this is pain in the but stuff at this point but your going to have to figure out what path to go down.

Did you try removing the card from device manager like I said and rebooting?

I might would just try that card in another pc before anything else as it sure sounds like it could be hardware issue.

Reply back I'll sure help in any way I can.

0 Likes

Hi Pokester,

Yes i removed from device manager and still no luck. As for HDD i have 2 in the PC an SSD and HDD i suppose i could boot windows onto the HDD but would that wipe everything of it? The Ubuntu method i will tonight

Thank you for everything so far :-)

0 Likes

Yah, you'd probably want a blank drive. If you don't have a backup drive for pictures, music and such may be a good excuse to buy one! You could do some testing then.

0 Likes
plumboby
Miniboss

Suggestion is check your HDMI cables or PSU maybe at fault. Have you checked both of these as could be as easy hardware fault being PSU starting to give up the ghost or HDMI getting worn had a few cheap HDMI crap out causing simular issues before. Is there any other 3rd party software installed might be that throwing gremilins in the build to.

0 Likes

Hi Plumboby,

Surely it cant be the PSU as the computer wouldn't start if that was the issue? besides checking Power requirements i only need 300w of power and have 550w in there. Ill try the HDMI cable once home tonight and let you know.

Thank you :-)

0 Likes
plumboby
Miniboss

I am going off whats posted really hard to say but just my suggestions is whats i found with my own issues & lessons learnt throwing round simple easy ideas avenues that may be a simple fix before going down the long road of OS reinstalls. Tho i recomend if reinstalling OS to run your OS just off SSD & use Standard Hardrive for storage its all i do with all my builds these days as had 10 kill Hard drives if they are weak I found SSD is the way to go OS wise. Sometimes eliminates the boot hang & other weird bugs issues & load times when booting to the OS.

0 Likes

Help. I am having a similar problem as the above and have tried all the suggested ideas and everything recognizes the card just the graphics itself doesn't work. Fans work, HDMI works, but not the graphics, I too get error 43. PLEASE HELP ME

Specs are:
OS win 10pro

mobo MSI Z170A gaming M5

CPU i5 6600 (non oc)

16 GB Balistix DDR4 2400

MSI RX470

0 Likes