cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

pokester
MVP

Re: Horrible GPU usage!

Stick with amdmatt​ . I know he himself has a Vega and will hopefully get you figured out.

pokester
MVP

Re: Horrible GPU usage!

As an RX 580 owner myself I know exactly what you are describe. The OP's Vega issue is different, the Vega really is a much different card than the Polaris chips.  That is good for you though.

Your issue absolutely sounds like a power ceiling / throttling issues. Do the following:

Raise the  Red Power Limit Sider to it's maximum. Slide the slider all the way to the right to 50. This is still well withing normal range and is not over volting in any way. It is dynamic and doesn't even mean your card is constantly using more power. Only that it can use more when needed.

This setting is in Radeon Setings / Gaming / Global Settings / Global Wattman : down below the fan settings.

If this alone does not help there are several other things you can do to get it stable.Then try the following,

To begin with if your are using anything like Afterburner, Trixx or other graphics tweakers, don't and uninstall them.

Next to the following:

1. Disable Fast Startup (google it)

2. Disable Hibernation (google it)

3. Make sure your Computer is set to "High Performance" in the power profile.

4. Turn off all Windows 10 game functions. In settings Gaming disable anything on, DVR, Game Bar ETC....

5. If your anti-virus software has a game mode, use it.

Now I want you to re-install the driver again doing the following:

Download the driver you want.

Run DDU from safe mode.  Get it from WagnardSoft_com.

Disconnect from the internet. ( this is the key as it is Windows update screwing up the reinstall)

Restart, and install the driver.

Restart with internet back on and you should be good to go.

After the driver re-install set the Power Limit Slider back to +50, to it's maximum.

If that doesn't get it. Let me know. I use custom fan and temp settings with my RX 580 and can post a screen shot of my settings for you to duplicate. I am work right now and don't have it here. I have done all these things and it has made my RX 580 rock solid stable, and it is anything but without what I have done.

I know this sounds like a lot, but unfortunately some of these cards are really a PITA to get working. I get that, and am just a user like you, I had no hand in making them.

I can tell you that when you find the settings that work, they are usually rock solid from there. Just sucks that they take a lot of tinkering.

daniel91
Adept II

Re: Horrible GPU usage!

were you reffering to me with these tips?

0 Likes
daniel91
Adept II

Re: Horrible GPU usage!

ill take any help i can get at this point. been nolifing this issue for a week now with no success...

0 Likes
pokester
MVP

Re: Horrible GPU usage!

No, Trollsbeserk with the RX 580.

However all the changes to Windows I suggested, I find makes gaming HIGHLY MORE STABLE regardless of card.

1. Disable Fast Startup (google it)

2. Disable Hibernation (google it)

3. Make sure your Computer is set to "High Performance" in the power profile.

4. Turn off all Windows 10 game functions. In settings Gaming disable anything on, DVR, Game Bar ETC....

5. If your anti-virus software has a game mode, use it.

------------------

Now with Wattman you may need to mess with voltage and PStates based on other help I have seen with Vega. You can search the forums there is lots of advise on those settings. I would think Matt will give you some good help so you may wait for his advice before changing more stuff.

trollberserk
Adept I

Re: Horrible GPU usage!

Sorry the late answer^^' I'm French so when you answer me I was sleeping

So, I do all what you wrote and that doesn't work My GPU usage stuck at 60% usage! I really don't understand why

0 Likes
amdmatt
Community Manager
Community Manager

Re: Horrible GPU usage!

I am using a Vega GPU myself, albeit with a slower CPU than yours for gaming, and i do not see the issues you describe. I am using out of the box default Wattman settings. Unfortunately you still have not answered all of my questions, or provided any details about your system specifications so it is difficult to offer many suggestions. Please click this this > INFORMATION REQUIRED WHEN POSTING A QUESTION

One thing you can try in the meantime is to open up Wattman and right click the P7 GPU clock state circle and set P7 as the minimum state and see if that improves your performance in those games.

Perhaps a video and some screenshots showing your issue would be helpful too.

daniel91
Adept II

Re: RX Vega 56 Low GPU Usage in some games

System:

MSI RX vega 56 airboost OC edition 8gb. windows 10 pro 64 bit, latest drivers of 18.11.2. c24fg70 144hz freesync monitor connected with DP.                                GIGABYTE B250M-DS3H with latest F9 bios. i7 7700 CPU with h60 watercooling system.850W thermaltek PSU.

now for what you've suggested, when i lowered P7 to the minimum, my GPU was working near costant 100% on all the games i've mentiond previously which is a step forward, but the frames were much much lower since the clock speeds were very low. what do you think this means that P7 at minimum forces GPU to work 100%?

0 Likes
grimbloodwolf
Adept III

Re: RX Vega 56 Low GPU Usage in some games

@daniel91, I think you misunderstand...... you're not "lowering" P7"...... you're setting it as the minimum state..... P7 being the highest state means that you'll more or less be locking the clock at it's highest state...... set P7 back to it's default speed and right click it, this will give you a popup menu with two options "set as minimum state" is the one you want to choose.

0 Likes
amdmatt
Community Manager
Community Manager

Re: RX Vega 56 Low GPU Usage in some games

Please post a video showing what you mean and have the GPU clock speeds, usage etc showing on screen. I would like to see a video showing the default behaviour and a video showing the behaviour you see after my suggestion. Please also provide a screenshot of your Wattman settings.

0 Likes