cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

bysantin
Adept I

RX 6800 XT Games crashing - Direct X issues?

I have troubles with my new build:

 

CPU: ryzen 3600 (while waiting for 5900x)

GPU: RX 6800 XT (xfx merc)

RAM: 16 GB 3600 MHz (8+8)

Motherboard: ASUS TUF Gaming Plus Wifi

PSU: EVGA 750 W Gold Modular

 

Issue: Games crashing.

 

Warzone crashing after few moments in game, or just being in menu. Error codes are AMD driver timeout, or Disk read error, or dev error 6860, also got a direct x error once.

Control crashing after few moments. Error code: memory could not be written.

 

Doom Eternal, stable, running at several hundred fps at nightmare 1080p.

Wolfenstein - New Order, stable, running fine.

 

So my theory is then that Direct X 12 and my new GPU aren't playing well together. Doom and Wolfenstein are Vulkan, and are running well.

 

I have updated BIOS, reinstalled Windows, updated windows to latest, reinstalled AMD Chipset drivers to latest, Installed the two latest versions of the AMD Gpu drivers.

I have also stess tested, GPU, VRAM, RAM, CPU with no bad results, other than one run of Uningine Direct X which crashed at 1080p extreme.

 

Anyone know any fixes for this?

 

EDIT:

Bios version: 3602

Windows: 20H2

GPU: 21.3.1, also tried the former version

No mans sky did also crash.

EDIT2:

Lowered my RAM to 3200

Followed these instructions: https://www.youtube.com/watch?v=PtIh1fnuNoE

Drivers without Adrenaline software. Now I could play one game of warzone with great framerate. Game crashed in menu after game, with Dev. error 6068.

4 Replies
xlox
Miniboss

Re: RX 6800 XT Games crashing - Direct X issues?

hello , try lower ram to 3200 to see if it helps

 

0 Likes
Thanny
Miniboss

Re: RX 6800 XT Games crashing - Direct X issues?

That large mix of different errors points much more to a RAM issue than anything else.  Either you're running it too fast or it's defective, most likely.

 

bysantin
Adept I

Re: RX 6800 XT Games crashing - Direct X issues?

I fixed this by doing this: https://www.youtube.com/watch?v=PtIh1fnuNoE

You need to use DDU to make sure you have removed everything before doing this.

0 Likes
Mordillio
Journeyman III

Re: RX 6800 XT Games crashing - Direct X issues?

Just my 2 cents...

for the past few months with my 6800xt I was having constant crashing in simple games such as WoW and DOTA2 all showing memory could not be read/written or DX errors regardless of which version was used, and was stumped trying every possible combination of drivers/settings and switching things in the BIOS with zero results. Almost upon giving up I realised that a new BIOS version had been released for my motherboard as of this month. Updating that solved everything.

TLDR; update BIOS, post results.

0 Likes