cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Journeyman III
Journeyman III

RX 6800 Black screen/ No signal

Hey guys,

Im the (un)lucky owner of a XFX RX 6800 (No XT)!

If i turn on the PC with the new graphics card, the "RADEON RX 6800 XFX" LEDs light up and the fans start.
The monitor isnt doing a thing. Its just black. The only thing i can trigger is a "No signal" if i plug out and in the Displayport cable. He starts swiching between HDMI and Displayport and turns off after a few times.
So, there are a few things i just tryed to solve it like:

-BIOS upgrade
-Pre installed the newest AMD drivers (Radeon Software)
-Tested other powersupply
-Changing VGA cables from PSU to make sure its not broken
-Testing older Monitor HDMI with same result
-I checked all different HDMI and Displayport slots

If i plug in my Radeon R9 380, it works fine. So the PCI x16 slot isn´t broken. Yesterday, i tried to plug it on an old Gigabyte 990X MB where my R9 works fine too. Nothing happens.

Specs:
BeQuiet Straight Power 11 750W
MSI X570 Gaming Edge Wifi
AMD Ryzen 5 3600X (Corsair AIO water-cooled)
4x Corsair Vengeance PRO 8GB @ 3200 MHz

Would be great if you guys have some ideas.
Greets

0 Kudos
9 Replies
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

I purchased a new pc recently, when it arrived I have had the same exact problem, no signal displayed but the fans and LEDs work. I have tried everything I can think of to get it going and also have tried other cards in the system and they work. So must be a fault with the card, would like to know if you have had any luck with yours?

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

RX 6800 Black screen/ No signal - is a default issue 

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Hi

 

Same here just got a Red Devil RX 6800 LEDs light up but that's it no fans spin or any signal from DP, I tried the card in my old rig, and would you believe it it worked ok starting to wonder if it's the PSU, not enough power.  I have an Aerocool 750w which on paper looks good and powers the RTX2060 currently ok not sure about this big boy GPU any advise or help would be great

0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Did you ever fix this?


@Serioussam wrote:

Hey guys,

Im the (un)lucky owner of a XFX RX 6800 (No XT)!

If i turn on the PC with the new graphics card, the "RADEON RX 6800 XFX" LEDs light up and the fans start.
The monitor isnt doing a thing. Its just black. The only thing i can trigger is a "No signal" if i plug out and in the Displayport cable. He starts swiching between HDMI and Displayport and turns off after a few times.
So, there are a few things i just tryed to solve it like:

-BIOS upgrade
-Pre installed the newest AMD drivers (Radeon Software)
-Tested other powersupply
-Changing VGA cables from PSU to make sure its not broken
-Testing older Monitor HDMI with same result
-I checked all different HDMI and Displayport slots

If i plug in my Radeon R9 380, it works fine. So the PCI x16 slot isn´t broken. Yesterday, i tried to plug it on an old Gigabyte 990X MB where my R9 works fine too. Nothing happens.

Specs:
BeQuiet Straight Power 11 750W
MSI X570 Gaming Edge Wifi
AMD Ryzen 5 3600X (Corsair AIO water-cooled)
4x Corsair Vengeance PRO 8GB @ 3200 MHz

Would be great if you guys have some ideas.
Greets


 

0 Kudos
Grandmaster
Grandmaster

Re: RX 6800 Black screen/ No signal

1. do a BIOS upgrade
2. do a CMOS and leave everything auto (no OC or XMP)
3. maybe set correct PCIe slot for main graphics

PC: R7 2700X @4.1GHz + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Ok I've decided to register to post the same here. 

I've got a xfx 6800 and it was impossible to install, when I was installing the drivers the the screens went black and no signal from any screen (3 connected).

The PC was actually running as it was online.

Then I did a fresh install and the same issue, as soon as I tried to install the drivers the PC died.

My problem was that I was installing just the Radeon software, you actually have to install the combo which install the AMD chipset first, it's so weird!

Anyway, now I can game and it all goes well until from time to time all my screens go black, lost signal and PC freezes. It happened 3 times this week and it's pretty annoying because I use my PC to work and I need it to be stable.

I never had any issues with my previous rtx2060.

I'm more inclined about AMD drivers than Hardware issue to be honest.

Event viewer shows critical kernel error and power lost so I don't really know. All these instances happened in outlook or browsing, so it's not an power limit or temperature.

If issues persist I'll return it and buy an Nvidia. I knew AMD driver support was bad but this??

 

 

0 Kudos
Miniboss
Miniboss

Re: RX 6800 Black screen/ No signal

Need the rest of the PC specs in your case. Anything can cause this form your description. Did you get the XFX Merc 319? Could be temps running 3 screens. Are they all the same resolution, refresh, and response time? Using a splitter can cause issues with the 5000/6000 cards, best to use a port per screen. Use a PSU with 2 PCIe power plugs vs. the dongle/split type off one rail. I run a Corsair RXx750.RX 6800 Settings.png

Kernel Power System 41 is probably the error and that is from the PC shutting down improperly (crashing). Can't say temps are good unless you check while browsing, etc. Use control+alt+o to see all the info while browsing, etc. If your temps go over 110c, that's an issue.

Personally, I would recommend going into settings/tuning and "manual" and disable the zero RPM fan option. On the Merc, put the switch to balanced vs. stealth. This is what I did with my RX 6800 but it's a Gigabyte so yours may or may not run these settings. If it's a 319 it should easily run like this or better. Note the VRAM setting to "fast". The actual VRAM frequency is about 2100 for most cards, mine's a freak.

"It worked before you broke it!"
0 Kudos
Journeyman III
Journeyman III

Re: RX 6800 Black screen/ No signal

Hello .. i have a similar issue to your and currently discussing it on MSI forums (RX6800 XT and the unpredictable black screen issue)

I also believe its a drivers or BIOS issue since games run smoothly and the black screen (which can bot be reproduced) happen only while browsing or watching youtube

I removed the RX6800 XT until i find a solution .. currently using RTX3070 in the same PC running solid but of course lower performance. (both cards are MSI Gaming x Trio)

I logged the issue with both AMD and MSI customer service

 

Ryzen3600/ Ballistix 2x8GB 3200 on xmp/ MSI B450 Gaming plus Max/ nvme WD 500gb+ ssd WD 1tb + hdd WD 6tb/ psu Corsair RM850x (2 separate 8pin cables used)/ monitor LG 32GN600 using DP 1.4 / all items are less than a year old / no over clock / below average temps idle and load
Windows10 pro 64bit .. all drivers and system are up to date. 

 

0 Kudos