cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

dp4700
Adept I

RX 6600 XT not utilizing correctly

I just upgraded from a rx 6500 xt to a rx 6600 xt and the GPU I got does not like playing games at all.

Whenever I try playing a game, the GPU starts off with 30 percent utilization but as gameplay gets heavier, the utilization starts decreasing to the point of where it has >5 percent utilization and my game has around 1 fps. When I tried troubleshooting benchmarks I got: GPU SCLK: >60 MHz; GPU PWR: >10 W; GPU JUNC TEMP: >30 C.

I never had this issue with my previous GPU and feel that something might be wrong with either my settings, drivers, or the GPU itself.

PC:
CPU: 3000G Athlon
GPU: 6600 XT Powercolor Fighter
RAM: G.Skill 16 GB (2x8) DDR4 3200 MHz
Motherboard: MSI B450 Max II
PSU: EVGA Supernova GT 850W
Driver: Adrenalin 22.2.3

0 Likes
1 Solution

HARDWARE STEPS

  1. Verify each PCIE power connector on your GPU has its own cable running to the power supply. If your card has two or more connectors, do not daisy chain them.
  2. Confirm your card is properly seated into the PCIE slot of your motherboard. If you're using a Riser cable, make sure it has a good connection on both ends and that it is the proper generation for both your card and motherboard.
  3. Ensure when installing your card that you did not accidentally displace your RAM.

 

SOFTWARE STEPS

  1. Deleting your old driver from Windows may not be enough since some settings can still be preserved in your Windows Registry. Clean the drivers again using Display Driver Uninstaller or AMD Cleanup Utility. Then, reinstall the correct drivers for your new card.
  2. Go to your Windows Power Plan setting and change it to High Performance. You can even try enabling the Ultimate Power Plan: https://www.howtogeek.com/368781/how-to-enable-ultimate-performance-power-plan-in-windows-10/
  3. In AMD Adfrenaline, go to the Tuning section -> Manual -> Power Tuning. Switch it to "enable." Move the Power Limit (%) slider to the right.
  4. Install a free benchmarking utility, such as Heaven Benchmark. Run the benchmark to completion and report your results here.

View solution in original post

9 Replies
goodplay
MVP

Did you remove the old driver and then do a full factory reset install of the 6600XT driver, and what benchmark app gave you that readout ?

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..

Yes, I deleted the driver from device manager and then did a full factory reset of my GPU when it was having the problem I mentioned. I downloaded my new driver from Adrenalin version 22.2.3. I used AMD Radeon Software to monitor the stats while playing under heavy load.

elstaci
MVP

Part of your problem is that your Athlon 3000g is bottlenecking your GPU card quite at bit at 1080P settings ultra.

Ran your specs at a FPS & Bottleneck website and this is what came up:

Screenshot 2022-03-13 220146.png

But you still should get more than 1 FPS, at least above 51 FPS.

Try running your games at the minimum basic settings and see if you get better FPS and  lowest Resolution possible.

Have you tried configuring Windows Settings in selecting your GPU card instead of your Integrated Graphics in each game?

I tried running games at low settings and the game runs at around 40 fps with around 30% gpu utilization and 60% cpu utilization but as more load comes, the gpu utilization drops to under 5 percent while my cpu is still around 60 percent utilization. I'll try installing the gpu on a different computer with a better cpu and tell you whether my gpu will have better performance. I checked windows and it shows that my gpu is being used by the game. I also noticed most of the games I play before heavy load run at around 600-800 MHz before decreasing when there is more load.

I don't believe SAM is supported with your cpu/mobo combo, and 900p freesync (doubt it. unless you posted wrong model).

Pump up your games graphic settings to make the card work.

 

 

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..

HARDWARE STEPS

  1. Verify each PCIE power connector on your GPU has its own cable running to the power supply. If your card has two or more connectors, do not daisy chain them.
  2. Confirm your card is properly seated into the PCIE slot of your motherboard. If you're using a Riser cable, make sure it has a good connection on both ends and that it is the proper generation for both your card and motherboard.
  3. Ensure when installing your card that you did not accidentally displace your RAM.

 

SOFTWARE STEPS

  1. Deleting your old driver from Windows may not be enough since some settings can still be preserved in your Windows Registry. Clean the drivers again using Display Driver Uninstaller or AMD Cleanup Utility. Then, reinstall the correct drivers for your new card.
  2. Go to your Windows Power Plan setting and change it to High Performance. You can even try enabling the Ultimate Power Plan: https://www.howtogeek.com/368781/how-to-enable-ultimate-performance-power-plan-in-windows-10/
  3. In AMD Adfrenaline, go to the Tuning section -> Manual -> Power Tuning. Switch it to "enable." Move the Power Limit (%) slider to the right.
  4. Install a free benchmarking utility, such as Heaven Benchmark. Run the benchmark to completion and report your results here.

This seemed to fix my problem. Tysm!

Thomasdk1405
Adept III

Hi

SAM on or off ? You have 3000 series cpu - try to turn SAM off if you have that and see if that makes difference. Furthermore what monitor do you have ? G-sync or Freesync ? If G-sync it could be related to fps sync to monitor. I had similar problems with 6900 xt gpu and 3800 x cpu vs g-sync monitor. Suddenly gpu util would drop from 80 % to 30 %. Turning SAM off and have settings for game like Game or esport and make sure that amd optimized is set. If I turn it off its like crazy to watch. Use the default settings like game / esports and turn SAM off and see where that takes you. 

The registry thing to disable ULPS did not do anything for me.

SAM is shown to be unavailable to me when I checked Radeon Software. I use a 1600x900 monitor (sceptre e205w-16003r) and Radeon shows me that I am using Freesync. I use low graphic settings for the games I play and make sure my fans spin at max to prevent heat.