Showing results for 
Search instead for 
Did you mean: 


Journeyman III

RX 580 Stuttering

Hi everyone.

I've bought recently a RX 580 (ASRock Radeon RX 580 8GB OC Phantom Gaming D) and I'm facing some issues regarding stuttering.

My hardware specs are:

Intel i58400

ASRock Radeon RX 580 8GB OC Phantom Gaming D

Seasonic S12II 520W

RAM G.SKILL Aegis 16GB (2x8GB) DDR4-2666MHz CL19

SSD 2.5" Crucial MX500 250GB 3D TLC SATA

Motherboard Micro-ATX Gigabyte B360M DS3H

AOC 24G2U5 Monitor

I have freshly installed the drivers 20.4.2 and tried with previous version and no luck.Already tried to turn off HDCP, changed profile (currently is GAME but tried with STANDARD too)

I'm playing Gears of War 4 with everything maxed out and the game runs smoothly at 75fps. After some minutes of playing I get stuttering and then goes back to the 75fps. When that happens the fps goes to 60 and the GPU load goes from 100% to like 10% or even lower during one or two seconds. This is supper annoying and ruins my experience. I've tried to lower graphical settings and the result is the same. 


I've tried to change the power tunning to +50 and no luck too.

You can check my problem in the following video 

I don't know more to do. The GPU is absolute new (no refurbish or used, absolute new), I just installed it yesterday and I still couldn't enjoy it properly.

I appreciate your help!


Best regards!

3 Replies
Journeyman III

Hello everybody!

I actually found the source of the problem.

The base default frequency is 1370Mhz for gpu model but it seems that struggles with that. I've been testing to reduce it and improved. Actually I don't have the annoying stuttering. 

I've put the state 7 as 1300Mhz and voltage at 1050mV and runs marvelously. I'm trying to improve the frequency to see how much can it take. 

ASRock > Phantom Gaming X Radeon RX580 8G OC 

Based on the description at the website it can take at 1435Mhz but truth be told the stock as 1370Mhz had a lot of stuttering. Maybe the voltage wasn't right too (too low or too high by default).

I'll test more settings and will provide feedback!

Best regards!

Journeyman III

No feedback on this?

I'd like to read what AMD has to say about this...

Journeyman III

Forgot to mention but it seems that the reason of the problem is when GPU reaches 79ºC. 

Reducing clock frequency helps to reduce temperature but since the weather is too hot it helps only a while. I configured the fan to works faster but it is loud but for me it is no problem since I gaming with headphones. I am more concerned if it reduces lifespan.