Showing results for 
Search instead for 
Did you mean: 


Journeyman III

rx 580 screen freeze, black screen, game crashes

My system:

GPU: AMD RX580 (8G GDDR5 OC) 1366Mhz (not overclocked)

OS: Windows 10 64-bit

Driver Version: Current: Adrenalin Edition 18.8.1 Optional / Best working yet: Crimson ReLive Edition 17.11.4 Optional

Display: AOC G2460V 1920x1080 @60Hz HDMI to HDMI (no adapter, just cable)

Motherboard + BIOS: Gygabite ga-h81m-hd3 (rev. 1.0) BIOS version: f5 (tried f7, didn't work)

CPU: Intel Core i3-4130 (2 cores, 4 threads) (not overclocked)

Power Supply Unit: CoolerMaster GX-Lite 600W (model number: RS-600-ASAB-l3)

RAM: Kingston (HyperxFury) 8GB (2x4) DDR3 1600Mhz

(I know, the graphics card is overkill, but my system meets all minimum specs so I don't see the problem)


My screen freezes randomly (with 18.8.1 much more often and under light workload, with 17.11.4 only under medium/heavy workload such as 3d games and benchmarks), the freezes are often followed by the screen turning off and on, getting stuck in a loop of it (turning screen off and on) and eventually the screen loses input signal, forcing me to do a manual restart (holding power button for a few seconds).

Another issue which happens instead of the screen turning off and on, is a game freezing and often crashing (screen doesn't turn off but does freeze for a second or two) (this happens after 5-10 mins of gaming, it happens more on 17.11.4, on 18.8.1 it's usually just a screen freeze, going black, and turning on etc.).

Also, I tried running minecraft, it worked fine but it had a significant fps drop (avg. ~45 fps) compared too my old gt640 which ran it at 1080p constant 60fps pretty easily. Fortnite seems to perform quite well, averaging out at ~55 fps at high settings (turned off shadows and post processing), little bit of tearing sometimes (noticed more stutter on 18.8.1 drivers than on 17.11.4), but it never seems to run longer than 20 mins.(on any of the drivers), after that the game crashes and sometimes an unreal engine error message shows up (see screenshot included)

I've gotten notifications such as "application has been blocked from accessing graphics software" and "global wattman settings restored due to system error (don't know if that was exactly what it stated but it's close enough)". (all I change in the global wattman settings is fanspeed, I never overclock it)

I've tried updating/changing drivers (best driver seems to be 17.11.4), updating/changing BIOS (f5 seems to work a lot better than f7), freeing up space on my Local Disk (C:) (ssd) also seemed to improve the performance quite a bit (moved games to hdd).

Hope I provided you guys with enough information (I tried making it a short as I could..) for you to be able to help me.

EDIT:          27/08/2018

I tested the GPU in a rig with an intel core i5-4460. Seems to be working fine when using driver 17.11.4. I bought a secondhand i5-4670K which will probably be delivered somewhere in the next 2-3 days. If this doesn't fix it I'll make sure to re-edit.

3 Replies
Journeyman III

Hello, i have exactly the same problem. I increased the power limit to +50% in Wattman it was fine for 2 days, today it happened again. Exactly the same problems that you have


Check my edit. I don't know what cpu you're using but so far that seems to have been the problem for me. (I was using a duo core intel i3-4130 which probably wasn't able to handle the gpus speed. If you're already running off of a quad (or more) core cpu you should check if you meet the system requirements stated on the box.

Adept I

check here : Black screen issue - Potential fix --> cpuidsdk.dll & cpuidsdk64.dll

if you have any software i mentioned.