Showing results for 
Search instead for 
Did you mean: 


Journeyman III

RX 580 Losing Signal


Back in February, I purchased an MSI RX 580.  Right from the get-go, when just browsing the web or using a resource light application, my monitor would be begin to flicker before finally turning to a colored static.  The weird thing is, I had 0 issues playing games such as Resident Evil 2 Remake or Valkyria Chronicles 4.  But I DO have issues playing games like Enter the Gungeon or A Hat In Time.  I did RMA the card and received a ( I think ) refurbished card.  Same issue.

Usually what happens is the monitor will flicker once.  Then a couple more times.  Then a long flicker before finally going to the colored static.  Turning the monitor off and on immediately resolves the issue for a little bit.  I have also experienced a flickering where the screen appears smaller and near the top left of the screen but that does not always result in the colored static.  

I was able to play a hat in time for a while this morning.  The screen went to colored static twice but power cycling the monitor fixed the issue for probably 40 minutes or me each time.

I am using a DVI cable.  I think I tried an HDMI cable at one point but I will try that again.  


RAM:2x4GB Vengence DDR3 1600MHz

MoBo: MSI Z77A-G45

CPU: i5-3470

PSU: LSP-750 Watt

Monitor : ASUS PA248

I think my MoBo and CPU may just be too old to really be compatible ( even though pc part picker said it should be compatible ).  I'll probably end up upgrading those in the coming months.


5 Replies
Journeyman III

I should add - I've made some changes in Wattman that do seem to help but have not totally resolved the issue. I've lowered the GPU voltage to 1137mV, increased VRAM max voltage to 950mV, turned off Zero RPM, and increased the power limit +50%.



I have had exactly the same problem with my Sapphire RX 580 4GB Pulse card, where it ends up displaying static coloured dots. I ended up powering off the PC and back on again to resolve.

I was wondering if my PSU wasn't supplying enough juice  ?

Not had this issue playing games either.. Just happens when browsing windows etc.

Asrock Fatal1ty B450 ITX, Corsair 2 x 8GB XMP 1 3000Mhz, Ryzen 3600 CPU, Corsair 450W SFX PSU, Windows 10 x64 Home.

Using latest Adrenalin 2019 Edition 19.10.2 drivers.

I have this connected via HDMI to Denon Amp and then LG 55" TV.

Can anybody recommend diagnostic software which tests your GFX card for memory errors ?

Hey Dave,

That's exactly the same screen I am seeing.  And like you said, it mostly happens when just using windows ( though I see it on less resource intensive games as well ).  

I don't believe it is a power supply problem just because I have a 750 Watt PSU and should have plenty of headroom for the graphics card.  It makes me think this problem happens when the graphics card power consumption is too low ( which seems preposterous ). 

My other theory is that this is a VSYNC issue of some sort.  Otherwise I have no idea.

I tried a software called OCCT that checks for errors of some sort.  I ran it for a few minute and it never detected whatever errors it is checking for but you might try it.

Big Boss

guys, grab DDU and clean up the drivers and install 19.10.2 fresh


Thanks for the reply.  I did exactly that a few months back and it didn't help.  Maybe I'll try again though