cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

iandrasil
Journeyman III

RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

Describe your system:

AMD Graphics Card:

     MSI RX580 8192mb 1366mhz

  • Desktop system
    • Windows 10 64bit
  • Radeon Adrenalin 18.3.4
  • 2 displays connected 1 HDMI 1 (iiyama prolite plb2403ws) and 1 via DVI-D (samsung syncmaster 245b)
  • Motherboard + Bios Revision
    • B350 TOMAHAWK ARCTIC (MS-7A34) (AM4) bios version:Version 7A34vH7

  • CPU: ryzen 5 1600x
  • TN6V6T00 Corsair TX650M PSU at 650watt
    RAM:16 GB (2 x 8.192 MB) balistix sport BLS2C8G4D240FSB DDR4 memory

Describe your issue:

I am experiencing issues using my new MSI RX580, I recently got back into Vanilla World of warcraft aka 1.12.1(5875) (release) client considering blizzard announced that they are remaking it officially, however using the client currently I am experiencing some stretched texture/polygon issues that don't occur on my other GPU (a MSI970)

Provided here are links to screenshots documenting the graphical issue:

stretch 1.PNG - Google Drive

stretch2.PNG - Google Drive

artifactevidence.png - Google Drive

now the reason I am suspecting that this might be a driver issue but correct me if I'm wrong here but the drivers made for AMD products back in those days were called ATI cards and I'm not sure if modern day GPUs/Drivers are even backwards compatible that far, so far I've only been able to solve the problem by switching out hardware but RMAing the GPU itself has so far only resulted in 30$ in shipping costs once to the retailer and once to MSI repaircentre in poland where neither one could determine a problem and send it back after a few hours of testing.

So far WoW 1.12 is the only application that is giving me serious graphical artifacts and weirdly enough it only seems to happen in certain areas (ironforge and Ahn'qiraj 20 man dungeon), this also leads me to further suspect it might be a driver issue.

Now I know that WoW1.12 is a bit of a niche at the moment but considering that blizzard is now officially working on their own version would it still be possible to receive support on this problem?

0 Likes
6 Replies
jargon
Elite

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

You said that you're only getting serious graphical artifacts in WoW 1.12. Do you get "less serious" artifacts in other games with the 580 which you do not see with the 970?

0 Likes
iandrasil
Journeyman III

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

I get no artifacting in other games, it's only wow 1.12 and only in those 2 areas. Will provide screenshots of it happening there after tonight's raid there.

0 Likes
iandrasil
Journeyman III

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

PS: Other people I've spoken to that also play on AMD GPUs going back as far as HD7700 cards (out of those I've spoken to) are also experiencing this issue.

They also report that it's exclusive to those 2 areas.

0 Likes
pokester
MVP

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

Since you can document this as repeatable and know others to be having the same issue. You should report this to AMD. Telling us here is good for the community to know about the issue but not likely to get you a fix as it is your peers here not AMD employees. I would open a ticket on this and include all your info and pics you already did here. Email Form

Good Luck!

iandrasil
Journeyman III

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

Posted it to them through the form, I hope it gets fixed cause some of this flickering is giving me headaches during raids   : (

0 Likes
archilion2
Adept II

Re: RX 580 Graphical flickering and stretched textures exclusive to 1 application, possible driver problem?

Happened on my R9 390, too. AMD, notice this. Vanilla (1.12.1) is very popular atm.

0 Likes