cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

thedoddsy
Adept I

Rx 580 2048SP 8GBs isn't at full clock speeds

Specs

MSI RX 580 2048SP 8GBs

A10-9700 CPU

16GBs of DDR4 2400Mhz RAM in dual channel

Seagate 7200RPM HDD

My RX 580 isn't running at full clock speeds when it should be for example I'm playing skyrim at 30 fps but my GPU is running at 600Mhz and CPU is under 20% utilisation with no background apps open and the GPU is at 40 degrees, I've set the power limit to the max, overclocked the Vram, got Radeon chill off and no other frame limiters, please help me.

6 Replies
pokester
MVP

See if this helps. 

Set your vsync to off then edit enblocal.ini to have it limit to your monitor refresh rate the following example is at 60hz:

enblocal.ini

[LIMITER]

WaitBusyRenderer=false

EnableFPSLimit=false

FPSLimit=60.0   

 

0 Likes

Nope, it didn't do anything.

0 Likes

The fact that it is at 30fps sounds like the game engine is capping it. If this is the only game you have doing this then likely it has nothing to do with any AMD settings or driver issues. Certainly not that it can't be, but my guess is no it is not. What version of Skyrim the original or remaster and do you have any of the custom 3rd party texture packs installed? 

Also if you change resolutions does it change anything? Or run in a borderless window and see if that changes things.

Also go to your individual game profiles in Radeon Settings and go into the one for Skyrim and set if to default. Then delete the profile. 

 

Also check this setting in enblocal.ini

WaitBusyRender if set to true in enblocal - disable it and then run the game in exclusive full screen mode.

0 Likes

No what i meant is that it wasn't capped at 30fps for example if i look at the ground the frame rate goes up to 60 and i'm on special edition

0 Likes

You might want to try returning to for instance the November 2019 driver. See if it behaves differently. I know there have been a lot of random complaints with the newest drivers. 

I really don't have much more of an idea, other than just trying to eliminate variables.

I did run that game a couple years ago on my RX 580 and it ran fine then. The drives or a game engine update could certainly change that. Or any mods if applied to the game. 

So I would try some older drivers at least and see if it helps. 

If not report the issue to AMD and maybe you get lucky and they fix it, if it is their issue. https://www.amd.com/en/support/contact-email-form 

0 Likes

I already tried old drivers and went to third party websites downloading the best working drivers they recommended and still none of them worked although I think it may be because of a CPU bottleneck even when my CPU isn't being fully utilised but I am getting the Ryzen 5 2600 soon, I'm also on the latest version of everything on my system which includes Windows, MOBO BIOS, Radeon drivers, CPU Chipset and Skyrim software.