cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

electric_tom
Journeyman III

RX 5700 XT working with HD monitor, but not 4K UHD TV

I'm having a really strange issue... I had my new RX 5700 XT working with my ASUS Prime X570 mobo and a new Samsung UHD 4k TV, everything was going great until I had a windows start-up missing file issue.

Windows wouldn't start anymore so I wiped the hard-drive and reinstalled windows. Windows worked on TV screen, but had no sound due to the fact I hadn't installed the drivers yet. I installed the motherboard drivers, then went to install the RX 5700 XT drivers (Newest Adrenalin package). When the install for the RX 5700 XT drivers got to around 10% the TV screen went blank, then my TV changed to no HDMI input. The computer was still running and making noises that lead me to believe the hard-drive was being accessed. I decided to try plugging the HDMI into an old HD monitor I had and the display worked fine! I finished the driver installation and restarted the computer. The computer now worked fine on the monitor (sound and all), but refused to work on my TV.

I messed around for a while, but couldn't figure out any solutions. I tried formatting the hard-drive and reinstalling windows again then reinstalling all the drivers, but the same thing happened. I don't think anything has changed from my initial working setup. The TV works fine with my Nintendo switch, and works with the computer when its running the basic windows display driver (with no sound), but completely dies once I have the actual RX 5700 XT drivers installed. It still works with the older HD monitor thankfully so I'm able to continue troubleshooting... Does any one have any ideas? Any help is hugely appreciated.

0 Likes
1 Reply
electric_tom
Journeyman III

Re: RX 5700 XT working with HD monitor, but not 4K UHD TV

**Update: I formatted again, reinstalled windows and downloaded all new most current drivers. I had the UHD TV, mobo, and RX 5700 XT all working together happily for a little while. I decided to try adjusting some radeon graphic settings, I turned on 'virtual super resolution' and it totally killed the display again. Like last time my old HD monitor still worked, I plugged it in turned VSR back off, tried the UHD TV again but it wasn't coming back. I have no idea why or what setting is causing this, but there seems to be no way to get the TV working again. Later tonight I will try reinstalling windows again, doing the same driver setup and just leaving all the setting alone... but I don't think it's right that a small setting change would irreversibly eliminate all compatibility :s 

Any advice on resolving my issue is appreciated. I've been troubleshooting this issue for a few days now... This is my first time switching from Nvidia/Intel to AMD/Radeon, I'm getting really tired of this and starting to get a really bad impression of AMD software and drivers. 

0 Likes