cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

jkirkintexas
Adept I

RX 5700 XT more stable in games when overclocked

My PC Specs:

GPU: Sapphire Nitro+ RX 5700 XT

PC type: Desktop, self built

Operating System: Windows 10 64bit 20H2 build

Driver version: Radeon Software Adrenaline 20.12.1

Display: AOC 24G1WG4 1920x1080 @144Hz DP to DP 1.2 connection.

CPU: I7-9700F Intel

Motherboard: Z370P D3 Gigabyte

Power Supply: Corsair 750w 80+ bronze semi-modular power supply CX750M

RAM System Memory: 32GB Corsair Vengeance LPX C15 4x8GB 

 

I have noticed that when I use the automated overclock in the afterburner system my GPU's performance in games (and benchmarks) not only slightly improves. But becomes more stable. Is there any reason for this? The auto overclock goes to 2011 MHz and in lets say, Cyberpunk 2077 running settings from this video: https://youtu.be/pC25ambD8vs and what is not mentioned on high or ultra, with latest patch for PC: 1.04. I am getting much more stable frame rates and card usage, my card in downtown corp headquarters would drop in usage to 60% sometimes while not overclocked (in this area dropping frames as well.) But when I have it overclocked it would not do this and kept up in the high 90's of usage. Is it normal for this card to preform better when overclocked? Since the model I have has such a good cooling solution, should I just leave it overclocked. As it runs more stable? Thank you everyone for any advice and theories. Be safe! :)

 

0 Likes
1 Reply
RPX100
Challenger

Re: RX 5700 XT more stable in games when overclocked

@jkirkintexas hey there!

Yes, you can keep your overclock and use it for gaming, if it works for you.
Just make sure to check your GPU's temps and adjust fan curve if needed.

There is a temp value called "junction temp" within Radeon Software:
Make sure the fans keep your GPU below 85°C junction temp.

 

Now regarding your question: "Why is it not holding stable frequency?"
Might be related to power saving features like:
- Windows 10 energy plan
- BIOS settings
- driver settings

Your GPU will generally downclock itself, whenever GPU load falls below the threshold.
Workarounds to fix this include: disable PCIe power saving features (win 10 + BIOS)

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 20.8.3 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
0 Likes