cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

mrnatyy
Journeyman III

rx 5700 stutter

So when playing any game, I get random stuttering. I could be playing Overwatch at Max settings in 1080p and I'll be getting 154 fps no problem. Then even when standing still, the game will stutter down to bellow 60 and skips frames in between making games unplayable. All drivers up to date, I have a 2700x CPU, latest windows updates, so I don't know the problem. Any ideas?

8 Replies
xodrik
Adept I

Re: rx 5700 stutter

I am having the same issue with the 5700 XT. 

DDU used to remove all old drivers - installed AMD Adrenaline and receiving good frames BUT have stuttering and frame loss.  This was extremely apparent while using Heaven Benchmark. 

EDIT:  It appears that while I did use DDU to remove the old drivers just to be safe, I still had software attempting to apply an OC on the previous card.  I'm assuming this was causing issues as when I removed the software everything started functioning normally. Phew. 

I would suggest if everything is rendering correctly to go through and double check all of your previous software (if any) that may be trying to adjust your GPU.  Hopefully it's as simple as that. 

0 Likes
zazzn
Journeyman III

Re: rx 5700 stutter

Chalk this up to drivers... I had the same on Starcraft and pubg. 

0 Likes
shuwen
Journeyman III

Re: rx 5700 stutter

Hey there,

I got the same type of issues playing Smite. Using DX11: Most characters show no basic attacks and or abilities. Switching to DX9 gave me huge framerate drops. 

Setup:

MB: Asus Rog Strix X470-F Gaming

CPU: 2700x

GPU: Asus Rog Strix 5700XT

AMD Driver 19.9.2

This MB got 2 M.2 slots. My second one (M.2.2) is empty. Even tho this one is not in use, you have to switch this to 2x in stead of auto in the BIOS.

This slot shares a PCI e clock with the main PCIe x1_1 which is the slot where you put your GPU.

You've got 3 choices. Auto, 2x or 4x.

So set it to 2x

This solved all my stuttering problems. I don't know why. I saw this solution on other forums. It also seems to work for X570 MB Models (disable gen 4 pci e express. you will not loose any performance)

DX11 still doesn't work tho.

Hope it works for you!

0 Likes
shuwen
Journeyman III

Re: rx 5700 stutter

Update:

Just update to new chipsetdrivers and the problems are back..

rerolled back to previous chipsetdrivers but it didn't work..

Hope they have a fix soon. 

Other games like WOW and Ark works just fine..

0 Likes
rctpavuk
Journeyman III

Re: rx 5700 stutter

had stuttering problems with freesync and vsync. try enabling only freesync and cap the framerate at 143 (if you have 144 hz freesync monitor) and disabling vsync in both the game and radeon gaming tab (under the game profile)
solved that for me in dota 2, fallout 4, and gta5.

0 Likes
shuwen
Journeyman III

Re: rx 5700 stutter

Thank you for this advice unfortunally it didn't work. I have a 144hz freesync monitor indeed.

Maybe I dindn't mentioned it but I'm playing Smite in dx9 cause in dx11 most of basic attacks and abilities are invisible. Probably this is to blame on Highres (Developer) (Framerates are excellent in dx11 tho)

Its like the 5700xt can't sustain the fps in dx9 cause of its simple graphics. And doesn't bother to ramp up its clockspeeds for the whole time. It does sometimes tho.

Before I update to the latest chipset drivers (1.9.27.1033) released on 9/27/2019 it worked just fine after changing the BIOS.

My Asus Rog Strix mb - pci-e 1_1 slot (where my gpu is placed) shares a pci-e clock with the second m.2 slot. Had to change it to 2x in stead of auto even tho this second slot is empty.

Other games like WoW, BF4, Rust, Ark and even Minion Masters work just fine.

Kind regards,

Op 30 sep. 2019 om 08:18 heeft rctpavuk <amd-external@jiveon.com<mailto:amd-external@jiveon.com>> het volgende geschreven:

Community <https://community.amd.com/?et=watches.email.thread>

Re: rx 5700 stutter

in Graphics

0 Likes
civillian1
Adept II

Re: rx 5700 stutter

did you manage to fix this?

i'm still having the stutters and i have no idea what else i can do to fix it

0 Likes
rctpavuk
Journeyman III

Re: rx 5700 stutter

reboot into safe mode, ddu the driver (do it twice)

then clean driver install to latest version

configure enhanced sync to disable,freesync on, set chill min/max fps to (your max refresh -1)

that’s what fixed it for me

0 Likes