cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

costantito
Journeyman III

RX 5700 gives no signal trough HDMI, but works on DP

As said in the tile, i get no signal from the hdmi port of my RX 5700.

I bought it from amazon warehouse around 1 month ago, it worked fine until a few days ago when suddently my hdmi port stopped working.

My rig is: i7 8700K, 16 GBb of ram, RX 5700 from Asus TUF (the one with the shitty cooler) , 250 GB NvME.

My monitor configuaration is like this: A 4k 60Hz monitor as main connected trough DisplayPort, a 1080P one as secondary monitor connected trough HDMI.

Lately come back using the VR headset (Oculus Rift), therefor i needed a HDMI port, so every time i needed to use the vr, i unplugged the secondary display and plugged in the Rift. There were no problems until some days ago when i plugged in my secondary monitor and nothing appeared on the screen. I restarted and nothing happened, thinking was the monitor the problem i hooked it up to my laptop and it worked, i tried going to linux (Manjaro) where my gpu works fine, no signal on the hdmi port.

At the moment i tried:

- 3 different monitor with every one a no signal resoult.

- Many different cables, tested on other pcs that works.

- I checked it there were any dus or something else in the hdmi port, but didnt find anything.

- Cleaning (with DDU) the drivers and reintalling them.

- Switching PCI lane.

- Installing the gpu in another totally differen rig.

- Probably many other things that im forgetting.

What im going to try:

- Completely reinstall Windows and the drivers as well

3 times the hdmi port accuately gave a signal:

The resolution was 800x600 and i wasnt able to change it from the windows setting, only by creating a custom resolution on the AMD Radeon Software of 1920x1080 and settign it manually, i also had a strange artifact: a blurred bar on the left side of the monitor,

but as soon as i restarted the pc i lost the signal and the settings.

This clearly is not a relaible option beacuse the signal is giver onece every 100 times i connected the screen.

I didnt found any fix googling, only a thread on the AMD forum talking about this:

https://community.amd.com/thread/243267

I am thinking of returning the gpu and buyng a RX 5700 XT but i would rather mutch more making this one work.

Edit:

Post update:

I found a way to make my gpu see my screen for a split second by connecting the display trough hdmi and turning it on while connected

Here a video as explanation: https://www.youtube.com/watch?v=oUropbW3l0s

I also found a way to keep the monitor from disappearing. if i click on the "Display 2" box i nthe radeon software fast enough the display dosent disappear at times.

The first time it happened the resolution was 640x480, i wasn't able to change it from the windows settings, so i added a custom resolution fo 1920x1080 (the native monitor resolution) trough the radeon software and the monitor accepted it right away, the image was crips and sharp.

Video as reference: https://www.youtube.com/watch?v=ej5ScFctxUE&t=

Even if this method works requires some attempts and obviously it dosent work with vr headset.

It means that my ports works fine tho!

Link to my reddit post on r/buildapc: https://www.reddit.com/r/buildapc/comments/fk7oq9/my_new_rx_5700_has_no_hdmi_signal/ 

5 Replies
saberslash12345
Adept I

Re: RX 5700 gives no signal trough HDMI, but works on DP

Hello,

I experience exactly the same issue as you, only with XFX 5700 XT model. 

I never had any signal through HDMI port, will try your "split second" solution with second monitor and will let you know the results. I do not use HDMI at all, so If I find that my HDMI is not hardware faulty but only has problems like yours, maybe it will relax my OCD feeling and I wont RMA card.

Also one more question, will it work if you try only 1 monitor on HDMI? And did it work in the beginning without problems on hdmi? 

Thank you, update soon to come

0 Likes
saberslash12345
Adept I

Re: RX 5700 gives no signal trough HDMI, but works on DP

Tried your approach, not getting that "split second" recogniton of second display via hdmi

0 Likes
CoolSaet
Journeyman III

Re: RX 5700 gives no signal trough HDMI, but works on DP

I have the same problem. Also not working with a second screen on hdmi, but recoginition for a split second.

0 Likes
LeyvinBeta
Adept I

Re: RX 5700 gives no signal trough HDMI, but works on DP

A Make-Shift Fix is to create a Custom Resolution / Timings for the HDMI Display.

I recently had this issue with my RX 5700 XT., as I'd been having an issue that whenever the Display (Smart TV) went into Screensaver Mode; it would result in a loss of image on the TV.

Now as a note, the Drivers / Windows would still CLAIM they were outputting fine; and even the Smart TV would report that HDMI was connected and working fine but obviously a black screen as no image was actually being output / received.

Ultimately what I ended up doing was resetting the Smart TV to Factory Default., this reset the Timing Tables and the image returned... but there was another Monitor TV that I had, which also had said issue that I couldn't do that for as it had no option.
What I had to do for that was create a Custom Resolution (Manual Timings) and this resolved the issue there.

What I find most interesting, is even switching to a DP-to-HDMI Converter (Active in my case., as my Display is UHD 4K) the problem persists. In essence what seems to be happening is a Sleep Signal seems to get stuck "On" for a given display. 

I'd say this is a Driver issue, but as it persists even during Boot... well it makes me think that something is happening with the Display Timings Table; like Metadata is getting stuck "On", but as I said a Custom Resolution / Timing will resolve it; and I'm certain it's because it Omits / Resets all Metadata. 

0 Likes
michaelzfreeman
Journeyman III

Re: RX 5700 gives no signal trough HDMI, but works on DP

Got the same thing. I created a custom resolution. Still no HDMI signal but (HDMI is active because devices handshake) so I deleted the custom resolution. THEN suddenly there was a full HDMI signal. Looks like this has to be reported as a bug to AMD if it has not been already.

AMD R9 380, Windows 10, Asus Z97P MB
0 Likes