cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

osdevon
Adept II

RX 5700 Constant BSOD + other issues

Since I put together my new build about a week ago, I have had nothing but problems.

My setup includes the reference Sapphire RX 5700, a R5 3600, and the Gigabyte Aorus X570 Elite.

My monitor is a LG 32QK500-W.

This is on a fresh installation of Windows 10 Home, with all available BIOS and Firmware updates installed.

First, with 19.7.5 I was running into consistent Video TDR Failure BSODs citing Atikmpag.sys, and the occasional Page Fault.

In addition to the crashes, WattMan has been completely unavailable, with all options and the graph being completely blank.

When I wasn't crashing, most of my browser use was completely unstable, with images, sound, and video consistently stalling and disappearing, and my Windows notifications being filled with "Firefox has been blocked from accessing the GPU".

I then discovered that disabling Enhanced Sync caused all video streams, whether YouTube, Netflix, Hulu, etc in 1080 or above causing the GPU video decoding to spike to 100%, dragging the entire system down to a crawl until lowered in quality or closed.

Update to 19.8.1 the other afternoon, along with yet another fresh installation of Windows 10, and in the short time before fiddling with some other settings, I encountered only 1 TDR Failure crash, when logging back in from sleep mode.

After some time, I read in the forums that LG monitor owners running at 75hz have been running into some issues matching mine, and so to see how it would affect me, I lowered to 60hz.

With that, I no longer run into TDR failures, or maxed video decoding with enhanced sync disabled. In addition, WattMan appears to be fully operable, and I have even been able to make use of the Auto (X) options with some improvement!
Unfortunately, I am now running into more, different BSODs.

The most common seems to be the Page Fault in Non Paged Area, with Kernel Security Failure following in consistency. There is also a third that has only happened twice, and I can't remember just what it was.

In-game performance tends to be fantastic at best, and at worst running at one fourth of what it should be for no apparent reason. Sometimes just rebooting seems to fix this issue temporarily.

I have run extensive 3DMark benches, and get wildly varying results each time.

TL;DR, are these Drivers just terrible, or is it time for a RMA?

1 Solution
Matt_AMD
Community Manager

The issue described in the OP should be resolved by updating to the latest driver here > https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-... 

View solution in original post

171 Replies

My issues did go away. 

Now, lucky me, I have this new one. 

I've reported it and talked with AMD about it. 

The drivers are trying to access memory they do not have access to. The fix they offered was too disable the cache on my CPU... Which is an obvious no. 

I'm not gimping my system to stabilize their drivers. 

shinkojiro
Miniboss

Been using 19.9.2 since it released with HW accel and Enhanced sync. No BSOD's or system crashes thus far. Been watching Youtube movies left and right.

0 Likes
fedup5700
Journeyman III

Having most of the issues on my xfx 5700 xt thicc ultra.

Tried most of described "fixes" and nothing works for me...

Bought it through Amazon so probably will return it soon as my patience will run out.

Ryzen 7 1700 (stock clocks)

16gb Corsair Vengeance @ 2400

MSI B350 Gaming Plus (with latest BIOS)

EVGA 750 GQ 80+ Gold

and of course xfx 5700 xt thicc ultra...

Previously having EVGA GTX 970 decided to jump the ship and try AMD, probably the worst move I did.

Can't play any games, Just Cause 4 sometimes work ( mostly crashes after 10 - 30 min but once managed to play for 2h+ without issues) but other than that nothing else do. 

Forza Horizon 4 going in to the main menu and when loading race crashing and going straight to desktop, sometimes crashes on first MS video. Managed only once run benchmark which run for 2 minutes, during that time everything performed well giving on average 146fps in 1080p Ultra.

Videos in YT crashing drivers and having black screen (monitor goes off but pc stays on)

After replacing GTX had a complete disaster with BSOD all the time even when starting windows (critical process died)

Reinstalled windows including all drivers from AMD and at lest now not having BSOD but all other options didn't worked for me.

Tried most of versions of drivers including 19.9.2 same thing happening.

Anything else I could try or just get rid of this disaster card and stick with team green?

Paying over £420 for something that doesn't work is bit too much, also support from AMD is bit a disaster, fixes that are not fixing much and drivers being released every 2 to 3 weeks? complete joke.

 

 

0 Likes
phlogios
Adept II

My issues were initially fixed by not installing the HDMI audio driver, but now I have issues with BSOD when computer wakes up from sleep, INTERNAL POWER ERROR
Also, when I boot the computer, it reboots automatically *once* before reaching the login view, every time. After the reboot, I can log in and play games.

0 Likes

Just disable the sleep

0 Likes
Matt_AMD
Community Manager

The issue described in the OP should be resolved by updating to the latest driver here > https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-... 

dirthurt
Adept III

I found a potential fix for my issue. 24hrs with no bsod but still testing. 

Using a gigabyte ga ab 350 gaming revision 3, turns out there is a compatibility chipset driver that allows ryzen 3000 series to work properly. Noticed there was a pci device that was not recognized under device manager, security/encryption device. This cleared up that issue and at least and seems to have stabilized the system. This driver is not part of the AMD driver chipset suite that comes with the video cards. 

Will report back. 

Another 24 hours and no crashes. Looking good. 

0 Likes
ubaied93
Adept II

Still having issue running LoL in multiplayer. black screen / radeon setting crash intermittent. the most annoying thing now is radeon setting keep crash, and have to open task manager, kill it, and rerun it back. all this happen at stock ( no oc at all ) cant be bothered to oc it and my 3600 anymore.

ubaied93
Adept II

2700mhz.png

GPU running @ 2700mhz, doing nothing sitting at desktop with no game open at all. lol. this is insane. And no this is not any aib 3rd party cooler .this is reference bois

0 Likes

I would suggest rebuilding your PC from scratch with new parts...

0 Likes

Cpu : new
mobo : new
psu : new
gpu : new
the only thing thing that is not new is the nvme's and hdd which cant really be the culprit =.= and yes i have fresh installed the o.s multiple time and install driver step2bystep accordingly. lol. Looking for cheap gpu atm for use, just thinking a perfect day to send it rma..or sell it cause dont want to see it anymore 

0 Likes

That's a lot of hardware. No way to pin it in the GPU just yet. 

1. Check for bios update. 

2. Turn off any overclock. 

3. Set xmp profile if not. 

4. Install all motherboard drivers. Chipset, Ethernet, Bluetooth, audio, anything else the manufacturer has on their page.  

5. Remove ryzen master, other unnecessary software. 

6. Check hardware manager for unidentified hardware or errors. 

7. Look at Windows error logs for clues if that doesn't work. 

0 Likes

Actually all this problem has been occur to me ever since i the day i sold off my Vega 56 and GTX 1070ti, and im still running ryzen 2600 + msi b450i that time during the gpu switch. It happens the day after AMD unveil the 5700xt (i got mine 2 days before launch, but cannot use it at first because there were no driver can be download for 5700). Blaming drivers at first, dint we all waited 1-5 driver releases until now, still same issue? and yes it doesnt matter whether you or OC or dint OC at all. it will even occur while not doing anything at desktop, like me lol. windows log doesnt say much. only says unexpected shutdown/crash is BSOD/blackscreen. if its not worst case its just AMD radeon setting keep crash, have to rerun it back.

Maybe just first batch issue. But then I got a friend which has 5700xt Anniversary and his other friend which owns XFX Thiccboi also experiencing same problem. TLDR i spent more time checking and looking for issues instead of playing games and it drive me nuts already lol.

0 Likes

it looks like you didnt put ram new, but the mobo and cpu are new, and that you are bluescreening from the desktop doing nothing. if that is the case, check the mobos qvl and make sure the ram is on it. the exact model. if you bought a 4 dimm kit it needs to list the 4 dimm kit, and so on. if it isnt, what you are going to need to do is get the ryzen timings calculator and use it to discover the sub timings that are good for your ram, and manually enter them into bios. then you need to mem test with something like memtest86

if your ram kit is on the qvl or you have already done all that, then your ram needs to = new too. crashing from the desktop doing nothing isnt going to be on the gpu. I had to do this too to stop the random bsos because i decided not to buy ram on the qvl (tho i would have for performance tweaking anyway)

0 Likes

dont worry my ram is also in qvl list and yes i already memtest alot. Nvm my RTX is on the way to fix my issue while im gonna send this curse for rma lol, and maybe sell it soon after....rip navi. The only FIX i discovered last time on update 19.9.0-19.9.1 is to install driver only ,but skip Radeon setting. basically do not install the amd setting. If i install it that way no problem appear. But then its not a complete package already. cause my freesync is off, and cannot use radeon anti lag, i cant oc or undervolt or relive etc. Lets face it, im not the only one having problem here. There crap tons of 5700-5700xt topic other than this we currently in.

0 Likes

Oh good you went the new parts route. I think you should switch to an Intel CPU to seal the deal. I'd say the problems you and your 3 friends are facing are actually very rare, for the people without problems of any kind simply dont come here or anywhere else, save Overclock.net to show of their sweet performance. Meanwhile, many people here are reporting their problems gone with this new driver, some not returning at all because the problem is presumably fixed and they need say no more. Other issues, such as multi-monitor elevating memory speeds, aren't gamebreaking in the least. Not installing Radeon settings is not the answer, or even an answer, either. I've been running my 5700xt ani edition non-stop with no BSOD, when watching youtube vids with HW acceleration, since 19.9.2, and thats literally the only thing that gave me BSOD after I fixed my system Ram (which was a long time ago).

cachemem20.png

Most of the people with these problems that actually come to these forums looking for help and claim they built their PC either dont know how to really set up PC's or don't actually have the issue. For, what I notice while trying to help people is that they dont accept the help. I could write it off as they feel the attempts to fix the issue are too much work, but that would be too narrow minded of me. When someone just deflects to "nah, my RTX card is already on the way" and "RIP Navi" that tells me only one thing: Troll the whole time.

Not gonna lie tho, I'm not surprised Navi has some problems with really old games. AMD tends to not really support older API's like DX9 with its newer cards. The fake DX11 game, World of Tanks, which was ported horribly from DX9, doesnt like to display properly at resolutions other than your monitors native resolution for instance, so no 1080 for me. So, I'm not surprised someone who still likes to play those really old games is upset with how Navi treats them. Not all of them behave strangely tho.

But, 19.9.2 should have fixed anything it says it fixed. Did for me  I hope you RTX card brings you joy either way

0 Likes

I just returned my 5700xt to the store, and they ran several test with it in their test-rig. Benchmarks and games that would not run with the stock clock on my system, ran without issues on their system. They concluded that there is nothing wrong with the card and that there is a compatibility issue with something in my system.

Thankfully the store has awesome customer support and just gave me my money back. I bought an RTX card and it has been running without issues for several days. I still don't think AMD is bad, i just want to emphasize the importance of testing components in other systems before declaring them defective. Sometimes weird compatibility problems just occur, and manufacturers cannot test compatibility with every system configuration.

if everyone would just go for the crosshair mobo theys never have a single problem with incompatibility. at least, ive never run into the problem of a gpu or related software just not working at stock because if something else in my system. id say thats a relatively rare occurance.

0 Likes

No offence, but you sounded like mocking me like i first time build my pc. Dude im working in IT store as technician, and i've assemble, tested, upgrade etc more than thousand rig for customer every year even laptops repair. 

And if you have not followed this thread earlier,  i did mention early I have tested the card IN intel system. And there is no issue at all. And ALL this even done at non oc'ing at all. NOW everything is completely stock. And yeah EVEN before I upgraded to X570 and all new parts, this problem occur on me on my B450 rig (ram new during b450 era) this is day after 7th July, amd released 5700 and drivers, and i upgade crap tons of stuff around 2 weeks later due to my PSU from RMA no stock so they credited refund so i make a move upgrade everything.

Anyway Unless AMD themself come down here and can shed some like WHAT is actually wrong with their product, then i can stop typing here since release so many driver until now and reformating my stupid PC so many time doesnt cut it. clearly its like the 5700xt is not compatible at all on X570 or maybe even ryzen 3000. or these whole pcie 4.0 gimicky.

Not a fanboy or anything. I wish i can stay all AMD since ryzen 1st gen and RX 480 due to their value and performance to price ratio even if its 5% slower. I'm tired and i just one something that works. And why I chose RTX ? cause i have plug that damn thing in borrow from friend, and no issue on my x570. the end.


0 Likes

I was. You admit that the GPU works in a different system, that would mean there is nothing wrong with the GPU. you also admit when you listed your components that several things could be the culprit, primarily a 1yr old ram kit and 3yr old nvme SSD.

Have you tried just replacing those two items? Did you change your PSU too?

0 Likes
dirthurt
Adept III

Honestly, it really doesn't sound like it's your graphics card. It's obviously something else causing the issue if the card works in another system fine. 

GPU incompatibility really isn't a thing these days, especially keeping it within the AMD platform. 

0 Likes
phlogios
Adept II

There is definitely something wrong with this GPU or its driver even if it works on some computers.

0 Likes

SOME computers have different drives they are installed to, and those can go bad as well. if it works on one computer using the same version of windows, you need to look at other system components.

For example, why would it be a bad 5700xt for one person running x570, windows 10 1903 or better, and a ryzen 3000 processor, and another person with those exact things in common have 0 issues? its another component in the system.

But, I get it. despite these admissions of the HPU working in a different system with no issues, you WANT this to be the gpu and amd's fault. Been a common frame of mind for many years.

0 Likes

Lets try not to make things personal from any perspective. So many variables can cause issues sometimes it's impossible to pin point an issue in some cases. For instance why does an old AMD work on the same board and the new one doesn't? Why does the green team new card work then? But you take that same card and try it on another machine and it works? Many times it is as simple as whatever motherboard you have likely needed a bios update to work properly and unfortunately sometime the makers never release a new bios. The micro code is out there, other makers did it, AMD made it but the OEM didn't implement it or may you just don't know to update it. Luckily I know from experience that this stuff happens and to be very wary. I just bought a Ryzen 3600 and paired it with an MSI Tomahawk B450 board. I purposely chose this board because of the reported quality of the board and the success rate being high of it working. I did not choose the Gigabyte board as many are still complaining they are not working. By now Gigabyte should have it working but apparently for some they don't. I also used all my old parts from a previous computer other than MB, Ram and CPU. None of this is the end users fault. It certainly isn't fault either to be ignorant of a situation. That is why people come here to hopefully get educated. I know that most people by the time they even get here are usually pretty aggravated at a situation. To me when I try to help and the OP is then not appreciative or worse I just stop helping. Their is no doubt that the the new Navi cards are suffering from some pretty big growing pains, Vega did (and still does IMHO) suffer the same. Polaris when you figure out the tweaks for your card is pretty darn solid IMHO. The truth of the matter with all this is that most end users are not very knowledgeable and they should not have to be either. AMD should be doing a better job of policing the products they are ultimately involved in selling. Unfortunately so much of their stuff is seen as value product so many shortcuts are taken by OEM's that add to instability and they still slap that AMD sticker on the box so AMD can take the blame from all. Now the issues with Navi reference cards well that's on AMD. I am glad to see they have been steadily fixing many of the issues but you don't have to look any further than the known issues in the driver notes or the countless posts in these forums to know there are real issues.

What I've been saying the whole time is there are many variables can make it seem like one component is bad, but its not. If someone is seasoned enough to take the thing out, put it in another PC, and observe it working flawlessly then they need to simply stop trying to pin it all on the GPU. That is why my first suggestion was to start over with new parts. Could be the ssd, could be the psu, could be the ram, could be the board, but its obviously not the GPU if it works just fine in a different system. After confirming something like that, still saying its the GPU is flat out arrogant. And quite frankly, there is no way to help that type of person after stupid crap like "RIP Navi, i'm going to RTX" after the first one. Even when those famed RTX had space invaders and BSOD's that they launched. I wont take people who start that crap seriously as if they have an actual problem they want solved. NOTHING has been flawless for all when it launched.

If we are going to be discussing the brand of GPU, I would have been saying stay far away from Gigabyte models for their history of crapping out in some way for both AMD and Nvidia, and MSI models because their CEO hates AMD, and now XFX models since they wanna be stupid with the Thicc.

There are some issues with Navi cards, but none are really THIS bad that haven't been a priority fixed. and again, the GPU is NOT going to cause BSOD from the desktop doing nothing. People with that problem need to give way more info as to what is starting with windows and such. Because I had that problem too when I first built this system, and solved it by fixing my RAM timings. Some will claim "I already did that and mem tested" but, I dont believe them, sorry. I don't believe that people have done everything just because they say theyve done everything. Theres so many people that will create new accounts in an opponents forums just to moan about things I wont take anything said for face value. Especially bad on Reddit.

So yea, my response to those guys remains to just go to intel/nvidia once again as they already want to do. Not like you cant find this same crap on their respective forums...

0 Likes

No problem I get that, but as they say you can lead a horse to water but you can't make them drink. If someone doesn't get it then they don't get it. But the truth is it may not be anything wrong with any of that stuff that should reasonably have to be fixed. To for instance if that person buys say an RTX 2060 super and it works fine then how does one explain why does it work and the AMD card does not. The only logical conclusion is that the AMD card requires some level of compatibility the other does not.  We already for instance have people having to turn of PCIE 4 on these cards and force ver 3 compatibility for stability. All kinds of things can be wrong none of it makes it the end users fault, or their equipment, unless proven it is an issue, and then you are lucky because you figured it out. At the end of the day AMD has the responsibility for these parts to work out of the box at default setting if you meet the posted specified requirements. There is no doubt that in many cases this expectation is falling short. There is also no doubts that in many cases those minimum specifications are not met. There is also no doubt that other drivers are hardware not being up to date as it should is a contributing factor.

0 Likes

Something I still cant outright believe. Not in the current world. I'll write it off as operator error.

0 Likes

You can write it off however you see fit. That is your right. Just be careful how you convey that to another user. Just because you are sure you are right doesn't mean you are. I have been in IT for over 40 years and have been sure I was right many times and have learned I can always still be wrong.

dirthurt
Adept III

How do you reason that? If it works on another computer, it works. 

What issue are you seeing exactly? 

0 Likes
shomynik
Adept I

I had vega 56 nitro for a year (INTEL system) with the multi monitor problem (I was active in one of these threads - a known issue with HBM memory they fixed with radeon vii). All that time using some painfull workaround, I was hoping it will be fixed via drivers (never did as it was a hw design error) only to RMA it (with the full refund - amazon germany rocks!) a couple of weeks ago when I saw some new navi desings that suit me. Went rx 5700 xt route thinking there was enough time for drivers to be ironed out, only to encounter an amazingly unstable performance (BSODs) and forums full of ppl complaining (trolls? not sure, I haven't seen that many with vegas). Although, when was working in-game it was showing some fantastic power. Tried every single thing (except os reinstalling) ppl sudgested here and other places with no success.

I returned the card the 3rd day in - my system is a music production machine with tons of installed software that work flawlessly, so reinstalling OS was out of question. Put the vega 56 back in, everything worked as it should again (with a workaround for the hbm issue ofc). Ordered rtx 2060 super, installed it, no issues (except multi mon setup was pushing some very high clocks by default - fixed with the set and forget utility), runing 2 weeks now with no problems.

I hate all the time I lost troubleshooting vega and now navi, I'm not paid to beta test their products and fix their errors - I make video game music for living and I need a powerfull gpu in my system, but stabillity is priority for me which AMD unfortunatelly doesnt deliver. But fortunately, NVIDIA does. After this exp, I also stopped thinking about Ryzen...

I get what you are saying. Even my Polaris card needs "tweeks" to run right. That should not happen. A card should work at default settings IMHO. Tweaking is usually for those trying to get that stable overclock not to just get it to run period. I will say and I only have one week under my belt with my Ryzen 5 3600 on my MSI B450. Each of the releases of Ryzen have had board stability issues too. That being said they did get those pretty much worked out quickly and I would bent the new 570 boards will be the same. I don't think these issues have been any worse than new boards on the Intel side as long as you stick with ATX boards. Where I see some disparity on the AMD side is in the micro and itx boards. There seems to be more boards of questionable quality. So you really want to research the board you but. I however would not be scared of going Ryzen for a processor choice, especially if you have a heave threaded work load. Plus AMD doesn't have the security issues in their hyper threading either.

osdevon
Adept II

Two Month Update

0 Likes
blindpanic
Adept III

I am still getting a wide variety of BSODs, everytime I think I've solved it I get a new one. The latest is

ntkrnlmp.exe causing 'TIMER OR DPC INVALID'. 


0 Likes
ubaied93
Adept II

I've found the fix. I sold the navi to someone else and replace with rtx. 2 weeks already. No issue. K bye.

Which i think is the culprit? Its the pcie 4.0. my motherboard unable to chg pcie bandwith. So i tried with thermaltake riser cable premium. Still running at 4.0 even though the cable is 3.0. then it makes my pc unable to boot and no display. I i out my newly.bought rtx and install back navi everything became normal back. Pcie 4.0 is not ready yet

shinkojiro
Miniboss

Still not a single bluescreen since 19.9.2.

19.9.3 fixed more issues, didn't cause any new ones.

19.10.1 fixed more issues. Can use HDR properly now, wherever applicable. Enabled on windows and adjusted brightness, will see if it wiggs out. This one, however, has an installation error. doesnt seem to have effected anything but will keep using to see if anything happens. Actually i think this error is because of the windows insider build I'm using. 1903 Build 18995.

The only major issue remaining IMO is with radeon relive. Its not 5700 series specific however. Its popup overlays and recording/streaming timer causes instabilities and lead to driver crashes. For example, Alt-tabbing out a full screen game immediatle after taking a screenshot (when the notification popup is active) or while streaming or recording with relive will immediately crash the drivers. Driver crash can occur with apps like vlc too with relive popup notificatios when activating an app hotkey as well. the resulting overlays combined with relive overlays leads to driver crash often. Already reported using the software reporting site.

Your insider theory is probably a sound one. AMD is very clear that NONE of their drivers support insider builds. Glad it is working for you though. That is great news. Thanks for the feedback!

0 Likes
brunoalves20015
Adept III

I followed amd's instructions regarding ram memory frequency, and apparently stabilized and GPU usage is normal and performance is good.

I haven't had BSODS in this day after this change.

Below are the instructions from AMD:


Dear Bruno,

Thank you for contacting AMD Support.

We are sorry that you have encountered problems with your RX 5700XT. I will be happy to help.

What is the manufacturer of your board? Note that most problems that occur with this card have incorrect installation or configuration, or system incompatibility. For example, many users use the PCI (riser) extension cable, which in most cases is not currently used with PCI-e 4 and after removing the card works perfectly. Keep what you are connecting to the direct card on the motherboard without any extender cable.

Another problem that identifies is an incompatibility of the old 300 or 400 series motherboards or their configurations with this very new board. For example, many users reported troubleshooting or changing a PCI-e mode option in the Generation 3 Auto Motherboard BIOS. Suggest consulting the motherboard manual and testing this option and also contacting the motherboard manufacturer. to confirm if there is any additional configuration that should be done.

Also note that the maximum memory speed supported by the Ryzen 1700X processor is 2667MHz, so if using 3200Mhz memory, this is not processor compatible and may cause system instability. Using memory above 2667MHz is considered overclocking and not supported. Keep in mind that memory is set below the processor limit.

Also save if your RAM is included in the motherboard compatibility list (QVL). This list is usually found on any motherboard manual, mailbox, or website. Memories for a list that are not used and can cause various problems. Consult the motherboard manufacturer if in doubt.

And to ensure there are no problems with driver installation and your system is installed correctly, I recommend performing a clean install by following the steps below:

UPDATE SYSTEM
- Verify that the motherboard BIOS and chipset drivers are up to date. Consult the motherboard manual or manufacturer if in doubt.
- Check if your Windows has the latest updates installed.

START A CLEAN INSTALLATION
Follow the instructions on this page to use the uninstaller AMD to remove previous drivers and ensure a correct installation:
- www.amd.com/cleanuninstall

INSTALL DRIVER MANUALLY
Download and install the latest driver version. https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-rx-5700-xt

If it doesn't solve your problem, please send us the DxDiag report from your computer so we can investigate:

GET DXDIAG
Press the Windows key + R
Type "dxdiag" in the dialog box and press "Enter"
Click on "Save all information".
Save the file and send us attached.

Please also inform us the motherboard model as well as the BIOS version. Please also send us the RAM power supply model, including its part number.

If you have any further questions, please feel free to contact us again.

Regards,

Kyle

AMD Global Customer Service

0 Likes

Followed the below instructions about driver installation, or did something with RAM settings?

So what advice differed from what you had? What did you change?