cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Journeyman III
Journeyman III

RX 5700 - can only get 4k on Basic Display Adapter

Turned my PC on today (R5 3600, RX 5700, 16GB RAM, 1TB M.2 SSD, LG 4k/60 monitor) and the highest resolution I can get is 1600x900.

I updated to the latest Adrenalin 20.1.2 but this didn't help (I was on a 19.12.x). Started troubleshooting and noticed that if I uninstall Adrenalin and default back to MS Basic Display Adapter I can get 4k without a problem. Also, my boot screen is in high 4k resolution. It drops to 900p once I get to W10.

Other things I've tried:

- Tried installing the bare driver without Radeon Settings, no 4k

- Tried installing earlier Adrenalin versions (19.11.3 and 19.8.1), no 4k

- Tried uninstalling every driver with AMD Cleanup Utility and reinstalling Adrenalin, no 4k

- Tried uninstalling my LG ULTRA HD driver, no 4k

My GPU is a PowerColor 5700 (non-blower). Not really sure if this is a driver issue or a GPU issue.

Help!

0 Kudos