cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Adept I
Adept I

RX 570 Screen static, glitching, lines, audio popping

I have an Asus 570 4GB with an AMD 1600 on the ASRock B-450 Pro board.

Nothing is overclocked all stock.

When I have my GPU connected to either digital output, as in the HDMI or the display port, to my 4k TCL TV the audio will start popping, the screen will blackout, drop, go to static, come back, then back to static. Lines will appear off and on throughout the screen. 

I plugged in my laptop (GTX 1050) to the same cables and it works fine at 4k @ 60 hz HDR off so I know it isn't a cable issue.

I uninstalled the latest driver (19.7.2) and reverted back to 17.7.2 and it seems to be more stable.  I booted into safe mode, disabled windows updating drivers, ran DDU, rebooted, installed the old drivers (did the same for the new just to test, no difference.)  It was glitchy still at first until I reseated the cable, now it seems fine for 20-30 minutes.

Is there something I am missing in the 19.7.2 (really any 19.x driver) that could be causing this? I never turn on HDR as it looks funny when I do.  This is all to a TCL 4k 49" TV.

1 Reply
Highlighted
Journeyman III
Journeyman III

Re: RX 570 Screen static, glitching, lines, audio popping

I too have a TCL 50 inch 4K and have the same problem. Randomly gives me the finger and goes straight static with popping noises. Checked that it was properly seated with no luck. Please let me know if you solved it. People always say it’s dying but how could it be if it’s literally not even 4 months old and it always runs cool. Let me know my man.

0 Kudos