cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

mvalburg
Journeyman III
Journeyman III

RX 570 Safe Mode OK, Windows 10 won’t boot

New Sapphire rx 570, fresh build as below:

ASRock B450 Steel Legend

AMD Ryzen 5 3600.  (No internal GPU)

32GB RAM   

Western Digital NVMe M.2 boot disk

Windows 10

On first boot, BIOS booted fine, blue Windows screen w/rotating circle led to ... black.  MB still powered on, but rx 570 shut down...won’t finish booting into regular Windows 10

Boots fine into Safe Mode; installing GPU driver in Safe Mode leads to “unsigned certificate” error 99.  Deactivated unsigned certificate enforcement in the list after Troubleshoot Advanced restart, but since it won’t boot into regular Windows 10, booting into Safe Mode undoes the deactivation of unsigned cert enforce, so driver still won’t install.

Build boots and operates fine with an Nvidia 1080 installed in the same - main - PCIe slot - after RMA’ing the rx570.  Reinstalling the replacement rx570 repeats the above.

I have removed all traces of prior drivers using DDU, still won’t install in Safe Mode and still won’t boot into regular Windows 10.  Will run in Safe Mode as long as I want; I’m assuming that means the PS is OK (?).

Any ideas?  I’m right at the edge of my knowledge, so I’d really appreciate some much smarter help ;>)

0 Kudos
4 Replies
elstaci
Esteemed Contributor III

Re: RX 570 Safe Mode OK, Windows 10 won’t boot

Is the replacement RX570 the same one you had before or is the serial number different. Just asking in case they "repaired" your original RX570 and send it back to you.

Which BIOS version do you have installed on your motherboard? The latest or did you upgrade it when you got the motherboard? if so which previous BIOS did you have installed?

Here is the latest BIOS for your motherboard from ASRock Support: ASRock > B450 Steel Legend 

It is very important that you FIRST installed the ASRock CHIP Set if you upgraded your BIOS from before version 2.63B.

By any chance, do you have the RX570 GPU Power cable connected from the PSU to the GPU card? If it isn't connected it won't work correctly or not at all.

mvalburg
Journeyman III
Journeyman III

Re: RX 570 Safe Mode OK, Windows 10 won’t boot

Thanks for the suggestions!

Different card, not the same one re=sent.

Old BIOS: 2.60

New BIOS current 2.80

I'm not able to complete driver installation with either the old or the new BIOS:  the screen goes blank 40-50% of the way through installation either way.  I've uninstalled all old remnants of drivers (few, it's a new build) using DDU (before every attempt).  I've done the installation with internet access disconnected, and with antivirus off.  I ran DDU in safe mode.  DDU did allow the new card to run on the built-in Windows 10 driver (basic), but any attempt to install the driver for the rx 570 has the above result.

Oh, and I upgraded the BIOS with an old Nvidia card installed:  doing it with the rx-570 installed requires installing the All-In-One prior to updating the BIOS, which isn't possible with the rx-570 installed, for the reasons listed above:  it goes black.

Any other insight?

0 Kudos
prosam
Journeyman III
Journeyman III

Re: RX 570 Safe Mode OK, Windows 10 won’t boot

Did you fix your rx 570 black screen?

0 Kudos
prosam
Journeyman III
Journeyman III

Re: RX 570 Safe Mode OK, Windows 10 won’t boot

I have also same problem... Anyome who fix this issue?

0 Kudos