Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Rx 570 not installing/reading

CPU: i5 3570k

Ram: 16gb ddr4 (2x8gb)

GPU: Dell OEM reference RX 570 4gb

Motherboard: Gigabyte ga-z77x-d3h (UEFI and Legacy dual bios currently)

PSU: Seasonic g650w

OS: Windows 10 pro 64bit

I was using the following set up with my old card GTX 960 2gb for the last 2 years. My friend no longer needed his RX 570 (he used for 1 year on his Dell inspiron prebuilt ) so he gave it to me. *It was working fine without any problems for his set up.

I put it in PCI-e 16x slot and 6 pin connector using HDMI to DVI-D cable on my 1920x1080p 60hz Dell LED monitor.

First try it would Post and fans spinning but with 1 long beep and 2 short beeps (beep code says its something due to GPU), so I searched on google and so tried the following solutions:

1. Took out all the cables from pc, psu and wall.

2. Restarted cmos battery (took it out for 8-10min)

3. Switching Ram sticks.

Upon doing the following solutions, beeps were gone!! But still remains no signal.

so I connected my old VGA cables to motherboard and integrated intel HD 4000 worked fine. I checked the bios and it was on UEFI and Legacy mode<--dual bios?), but didn't touch anything in bios cause lack of knowledge.

and then I've tried using DDU to uninstall all previous Nvidia drivers.

still no signal. GPU-z shows Intel HD 4000 when RX 570 is slotted in, but I haven't tried manually disabling HD 4000 (I think it disables automatically when new gpu is installed? correct me if I'm wrong..)

yeah, so confusion confusion... I need suggestions and solutions guys and girls. Any help will be appreciated!

0 Replies