cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Journeyman III
Journeyman III

RX 5500 XT with an older motherboard

Hi,

while trying to refresh an older desktop I put an RX 5500 XT card into a PC with an Asus P7P55D-E motherboard and my machine stopped booting. It shows the BIOS splash screen, then the screen turns black and the booting process halts completely, with no activity from disks.

However, when I put an older nvidia card into the primary PCI slot and the RX 5500 into the secondary, the system starts normally. The RX 5500 is then recognized by the OS as the secondary device and I am able to connect my monitor to it. Some software refuses to work with such setup though.

Is there a way to make my system boot with the RX 5500 as the only card?

The motherboard has the most recent available BIOS version installed.

4 Replies
Highlighted
Big Boss
Big Boss

Re: RX 5500 XT with an older motherboard

Your MB may need a bios update to support it. The navi cards are the first PCIe 4.0 cards and while it is supposed to be backward compatible it may be introducing a hiccup causing the issue. Report the issue to your motherboard makers support department and see if they have advice. 

You can ask AMD support here: https://www.amd.com/en/support/contact-email-form 

Also while you don't have any newer bios to load. Did you make sure you are running the latest chipset driver for your board?

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: RX 5500 XT with an older motherboard

I'll probably contact the manufacturer of my motherboard, but seeing as the model is now around ten years old and the latest BIOS update is only slightly newer, I don't expect much to come out of that.

But! I managed to configure my system to push all the workload through the RX 5500 and it works beautifully. Even the software that previously had issues now just works. The old nvidia is now only needed to trick the motherboard into starting up and for the time being I'm pretty okay with such setup.

0 Kudos
Highlighted
Big Boss
Big Boss

Re: RX 5500 XT with an older motherboard

I do wonder if you situation is similar to another thread. The person has a 5600 and says they see not bios screen or post with this card in their machine. Theirs is a much newer x570 board but maybe something with the navi bios is having a hiccup. 

Id definitely talk to the GPU maker support department too for advice. 

The other thread: https://community.amd.com/thread/257779 

0 Kudos
Highlighted
Grandmaster
Grandmaster

Re: RX 5500 XT with an older motherboard

If you can enter the BIOS screen, you should be able to re-install the Windows. What version of Windows do you have? And have you tried installing Windows again? A new hardware you just added might prevent the Windows OS from booting. Is that the problem? Or is the problem that the motherboard cannot select the boot devices? Can you describe exactly what the problem is?

0 Kudos